Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-03-2016, 03:11 AM   #151
Forum Member




Join Date: Aug 2016
Location: Pyrenées Atlantiques
Posts: 55
Hello ,

It would be intresting to know the serial number of each to see if it is all the K1 or only a batch impacted ...

09-03-2016, 03:41 AM   #152
Site Supporter




Join Date: Mar 2013
Posts: 14
6356175
09-03-2016, 03:47 AM   #153
Loyal Site Supporter




Join Date: Jun 2012
Location: South Coast, NSW
Posts: 257
6356979
09-03-2016, 09:26 AM   #154
New Member




Join Date: Aug 2012
Posts: 5
Here's a bit of follow up on my original post about the failed mode dial on my K1. It had been bought as a 'like new' item from The Camera Exchange. They have been the good part of this experience, taking the camera back and even paying my return postage from Canada. They are keeping my original payment as part payment on a new K1 which should be available in October. .....October? The apparent lack of availability suggests that there is a BIG problem that is in the process of getting a 'fix'. This is a huge stumble for Pentax. It's been, not only committed Pentax users like us, but the larger photographic community that's waited to see a FF Pentax offering. Everyone's waited, what, a decade and a half? As said earlier in this thread by another member, this is the first time I've been letdown by a Pentax product. Having had it in hand shooting, the K1 is a terrific camera design. However, the follow through to reliable final product seems to be rubbish. Here's keeping my fingers crossed that October will see a 'fixed' K1 built to the usual Pentax quality standard.

09-03-2016, 11:15 AM   #155
Forum Member




Join Date: Aug 2016
Location: Pyrenées Atlantiques
Posts: 55
Any more serial n° ?

Mine is 6368730 and every thing is ok ritgh now
09-04-2016, 05:50 AM   #156
Site Supporter




Join Date: Mar 2013
Posts: 14
QuoteOriginally posted by Eric64800 Quote
Any more serial n° ?

Mine is 6368730 and every thing is ok ritgh now
Your serial number is 12,000 more than mine, perhaps they fixed it on later production and you wont have the problem
09-04-2016, 06:27 AM - 1 Like   #157
Loyal Site Supporter
monochrome's Avatar

Join Date: Mar 2008
Location: Kirkwood (St. Louis) MO
Photos: Gallery | Albums
Posts: 20,057
QuoteOriginally posted by squarenegs Quote
Here's a bit of follow up on my original post about the failed mode dial on my K1. It had been bought as a 'like new' item from The Camera Exchange. They have been the good part of this experience, taking the camera back and even paying my return postage from Canada. They are keeping my original payment as part payment on a new K1 which should be available in October. .....October? The apparent lack of availability suggests that there is a BIG problem that is in the process of getting a 'fix'. This is a huge stumble for Pentax. It's been, not only committed Pentax users like us, but the larger photographic community that's waited to see a FF Pentax offering. Everyone's waited, what, a decade and a half? As said earlier in this thread by another member, this is the first time I've been letdown by a Pentax product. Having had it in hand shooting, the K1 is a terrific camera design. However, the follow through to reliable final product seems to be rubbish. Here's keeping my fingers crossed that October will see a 'fixed' K1 built to the usual Pentax quality standard.
There is no BIG problem. K-1's are in short supply globally due to lack of sensors available from Sony. Sony's sensor plant was damaged in 2 earthquakes and shut down twice (for more than 2 months total). Pentax started receiving sensors again second week of August - many of the first week's sensor deliveries were rejected as "trash" according to asahi man.

K-1 only recently returned to full production.

Last edited by monochrome; 09-04-2016 at 08:09 AM.
09-05-2016, 03:52 AM   #158
New Member




Join Date: May 2011
Location: Kansas City, MO
Posts: 4
K-1 failure to manual mode operation

My K-1 failed last week during a vacation to Alaska. The mode dial has been locked for the most part since the body was received May 9th. I have been pressing the center button to facilitate dial changes. The camera body had about 1200 actuations at the time of failure.
I have purchased and still own a K-x, K-5 and Pentax Q over the years and this is the first problem I have ever had with Pentax equipment. Unfortunately, I had none of these other bodies with me on my trip. I was still able to use the K-1 in manual mode for the most part, except for photographing the northern lights we caught in Fairbanks. I could not get the camera shutter to actuate when pointed at the faint light displays. Fortunately, my wife was able to capture the display with her cell phone camera and all was not lost. The camera's serial number is 6359271.

Update: Received call from Precision Camera on 9/12/16, camera received, but the part needed for the repair is out of stock, expected to be received 9/27/16.

Update 10/4/16: 9/27/16 came and went with no change in my camera's status when checked online. A query sent to Precision Camera's customer service resulted in a new estimate of parts arrival on 10/14/2016. Their explanation is that original parts are needed for the repair and they are working with Ricoh to acquire the parts from overseas. The parts have been back ordered.

Update 10/20/16: Part did not arrive once again. Called and spoke to customer service at Precision and they have no idea when Ricoh will ship the needed part. I left a message at Ricoh Customer Service website asking for help in the matter and will give them a couple of days to respond before calling.

Update 10/27/16: Part arrived and camera is being repaired.

Update 11/3/16: Repair completed 11/2/2016, camera is in the process of being shipped back.


Last edited by Terrencio; 11-03-2016 at 02:10 PM. Reason: update 11/3/16
09-07-2016, 11:27 PM - 2 Likes   #159
Loyal Site Supporter
redpit's Avatar

Join Date: Aug 2013
Location: Athens
Photos: Gallery | Albums
Posts: 674
Yesterday I got my K-1 back from the service and it works flawlessly! I spoke with the serviceman and he explained me that Pentax has changed the mode selector base with a new one (the new spare part has different code) as there was a contact problem with the original one (I don't know in which initial batches). The fix is very easy and I got my camera back the next day. I'm glad I shoot with no restrictions again!

SN: 6355971

Last edited by redpit; 09-08-2016 at 12:37 AM.
09-08-2016, 12:33 AM - 1 Like   #160
Forum Member




Join Date: Aug 2016
Location: Pyrenées Atlantiques
Posts: 55
Thank you for your report
09-08-2016, 01:16 AM - 1 Like   #161
Loyal Site Supporter
redpit's Avatar

Join Date: Aug 2013
Location: Athens
Photos: Gallery | Albums
Posts: 674
QuoteOriginally posted by Eric64800 Quote
Thank you for your report
You're welcome! One of the great things about PF is that connection and feedback from all over the planet We have learnt a lot first hand from real users and not from reviewers or people who use Pentax equipment occasionally... I'm waiting for the goods news from other K-1 users also and I'm keeping an eye on other issues that may arise but most importantly the beautiful K-1 photos that are being uploaded!
09-13-2016, 08:17 PM   #162
Loyal Site Supporter




Join Date: Jun 2012
Location: South Coast, NSW
Posts: 257
Mine arrived back today and it is working fine again - so pleased to have it home where it belongs.

That was excellent turnaround from CRKennedy - 8 days including a weekend and postage time at both ends.
09-13-2016, 10:59 PM   #163
Pentaxian
Jonathan Mac's Avatar

Join Date: Apr 2009
Location: Madrid, Spain
Posts: 4,156
Obviously this should be repaired for free.

I don't have a K-1 but the only part of my K-3 which is clearly fragile is the mode dial, and my guess would be that the K-1 dial is based on the same design. I've taken great care with it from the beginning as it worries me.
09-14-2016, 12:34 AM   #164
Loyal Site Supporter
UncleVanya's Avatar

Join Date: Jul 2014
Photos: Gallery | Albums
Posts: 9,752
QuoteOriginally posted by Jonathan Mac Quote
Obviously this should be repaired for free.

I don't have a K-1 but the only part of my K-3 which is clearly fragile is the mode dial, and my guess would be that the K-1 dial is based on the same design. I've taken great care with it from the beginning as it worries me.
??????
What on earth makes you feel that the k-3 mode dial is fragile? I would think reports of failures would have poured in as they did with the k-1... Crickets...
09-14-2016, 02:31 AM   #165
Loyal Site Supporter




Join Date: Jun 2012
Location: South Coast, NSW
Posts: 257
QuoteOriginally posted by Jonathan Mac Quote
Obviously this should be repaired for free.

I don't have a K-1 but the only part of my K-3 which is clearly fragile is the mode dial, and my guess would be that the K-1 dial is based on the same design. I've taken great care with it from the beginning as it worries me.
I have two K-3s and both of them have been absolutely fine...very robust in fact. One fell into an icy, fast flowing, boulder strewn river (with me and tripod attached) and after drying out is still going strong a couple of years later. I have taken them both into very rough conditions with no ill effects at all. From my experience, there's absolutely nothing that's fragile about the K-3, and I don't think there was ever a problem with the mode dial.

The K-1 mode dial problem is a known issue and Pentax has fixed it - I expect the mode dial will now last as long as the camera does. I certainly won't be giving it the kid glove treatment!
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
body, camera, failure, fuji, involved, issue, issues, k1, k1 mode, lot, mass, offer, pentax, pentax forum, pentax help, people, photography, pm, post, program, repair, ricoh, shooter, time, troubleshooting, weeks
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
purchase mode dial? pixelvandal Pentax K-01 21 1 Day Ago 07:41 PM
K1 stuck in manual mode ukspeedtraps Pentax K-1 50 10-05-2016 12:41 AM
Mode dial not working properly? wralyn Troubleshooting and Beginner Help 3 11-21-2015 02:32 AM
Mode dial right vs. left hjoseph7 Pentax DSLR Discussion 24 02-17-2015 08:35 PM
Mode Dial Problem nrh771 Troubleshooting and Beginner Help 5 11-03-2014 02:44 AM



All times are GMT -7. The time now is 05:52 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top