Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-14-2016, 10:42 AM   #166
Forum Member




Join Date: Aug 2016
Location: Pyrenées Atlantiques
Posts: 54
Hi ,

Are you sure Pentax has fixed it ?

09-14-2016, 11:10 AM   #167
Site Supporter




Join Date: Jul 2011
Photos: Gallery | Albums
Posts: 809
QuoteOriginally posted by Rayand Quote
Your serial number is 12,000 more than mine, perhaps they fixed it on later production and you wont have the problem

Mine is not a pre-order, I ordered right after the first pre-orders started rolling in, and they shipped mine when the next large batch that almost caught everyone up in the USA came in.
Mine is in the 6369xxx batch, so far so good... and I don't baby it... I don't beat on it either. It's a dial, and it gets used per norm.
Eric
09-14-2016, 11:30 AM - 1 Like   #168
Loyal Site Supporter
redpit's Avatar

Join Date: Aug 2013
Location: Athens
Photos: Gallery | Albums
Posts: 658
QuoteOriginally posted by Eric64800 Quote
Hi ,

Are you sure Pentax has fixed it ?
I'm one of those unlucky ones, but I have not lost my trust in Pentax! When you are an early adopter you have more chances to be the real tester as well...

Mine works fine and the service guy told me confidently "Don't worry Pentax cameras don't break!"

Last edited by redpit; 09-15-2016 at 03:33 AM.
09-14-2016, 11:58 AM   #169
Loyal Site Supporter
UncleVanya's Avatar

Join Date: Jul 2014
Photos: Gallery | Albums
Posts: 9,737
QuoteOriginally posted by redpit Quote
Yesterday I got my K-1 back from the service and it works flawlessly! I spoke with the serviceman and he explained me that Pentax has changed the mode selector base with a new one (the new spare part has different code) as there was a contact problem with the original one (I don't know in which initial batches). The fix is very easy and I got my camera back the next day. I'm glad I shoot with no restrictions again!

SN: 6355971
QuoteOriginally posted by Eric64800 Quote
Hi ,

Are you sure Pentax has fixed it ?
See above. If the spare part code number has changed that's a good indicator that this is resolved with a new part. However it is unclear which serial numbers might be assembled with the older part. My guess is that it's a bit of a crap shoot for now.

09-14-2016, 10:08 PM   #170
Pentaxian
Jonathan Mac's Avatar

Join Date: Apr 2009
Location: Madrid, Spain
Posts: 4,100
QuoteOriginally posted by UncleVanya Quote
??????
What on earth makes you feel that the k-3 mode dial is fragile? I would think reports of failures would have poured in as they did with the k-1... Crickets...
QuoteOriginally posted by snpsht Quote
I have two K-3s and both of them have been absolutely fine...very robust in fact. One fell into an icy, fast flowing, boulder strewn river (with me and tripod attached) and after drying out is still going strong a couple of years later. I have taken them both into very rough conditions with no ill effects at all. From my experience, there's absolutely nothing that's fragile about the K-3, and I don't think there was ever a problem with the mode dial.

The K-1 mode dial problem is a known issue and Pentax has fixed it - I expect the mode dial will now last as long as the camera does. I certainly won't be giving it the kid glove treatment!
While I haven't had any problems, it's clear from handling the K3 that the mode dial is not built as strongly as the rest of the camera.
09-14-2016, 10:58 PM   #171
Loyal Site Supporter
UncleVanya's Avatar

Join Date: Jul 2014
Photos: Gallery | Albums
Posts: 9,737
QuoteOriginally posted by Jonathan Mac Quote
While I haven't had any problems, it's clear from handling the K3 that the mode dial is not built as strongly as the rest of the camera.
I just don't get that impression. The depth of field preview, the pop up flash, the memory card door... These seem weaker.
09-16-2016, 06:25 PM   #172
Junior Member




Join Date: Feb 2009
Location: Vietnam
Posts: 45
QuoteOriginally posted by Eric64800 Quote
Hi ,

Are you sure Pentax has fixed it ?
Not so sure, we are one of the first country received the K-1 and seem more than 20% of them included mine have the same problem with M-Mode. Lucky that it's all under warranty so we have to wait for a few days/weeks to get it repaired. Anyway, we can borrow the lower version like K-5, K-3 to use when the K-1 is not around.
09-22-2016, 12:08 PM   #173
Site Supporter
x-country's Avatar

Join Date: Dec 2009
Location: Frösön (Östersund)
Posts: 51
Hi, it has happened to me also. I will visit my local dealer on monday. Serialnumber is 6354403.

09-23-2016, 01:14 AM   #174
Forum Member




Join Date: Aug 2016
Location: Pyrenées Atlantiques
Posts: 54
Thank you for your report , again 635 serie ...
09-30-2016, 09:51 PM   #175
Pentaxian




Join Date: Jul 2011
Location: Eastern Oregon
Posts: 614
As a member of both Canon Professional Services and Nikon Professional Services (30 years as a pro will do that...) I can tell you that you have to be a pretty heavy hitter to really need either service. For the casual freelancer (like myself) the expedited repairs are about the most useful thing. But you do pay a premium for shipping for that, so it's not free. And you do have to pre-authorize a certain amount on your CC for the rush service in case it's not a warranty repair.


I am not too worried about using a K-1 professionally, though, because for the price of 1 Canon 5D4 I can have 2 K-1's (+$100) and 2 K-1's is a faster repair than rush service on 1 5D4.
11-19-2016, 04:31 AM   #176
New Member




Join Date: May 2014
Location: Athens
Photos: Gallery
Posts: 1
635xxxx user.. Same problem . I've just sent email to Ricoh Greece. Bought it 4/2016
11-21-2016, 10:45 AM   #177
Forum Member




Join Date: Oct 2016
Posts: 56
The dreaded mode dial stuck in M happened last week. It wouldn’t select anything but ‘M’.

The serial number in the 6356xxx range.

Body sent back to Pentax UK for warranty repair.

They replaced the mode dial assembly, put on 1.40 firmware and did a check/test.

The body was with them for two days and is now back with me.

Very impressed by their speedy repair/return.
11-21-2016, 11:45 AM   #178
Pentaxian
LFLee's Avatar

Join Date: Aug 2009
Location: Western MA
Photos: Gallery | Albums
Posts: 2,258
just saw a guy complaint about this failed mode dial in FB before I browse PF. Looks like a common issue.
- white dots in long exposures; (fix with latest firmware update)
- failed mode dial.

I guess so far only two problems? not bad!
11-27-2016, 03:52 PM   #179
Site Supporter




Join Date: Aug 2012
Location: California
Posts: 275
Just want to add to the statistics one more data point: My K-1's mode dial just failed few days ago.
The dial is stuck in "M" mode and won't select anything else. The camera belongs to the first batch
shipped by B&H. My serial number is in the range 6359xxx.

I'm going to contact Ricoh Pentax and send the camera back for repair. I hope it won't take them
several weeks to get it fixed....
12-09-2016, 10:32 AM   #180
Site Supporter




Join Date: Aug 2012
Location: California
Posts: 275
Got an update from Precision Camera about my K-1 mode dial failure repair.
Repair is on hold, waiting for parts. Guess I probably won't have my K-1 back until Jan or Feb 2017...Christ Lord
Attached Images
 
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
body, camera, failure, fuji, involved, issue, issues, k1, k1 mode, lot, mass, offer, pentax, pentax forum, pentax help, people, photography, pm, post, program, repair, ricoh, shooter, time, troubleshooting, weeks
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K1 stuck in manual mode ukspeedtraps Pentax K-1 50 10-05-2016 12:41 AM
purchase mode dial? pixelvandal Pentax K-01 20 06-25-2016 06:48 AM
Mode dial not working properly? wralyn Troubleshooting and Beginner Help 3 11-21-2015 02:32 AM
Mode dial right vs. left hjoseph7 Pentax DSLR Discussion 24 02-17-2015 08:35 PM
Mode Dial Problem nrh771 Troubleshooting and Beginner Help 5 11-03-2014 02:44 AM



All times are GMT -7. The time now is 03:41 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top