Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-25-2017, 12:06 AM   #196
New Member




Join Date: Oct 2010
Location: Geneva
Posts: 19
Mode dial - hardware failure

It is a hardware failure. Exerting a slight lateral pressure on the dial knob would change the settings sporadically. I had to send my K-1 for repairs after having used it for about one year.

08-28-2017, 03:26 PM   #197
Pentaxian
Nick Siebers's Avatar

Join Date: Jun 2008
Location: Madison, WI
Photos: Gallery | Albums
Posts: 2,158
This appears to have happened to my K-3, now just over 2 years old. Not sure what to do with it. Ugh.
09-01-2017, 08:43 AM   #198
Site Supporter
Site Supporter
blackcloudbrew's Avatar

Join Date: Mar 2009
Location: Cotati, California USA
Photos: Gallery | Albums
Posts: 3,903
Have the same problem, the serial of my K-1 - 6361763. So, it appears right in there for this problem.
09-01-2017, 10:12 AM   #199
Site Supporter
Site Supporter




Join Date: Jul 2011
Photos: Gallery | Albums
Posts: 1,700
QuoteOriginally posted by blackcloudbrew Quote
Have the same problem, the serial of my K-1 - 6361763. So, it appears right in there for this problem.
Ugh! Sorry man. And... you guys are making me nervous, you are creeping up dangerously close into my 6369xxx range. Starting to make me wonder where the cutoff point is?

Hope I don't find out personally, especially after my warranty expires. I got the LEAF 3Yr extended from Adorama, hope I don't have to test it out, but if it's going to fail, I hope it does before that one runs out too...

Eric

09-01-2017, 12:16 PM   #200
Senior Member




Join Date: Feb 2012
Posts: 174
Mine, which still is in repair, has a serial number starting with 63544...
I got it near the end of April 2016.
10-24-2017, 10:23 PM   #201
Loyal Site Supporter
Loyal Site Supporter




Join Date: Mar 2008
Location: Glendale, CA
Photos: Gallery | Albums
Posts: 84
I have the mode dial problem. Got it this past weekend during a workshop. Have shutter priority, manual, and bulb. A reset didnít address issue. Will be contacting Precision Camera tomorrow. SN is 6359274.
10-24-2017, 11:14 PM   #202
Loyal Site Supporter
Loyal Site Supporter
redpit's Avatar

Join Date: Aug 2013
Location: Athens
Photos: Gallery | Albums
Posts: 986
There is no reason to worry, since the repair is very simple (it takes a few minutes to replace the whole mode dial selector with a new slightly redesigned one) and it works flawlessly ever after. I haven't heard of anyone having problems after the repair, it seems that Pentax has addressed the issue (a batch of problematic mode dial selectors probably).
10-28-2017, 03:32 PM   #203
New Member




Join Date: Feb 2015
Posts: 24
This is the first I heard of this. My serial number is 63952XX should I call Precision Camera? I keep rotating the dial but I don't have any problems.

10-29-2017, 04:33 AM   #204
New Member




Join Date: Oct 2010
Location: Geneva
Posts: 19
Maybe les chance ?

QuoteOriginally posted by scottyb70 Quote
This is the first I heard of this. My serial number is 63952XX should I call Precision Camera? I keep rotating the dial but I don't have any problems.


I had the problem. Was repaired under guarantee earlier this year. Serial number 6362088. Made in Philippines.
Yours may be more recent, so less chance of having a defective camera.
11-01-2017, 11:23 AM   #205
Loyal Site Supporter
Loyal Site Supporter




Join Date: Mar 2008
Location: Glendale, CA
Photos: Gallery | Albums
Posts: 84
QuoteOriginally posted by redpit Quote
There is no reason to worry, since the repair is very simple (it takes a few minutes to replace the whole mode dial selector with a new slightly redesigned one) and it works flawlessly ever after. I haven't heard of anyone having problems after the repair, it seems that Pentax has addressed the issue (a batch of problematic mode dial selectors probably).
Good to know. Thanks.
11-06-2017, 11:14 PM   #206
Loyal Site Supporter
Loyal Site Supporter




Join Date: Mar 2008
Location: Glendale, CA
Photos: Gallery | Albums
Posts: 84
Sent my K-1 in on Tuesday, 10/31/17, UPS 2 day air for delivery on Thursday, 11/2/17. They accepted my extended warranty, repair was completed on Friday, 11/3/17 and was ready to ship same day, but didnít ship until today via UPS air overnight, Monday, 11/6/17. Delivery ETA is tomorrow, Tuesday, 11/7/17. Will update tomorrow if fixed.

Last edited by agkchang; 11-07-2017 at 05:12 AM.
11-07-2017, 07:45 AM   #207
Pentaxian




Join Date: Dec 2016
Posts: 1,156
Ricoh/Pentax should also identify the source of this problem and correct it. This is apparently a serious shortcoming in the K-1. When Pentax was still Pentax USA (out in Colorado I believe) they had their own very good repair service at their location. I had a problem fixed under warranty in no time flat. But that was when they were still a complete company, including their excellent medical optics, which were stripped off after being bought out by Hoya. Hopefully, in time, now under Ricoh, their service will again improve.
11-07-2017, 08:12 AM   #208
Site Supporter
Site Supporter




Join Date: Jul 2011
Photos: Gallery | Albums
Posts: 1,700
QuoteOriginally posted by mikesbike Quote
Ricoh/Pentax should also identify the source of this problem and correct it. This is apparently a serious shortcoming in the K-1. When Pentax was still Pentax USA (out in Colorado I believe) they had their own very good repair service at their location. I had a problem fixed under warranty in no time flat. But that was when they were still a complete company, including their excellent medical optics, which were stripped off after being bought out by Hoya. Hopefully, in time, now under Ricoh, their service will again improve.
Hi Mike -

Not sure if you have been following the whole thread or just read the latest post, but so far as we know, Ricoh service identified this problem a long time ago. It has only been experienced in a small batch of the early serial number K-1's, and the problem is resolved with later serial numbers, or after service installs the replacement part.

So far I have yet to see anyone report a problem outside the serial number range as reported so far, and no one has posted about a single repeat failure with the replacement mode dial after service. (Shhhhhush! Don't jynx it! heh heh ).

Eric
11-07-2017, 09:18 AM   #209
Loyal Site Supporter
Loyal Site Supporter
monochrome's Avatar

Join Date: Mar 2008
Location: Kirkwood (St. Louis) MO USA
Photos: Gallery | Albums
Posts: 22,859
QuoteOriginally posted by mikesbike Quote
Ricoh/Pentax should also identify the source of this problem and correct it. This is apparently a serious shortcoming in the K-1. When Pentax was still Pentax USA (out in Colorado I believe) they had their own very good repair service at their location. I had a problem fixed under warranty in no time flat. But that was when they were still a complete company, including their excellent medical optics, which were stripped off after being bought out by Hoya. Hopefully, in time, now under Ricoh, their service will again improve.
When did you have a repair done in Golden?
11-07-2017, 07:17 PM   #210
Loyal Site Supporter
Loyal Site Supporter




Join Date: Mar 2008
Location: Glendale, CA
Photos: Gallery | Albums
Posts: 84
Received my repaired K-1. Repair document that came back with my K-1 says they repaired the mode dial and associated items which I am translated as replaced. Works as expected. Documents also says they did a complete cleaning, internal and external; auto focus test, check, recalibration and realignment.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
body, camera, failure, fuji, involved, issue, issues, k1, k1 mode, lot, mass, offer, pentax, pentax forum, pentax help, people, photography, pm, post, program, repair, ricoh, shooter, time, troubleshooting, weeks
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
purchase mode dial? pixelvandal Pentax K-01 26 08-25-2018 12:09 PM
K1 stuck in manual mode ukspeedtraps Pentax K-1 50 10-05-2016 12:41 AM
Mode dial not working properly? wralyn Troubleshooting and Beginner Help 3 11-21-2015 02:32 AM
Mode dial right vs. left hjoseph7 Pentax DSLR Discussion 24 02-17-2015 08:35 PM
Mode Dial Problem nrh771 Troubleshooting and Beginner Help 5 11-03-2014 02:44 AM



All times are GMT -7. The time now is 07:05 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top