Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-01-2016, 07:22 AM   #121
Site Supporter
stubyles's Avatar

Join Date: Oct 2013
Photos: Gallery | Albums
Posts: 456
A five minute call to SRS Microsystems (My vendor) resulted in them arranging a collection, FOC to me, for tomorrow. They will then send it back to Pentax.
Impressed so far.

08-01-2016, 07:53 AM   #122
Pentaxian
les3547's Avatar

Join Date: Jun 2010
Location: Sebastopol, California
Photos: Albums
Posts: 1,849
Does anyone know if for the Mode Dial to fail, must it be used (turned) regularly? I ask because my camera stays on aperture priority all the time.
08-01-2016, 01:07 PM - 1 Like   #123
Site Supporter
stubyles's Avatar

Join Date: Oct 2013
Photos: Gallery | Albums
Posts: 456
QuoteOriginally posted by les3547 Quote
Does anyone know if for the Mode Dial to fail, must it be used (turned) regularly? I ask because my camera stays on aperture priority all the time.
Mine failed when I changed from AV to M after I put an M42 lens on.
I regularly change modes.
08-03-2016, 10:02 PM   #124
Senior Member
Mock's Avatar

Join Date: Feb 2009
Location: Edmonton
Photos: Gallery | Albums
Posts: 290
Wanted to post an update regarding my repair experience so far. It's not good.

I sent off my camera via the dealer on June 23rd, they sent it directly to Sun Camera as is standard for Canadian warranty service. July 13 I get an update stating the repair will be done under warranty and completed in 3 weeks (August 3). I'm leaving for vacation this weekend so I tried to make an arrangement two weeks ago to have the camera shipped back to me faster. When asked by my dealer whether this would be possible, Sun replied with this bombshell: THAT MY CAMERA IS BEING REPAIRED IN THE USA, and will not be completed until August 7.

This means they finish the job on the 7th presumably, ship the camera to Sun, wait forever for it to clear customs, wait for Sun to ship it back to my dealer. I figure it will be back the week of August 15th, nearly 2 months total.
When I read about the service Europeans and others get with the camera turned around in days, I feel very jealous.

Finally, why should I buy from a Canadian dealer if Ricoh is just going to have service done in the USA anyways? I could just as easily have purchased from B&H and avoided having my camera bounce all around the continent...

08-16-2016, 05:26 AM - 1 Like   #125
New Member




Join Date: Mar 2013
Posts: 13
QuoteOriginally posted by les3547 Quote
Does anyone know if for the Mode Dial to fail, must it be used (turned) regularly? I ask because my camera stays on aperture priority all the time.


Mine failed after 1200 actuations, it has gone back to SRS, I use my camera in aperture priority most of the time, for a while I was able to select between click stops and get it to function in TAv, but eventually it went to Manual only.
08-17-2016, 01:11 PM   #126
New Member




Join Date: Aug 2012
Posts: 5
Haute mode............

OK, here's another hand up. Yesterday, my K1 decided it's now a Manual mode only camera, after approx. 700 exposures. Mind you, a very nice needle-match body but not what I paid for. I turned it on and with the second exposure, having been moved from 'Av' to 'M' it went 'manual for ever'... no matter what the mode dial was set to. I've had problem Pentax lenses, but this is my only DSLR problem body since my first, an *istD. I am not happy!
08-17-2016, 01:20 PM   #127
Loyal Site Supporter
UncleVanya's Avatar

Join Date: Jul 2014
Photos: Gallery | Albums
Posts: 9,513
QuoteOriginally posted by squarenegs Quote
OK, here's another hand up. Yesterday, my K1 decided it's now a Manual mode only camera, after approx. 700 exposures. Mind you, a very nice needle-match body but not what I paid for. I turned it on and with the second exposure, having been moved from 'Av' to 'M' it went 'manual for ever'... no matter what the mode dial was set to. I've had problem Pentax lenses, but this is my only DSLR problem body since my first, an *istD. I am not happy!
This sucks. I'm glad it is not a complete failure - you can continue and finish what you are shooting but this is a dreadful pain. My one real question about this is what the long term reliability will be - when "fixed" if these work for a very long time without problems I think it is an annoying quirk... but if repeat failures rear up. That's going to suck.
08-17-2016, 01:56 PM   #128
Lens Buying Addict
monochrome's Avatar

Join Date: Mar 2008
Location: Kirkwood (St. Louis) MO
Photos: Gallery | Albums
Posts: 19,474
From previous threads - IIRC:
  • The ribbon connector for the Mode dial simply comes loose
  • It is a 3 minute fix, actual time spent
  • Parts are not required
  • Remaining time is Repair Center foofawraw (Precision)
  • It was suggested one assembler was poorly trained; # of cameras is limited
Fwiw. That's what I remember.

08-17-2016, 01:58 PM   #129
Loyal Site Supporter
UncleVanya's Avatar

Join Date: Jul 2014
Photos: Gallery | Albums
Posts: 9,513
QuoteOriginally posted by monochrome Quote
From previous threads - IIRC:
  • The ribbon connector for the Mode dial simply comes loose
  • It is a 3 minute fix, actual time spent
  • Parts are not required
  • Remaining time is Repair Center foofawraw (Precision)
  • It was suggested one assembler was poorly trained; # of cameras is limited
Fwiw. That's what I remember.
Here's hoping that's accurate and that the repair once made stays made.
08-17-2016, 06:12 PM   #130
Site Supporter




Join Date: Mar 2014
Photos: Gallery
Posts: 724
QuoteOriginally posted by UncleVanya Quote
Here's hoping that's accurate and that the repair once made stays made.
clean your hands and push it back into its socked
08-19-2016, 12:41 AM   #131
Site Supporter
Denali_Mark's Avatar

Join Date: Mar 2008
Location: Anchorage, AK
Photos: Gallery | Albums
Posts: 126
Two months into owning the K1 I developed a problem where the camera suddenly was unable to function with several lenses. For a time the camera worked with my newly purchased 24-70 f2.8 lens. Finally, the auto mode failed. The camera would autofocus but was unable to adjust aperture. I contact B&H which told me I needed to discuss with Ricoh- Pentax. Ricoh told me to contact Precision Camera in Connecticut - apparently the only service/repair provider now for Pentax products. I shopped the camera to Precision. They identified the problem as requiring a new mode dial assembly. They returned the camera to me in under a couple business weeks and well under the one-year warranty. The repair order said they had performed a complete repair and all functions were returned to factory spec. This repair included a new mode dial assembly, AF test, firmware download and cleaning. When I tested the camera today it was unable to function with my Sigma 50-500 mm lens (it had before the repair). There was no firmware update. The camera operated fine for a dozen shots or so with my Pentax 24-70 f2.8. Then when I switched to manual mode the dial used to adjust the aperture malfunctioned, cycling up and down apertures in a random manner. The mode dial assembly feels incredibly loose - it rotates very easily like it might twist off. It doesn't feel like it locks well onto the different shooting modes. I'm contacting Precision and Ricoh tomorrow. Really ashamed. The camera was a birthday gift purchased in time for a workshop this fall. First time I have felt really let down by a Pentax product.
08-19-2016, 01:14 AM   #132
Loyal Site Supporter
redpit's Avatar

Join Date: Aug 2013
Location: Athens
Photos: Gallery | Albums
Posts: 606
QuoteOriginally posted by monochrome Quote
From previous threads - IIRC:
  • The ribbon connector for the Mode dial simply comes loose
  • It is a 3 minute fix, actual time spent
  • Parts are not required
  • Remaining time is Repair Center foofawraw (Precision)
  • It was suggested one assembler was poorly trained; # of cameras is limited
Fwiw. That's what I remember.
I'm still waiting for my K-1 to be fixed. I'm calm because of the country I live in and the kind of services we are used to The official dealer (with whom I have great cooperation and I'm very satisfied) has informed the EU service department in France and they have sent him a small spare part needed for the repair. I don't know if it is the ribbon connector @monochrome mentions above, but the EU service department informed the dealer that it is a very easy repair that can be easily done by our service (although this will be their first such repair). Now we are waiting for the official repair service to open after summer vacation on Monday... That means I'm more or less 40 days with my K-1 stuck in M mode... If I were a pro photographer that wouldn't be accepted, I would already had looked for other options as everybody understands.

QuoteOriginally posted by Denali_Mark Quote
First time I have felt really let down by a Pentax product.
That are exactly my feelings and thoughts... I really hope everything turns out well and no further problems are encountered in the future, but first thing first, now I'm waiting for my mode dial repair and I will inform you about anything more I will learn and my experience.

For a friend that asked whether I was changing modes frequently, no is the answer. Most of the time it was on TAv mode and less time in M mode. But if it is to happen I think it will, you don't have to restrict your camera operation to prevent something from damaging. What's the point of not enjoying your camera?
08-19-2016, 02:49 AM   #133
Loyal Site Supporter




Join Date: Mar 2015
Photos: Gallery | Albums
Posts: 4,825
Is the failure always into M mode? Because if it is, it seems they have at least done their best to give us a "fail-functional" camera - I would rather be stuck in M than anything else, so long as everything else worked. That said, I shoot a lot with an MX and Spotmatic F, so I'm used to not having the luxuries.

Agree, though, that this is a pain in the @r$e, particularly with that account of Sun having to send it off to the US - that was a shocker! I had disappointment from Sun when they said the parts to repair my *istDL were no longer available, but I could not fault them on their communication.
08-19-2016, 03:35 AM   #134
Site Supporter
stubyles's Avatar

Join Date: Oct 2013
Photos: Gallery | Albums
Posts: 456
Got mine back yesterday 2 1/2 weeks after I sent it to SRS.
Repair document (from Johnsons Photopia Ltd) says that they:

Replaced the Mode Dial,
Repaired Mechanical Assembly,
Cleaned Viewfinder & CCD,
Updated FW,
Checked & Tested.

Everything seems ok.
08-19-2016, 04:03 AM   #135
New Member




Join Date: Mar 2013
Posts: 13
QuoteOriginally posted by stubyles Quote
Got mine back yesterday 2 1/2 weeks after I sent it to SRS.
Repair document (from Johnsons Photopia Ltd) says that they:

Replaced the Mode Dial,
Repaired Mechanical Assembly,
Cleaned Viewfinder & CCD,
Updated FW,
Checked & Tested.

Everything seems ok.
Interesting, they told me that they expected a two week turnaround when I took mine in last week.

If the mode dial was replaced it seems that it wasn't just a ribbon cable reseat that was needed, so those who had a quick fix must have had a different problem -??

Lincoln Steampunk event next holiday weekend so I hope mine appears in a similar time, or it's back to the K5 ii


Here's hoping it's the only early adopter pain we suffer, as the wait for FF was just too much, and I succumbed to the temptation!
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
body, camera, failure, fuji, involved, issue, issues, k1, k1 mode, lot, mass, offer, pentax, pentax forum, pentax help, people, photography, pm, post, program, repair, ricoh, shooter, time, troubleshooting, weeks
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K1 stuck in manual mode ukspeedtraps Pentax K-1 50 10-05-2016 12:41 AM
purchase mode dial? pixelvandal Pentax K-01 20 06-25-2016 06:48 AM
Mode dial not working properly? wralyn Troubleshooting and Beginner Help 3 11-21-2015 02:32 AM
Mode dial right vs. left hjoseph7 Pentax DSLR Discussion 24 02-17-2015 08:35 PM
Mode Dial Problem nrh771 Troubleshooting and Beginner Help 5 11-03-2014 02:44 AM



All times are GMT -7. The time now is 11:44 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top