Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-08-2016, 09:56 PM   #1
New Member
popsy86's Avatar

Join Date: Jun 2016
Posts: 1
Pentax Espio 838 Shutter Won't Fire/Won't Shoot

Hi everyone.

Want to ask something. Lately I inherited a 35mm Pentax Espio 838 from my uncle. Really excited to try them soon. Today i just test it, and attach an used CR123A battery from my other camera to it. And then i found the shutter won't fire or shoot even when the back cover closed. But it seems a display to count the film seems working, it display film count, and displaying an indicator when this button pressed: flash mode indicator, red eye, and self-timer. The date display also showing a date (it's outdated though). And also the zooming work well, it moving when I pulled the lever. The thing is, I tested it without a film roll.

The question:
1. Does the shutter only firing when the film roll attach?
2. If it isn't, does the low battery affect the shutter not firing (though the zoom working)?

Please i need guidance. Thanks in advance

Attached Images
 
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
auto focus, battery, camera, count, date, display, espio, espio 838 shutter, film, pentax, pentax 35mm, pentax espio, pentax espio 838, pentax help, photography, point & shoot, roll, shutter, shutter behavior, troubleshooting, zoom
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Film advance (end) but shutter button won't fire rbfigueira Pentax Film SLR Discussion 3 07-24-2014 05:57 AM
Pentax ME Super Shutter Won't Fire haqeem18 Troubleshooting and Beginner Help 10 02-11-2014 09:13 AM
Shutter won't fire anselesn Troubleshooting and Beginner Help 5 07-20-2013 04:30 PM
mz-7 shutter won't fire jefflichty Pentax Film SLR Discussion 2 12-28-2009 05:12 AM
Help!! 67 Shutter won't fire. Swift1 Pentax Medium Format 5 10-05-2009 01:05 PM



All times are GMT -7. The time now is 02:39 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top