Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-27-2016, 05:25 PM   #1
Pentaxian
eccs19's Avatar

Join Date: Jul 2008
Location: Lisle, Ontario
Photos: Gallery
Posts: 1,461
DNG and LR CC

Just updated to LR CC. In LR5, I had no issues with DNG files. First go of importing some test shots in CC (DNG format), and a few of the thumbnails were corrupted looking. I was able to edit them and export, but just thumbnail was messed up. I switched the K-1 to PEF, and shot off a bunch of images, and they all seemed OK. Anyone else experience this? I should note, the card I used was a brand new Lexar Pro II card. It's possible the card is bad, but I would think if the file was actually corrupted, then I wouldn't have been able to even edit the photo.

06-27-2016, 06:37 PM   #2
Site Supporter




Join Date: May 2016
Location: New Hampshire
Posts: 89
I use Lightroom CC with DNG files from my K-1 without issue. Sounds like something weird happened when building the previews. I don't know if there's a direct way to force LR to rebuild the previews but you could generate the 1:1 versions and then delete them, that would probably force it to redo the regular previews.
06-27-2016, 06:45 PM   #3
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Oregon
Photos: Gallery | Albums
Posts: 10,618
Library>Previews>build standard previews (or 1:1)

I would try rebuilding the previews first, and I would format that card in camera at first opportunity.

I have had no issues with DNG on LR CC, through several versions and on K-5IIs, K-3, K-3II and K-1.
06-27-2016, 06:59 PM   #4
Pentaxian
Oldbayrunner's Avatar

Join Date: Mar 2013
Location: Havre de Grace, MD
Posts: 1,225
Do you have the most recent lr update from Adobe creative cloud?

06-27-2016, 10:05 PM   #5
Site Supporter
shiner's Avatar

Join Date: Jan 2009
Location: N GA USA
Photos: Gallery | Albums
Posts: 1,402
No issues with DNG in LR CC here, either.
06-28-2016, 03:36 AM   #6
Pentaxian
eccs19's Avatar

Join Date: Jul 2008
Location: Lisle, Ontario
Photos: Gallery
Posts: 1,461
Original Poster
Thanks for all the input. It should be the latest version of CC,as it's a fresh install. I always format the cards before using in camera. It's a new computer, so I guess potentially it could also be an issue with the card reader. Hopefully I'll get it figured out.
07-30-2016, 10:48 AM   #7
Site Supporter
dakight's Avatar

Join Date: Sep 2014
Location: Phoenix, AZ
Photos: Albums
Posts: 1,165
I ran across a different issue with Lightroom. I have the CC version and I keep it updated regularly. This morning I took a few shots with my K-1 in the front yard and switched lenses a couple times. One time I managed to move the mode dial to U5 (I have no idea how, but it's locked now.) Subsequent images were recorded in PEF Format. When I imported, Lightroom would read and import the DNG files with no problem but it refused to import the PEF files. I used the DCU software to convert the images to DNG and they came in fine. I thought that Lightroom supported PEF files but it sure choked on these. Is there something I'm missing?
07-30-2016, 01:23 PM   #8
Pentaxian
eccs19's Avatar

Join Date: Jul 2008
Location: Lisle, Ontario
Photos: Gallery
Posts: 1,461
Original Poster
QuoteOriginally posted by dakight Quote
I ran across a different issue with Lightroom. I have the CC version and I keep it updated regularly. This morning I took a few shots with my K-1 in the front yard and switched lenses a couple times. One time I managed to move the mode dial to U5 (I have no idea how, but it's locked now.) Subsequent images were recorded in PEF Format. When I imported, Lightroom would read and import the DNG files with no problem but it refused to import the PEF files. I used the DCU software to convert the images to DNG and they came in fine. I thought that Lightroom supported PEF files but it sure choked on these. Is there something I'm missing?
I'm one version behind on LR CC and have no issues with importing PEF files. Not sure what would have happened in your case.

07-31-2016, 05:58 AM   #9
Moderator PEG Judges
Kerrowdown's Avatar

Join Date: Aug 2008
Location: Highlands of Scotland.
Photos: Gallery
Posts: 31,796
All good here, no issues at all.
07-31-2016, 07:29 AM   #10
Site Supporter
dakight's Avatar

Join Date: Sep 2014
Location: Phoenix, AZ
Photos: Albums
Posts: 1,165
I guess I will have to experiment to get to the bottom of it.


I suppose it could have something to do with my work flow. I don't often use the import dialog. Instead, I copy the files into the desired location on the disk then I synchronize the folder in Lightroom to import any new folders and files. I have been using this method for about a year and it has worked without a hitch until now.


I read somewhere that PEF files have an auxiliary file to hold the EXIF data. I wonder if that has anything to do with it. If those are hidden files they might not be copied with the main ones. I really have no idea and it's more of a theoretical question since I don't ordinarily use PEF format.

---------- Post added 07-31-16 at 08:02 AM ----------

Well. I just went back read the entire thread and now I know that auxiliary files or lack of, is not the problem. They are only used in certain specific cases and they are not created by the camera so that cannot be the cause of my problem. It will probably remain a mystery.

---------- Post added 07-31-16 at 08:28 AM ----------

And finally, I just went back, after updating Lightroom I synchronized the folder and the 5 PEF files that refused to import yesterday came right in this morning. I give up; I'll probably never know why and it will probably never happen again.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, card, cc, dng, dng and lr, files, folder, import, lightroom, lr, pef, pentax help, photography, post, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pixel Shift in LR CC? enoeske Pentax K-1 58 05-24-2016 11:14 AM
PEF vs DNG in LR for K3 Spodeworld Pentax K-3 10 11-27-2014 12:22 AM
Premiere CC and K5 issues Lance C Video and Pentax HDSLRs 10 08-27-2014 08:10 AM
WB issue in LR 5 with K-3 DNG Azzy Pentax K-3 21 12-16-2013 04:51 PM
Help in Understanding DNG Processing in LR 2.6 KettererE Digital Processing, Software, and Printing 4 01-21-2010 12:35 PM



All times are GMT -7. The time now is 03:41 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top