Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-11-2016, 01:15 PM   #1
New Member




Join Date: Dec 2010
Location: Kentucky
Photos: Albums
Posts: 6
K-r and Sigma 17-50 zoom lens.

I have used my K-r for several years with a Sigma 17-50mm F2.8 EX DC OS HSM lens with no trouble.

Recently, however, I noticed a "rattling" sound and a shaking of the image in the viewfinder when I attached the lens, turned the camera on, and used the zoom ring to zoom in. At two points in the zoom range, this would happen.

With the camera turned off, the lens did not rattle, nor did the image through the viewfinder shake when turning the zoom ring.

I looked into the front of the lens while doing this, and saw the smaller, middle lens element(s) which move back and forth during zooming also moving from side to side while zooming with the camera in the on position... which explains why I see and hear what I do.

What might cause this?

No other lens does it!

Is there possibly an issue with the electronic communication between the camera body and this particular lens?

Thanks,

Mike


07-11-2016, 01:21 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,944
If you have the older version of this lens with in-lens OS, that's likely to blame. The OS could be failing.

Try disabling the OS using the switch on the lens, as it's redundant given the K-r's in-body stabilization. In fact, if you have both on at the same time, it could induce blur.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

07-11-2016, 07:11 PM   #3
New Member




Join Date: Dec 2010
Location: Kentucky
Photos: Albums
Posts: 6
Original Poster
Adam,

In fact, I have tried disabling the OS with that switch on the side...to no avail. I also tried disabling the K-r's stabilization, too...STILL have this problem. (Hmmmm.... Did I disable both of them? I'll have to check that, too...)

I might add that all but one of the two to three dozen photos I shot using the camera / lens combination turned out to be in focus, after this problem showed up a few days ago! As long as I let the lens' image-shakiness stop, the picture was fine...

I need to try this lens on another Pentax camera or two to see what happens!

Thanks!
07-11-2016, 07:18 PM   #4
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,944
Then it sounds like the lens might be in need of service. Let us know what you find out!


Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

07-11-2016, 11:09 PM   #5
New Member




Join Date: Jul 2012
Posts: 12
Definitely a problem with the OS. I had the same symptoms with my Sigma 17-70 version ii. Cause was the flex cable to the OS unit was starting to split which caused the OS system to go haywire at two points in the zoom range. I was told the only solution was to replace the OS unit -- switching it off doesn't help as it still draws power to lock the moving element in place.
07-12-2016, 05:22 AM   #6
New Member




Join Date: Dec 2010
Location: Kentucky
Photos: Albums
Posts: 6
Original Poster
QuoteOriginally posted by Suzhouren Quote
"caused the OS system to go haywire at two points in the zoom range."
BINGO! That's exactly what I'm seeing.... There are two points in my lens' zoom range at which this happens, too!

Interestingly, if I turn the zoom ring very fast, it doesn't happen at all....

Since this lens is well out of warranty, where would I find a place to have it repaired (Sigma, U.S.A.?) and would it cost far less than a new lens?

Thanks...

Mike
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, image, k-r, k-r and sigma, lens, pentax help, photography, sigma, troubleshooting, viewfinder
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help me decide: Tamron 17-50, Pentax DA 16-45, or Sigma 17-50 for my K-01 yellowbrick Pentax SLR Lens Discussion 38 04-30-2016 07:26 AM
For Sale - Sold: K-5, Sigma 50-150/2.8, Sigma 10-20, Sigma 17-50/2.8 OS and extras JohsonChou Sold Items 9 10-28-2014 06:53 PM
For Sale - Sold: Sigma 17-50 and Sigma EX DG 50mm macro herp photos Sold Items 14 10-02-2014 07:04 AM
For Sale - Sold: Pentax K-m + 50-135 + F 100 macro + sigma 17-70 + 50-150 + tamron 17-50 + metz 50 AF blem49 Sold Items 11 07-26-2013 03:25 PM



All times are GMT -7. The time now is 12:16 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top