Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-22-2016, 03:47 AM   #1
New Member




Join Date: Apr 2016
Photos: Gallery
Posts: 2
K3 exposure not works in "Av, Tv, TAv, P" mode

I am newbie and this's the first time to post with my K3 problem:

Shutter speed, aperture, ISO lost ability when I set Av mode even Tv or TAV; and I had to set them manually.

I had tried using Av-Tv-TAV mode, pointing to other scene to shot and press 1/2 ...focus function works very good but camera had the same exposure value as last shot (in manual). So on.
On back display, at left top displays "M" even I set AV-TAv or Tv mode.

AF, green button work very good ...so I must press it every time for knowing (shutter speed, aperture, ISO) and set them in manual.

Things had done: updated latest firmware for K3, change other battery ...
Problem happened 3 days ago. Now I did only use K3 with MF mode

Anyone have experiences helping me or send camera to pentax technician.
Thank you very much.

07-22-2016, 04:33 AM   #2
Site Supporter




Join Date: Jun 2013
Location: Newcastle
Photos: Gallery | Albums
Posts: 1,443
Have you got Auto ISO on?
07-22-2016, 04:42 AM   #3
New Member




Join Date: Apr 2016
Photos: Gallery
Posts: 2
Original Poster
Hi Wild Mark
Yes. Normally, I set auto ISO from 100-3200
07-22-2016, 05:38 AM - 1 Like   #4
Site Supporter




Join Date: Jun 2013
Location: Newcastle
Photos: Gallery | Albums
Posts: 1,443
try taking Auto ISO off and see what happens.

07-22-2016, 06:55 AM - 1 Like   #5
Pentaxian
StephenHampshire's Avatar

Join Date: Oct 2009
Location: Winchester
Photos: Gallery | Albums
Posts: 1,060
Sounds like the camera is not reading the f-stop on the lens (hence Av, TAv and Tv modes not working) Try re-mounting the lens and cleaning the contacts- assuming you are using a modern F/DA lens or a manual lens with A on the aperture ring...
07-22-2016, 11:59 AM - 1 Like   #6
Senior Member




Join Date: Dec 2013
Location: Buffalo, NY
Posts: 207
QuoteOriginally posted by nguyenlong Quote
On back display, at left top displays "M" even I set AV-TAv or Tv mode.
I remember reading somewhere that if the mode select dial malfunctions the camera will default into M mode. It's probably a failsafe so you can have full control over your exposure settings even if you can't select a different mode. (Imagine if you were stuck in bulb mode! )

I'd suggest working your mode select dial back and forth to see if it starts working again. Maybe it somehow got some moisture or dust inside that's interfering with the contacts.

---------- Post added 07-22-16 at 03:06 PM ----------

If you still can't figure it out it may be time to look into repair services. In the meantime, practice using it in M mode to get more familiar.

When you half press the shutter the EV indicator in the viewfinder can help you get your shutter / aperture / ISO correct so you can still take pictures. I like using the EV indicator better than using the green button because I decide what to change, so it's more like Av, Tv, TAv modes than using the green button and hoping it can read your mind.

Last edited by TheOneAndOnlyJH; 07-22-2016 at 12:07 PM.
07-22-2016, 02:54 PM   #7
Site Supporter




Join Date: Jun 2013
Location: Newcastle
Photos: Gallery | Albums
Posts: 1,443
QuoteOriginally posted by TheOneAndOnlyJH Quote
Imagine if you were stuck in bulb mode! )

That is my reality for a K5 I own
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
button, camera, ev, exposure, indicator, iso, k3, k3 exposure, mode, pentax help, photography, press, shot, shutter, troubleshooting, tv
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
What Mode (AV, TV, M, P,..) Do You Generally Use While Sightseeing jackloganbill Pentax DSLR Discussion 65 12-30-2016 07:24 AM
Lost ability to use to SV, TV or TAV--mode dial only selects AV, M, X, Bulb rweissman Pentax Medium Format 11 07-18-2016 03:12 AM
"Click" in between "C" and "MF" mode on focus selector? K-50 maxwolfie Pentax K-30 & K-50 3 01-29-2015 04:19 AM
What does the "P" stand for in "SMCP-FA" pmighetto Pentax SLR Lens Discussion 2 08-27-2014 04:18 PM
Is Av Shift and/or Tv Shift in TAv Mode possible. robert_s Pentax K-5 3 09-30-2011 09:03 AM



All times are GMT -7. The time now is 07:09 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top