Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-03-2016, 09:42 AM   #1
Senior Member
aT0Mx's Avatar

Join Date: Oct 2011
Location: Ontario
Photos: Albums
Posts: 155
K-5 and manual lenses.

I have been using my k5 for about a month now and something unusual has popped up.

K-5 with fully auto lens (18-55wr and others) works fine.

K-5 with manual focus, auto aperture lens (rokinon 15mm) works fine on auto aperture, but flashes F-- on top lcd and cannot activate live view on any setting

K-5 using fully manual lenses will not activate live view on any setting and flashes F-- as soon as it's in contact with body.

All these lenses work perfectly on my K-R in any mode.

If anyone knows anything that may help it would be apprecited as I'm in the middle of the woods right now.

Thanks.

08-03-2016, 09:45 AM   #2
Loyal Site Supporter
paulh's Avatar

Join Date: Sep 2010
Location: DFW Texas
Photos: Gallery | Albums
Posts: 12,481
In the menu, is "using aperture ring" allowed ? Also, fully manual lenses (no auto aperture) work in M mode, using green button metering.
08-03-2016, 10:26 AM   #3
Loyal Site Supporter




Join Date: Mar 2015
Photos: Gallery | Albums
Posts: 4,856
The fact that your Rokinon works fine in A mode and flashes F__ when turned off it does suggest that your "enable aperture ring" setting is currently switched off.
08-03-2016, 11:41 AM   #4
Loyal Site Supporter
UncleVanya's Avatar

Join Date: Jul 2014
Photos: Gallery | Albums
Posts: 9,555
Agree with the above but confused how that dovetails with live view...

08-03-2016, 12:54 PM   #5
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,993
Definitely set the aperture ring to 'A' with the Rokinon. If the camera can't enter live view or is behaving erratically, try cleaning the lens mount. Some old lenses also short the wrong contacts and cause weirdness- what fully manually lens did you try?

https://www.pentaxforums.com/forums/54-pentax-lens-articles/110657-how-use-me...k-x-k-7-a.html

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

08-03-2016, 01:28 PM   #6
Senior Member
aT0Mx's Avatar

Join Date: Oct 2011
Location: Ontario
Photos: Albums
Posts: 155
Original Poster
Yup. I've not done a reset for a while and forgot to change that custom setting.

It should say it's "prohibited", not "can't activate".

Thank you Paulh.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
aperture, auto, camera, flashes, k-5, lens, lenses, pentax help, photography, troubleshooting, view
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax K-5, K-5II and K-5IIs rear sync broken with manual lenses Nass Pentax K-5 17 02-25-2013 05:24 AM
Availability of DXO Profiles for manual K/A/M lenses and K-5 ChrisGVE Pentax K-5 4 07-29-2012 05:54 PM
K-5 Viewfinder and manual lenses focus problem PiotrKrochmal Pentax K-5 10 03-08-2012 03:54 PM
Manual lenses and the K-5 NaClH2O Pentax K-5 10 10-26-2010 01:49 PM
K-5 and K-R with manual lenses, any improvements? ovim Pentax K-5 48 10-20-2010 02:00 AM



All times are GMT -7. The time now is 04:18 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top