Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-12-2016, 01:28 AM   #1
Site Supporter




Join Date: May 2015
Location: Hampshire
Photos: Albums
Posts: 386
Curious as to why the K20D does and the K-5 does not?

Having a K mount manual lens with a black anodised mount means some work on the mount or some conductive foil strategically placed to enable green button stop down metering on a K-5 (and others) but no problem on the K20D (and earlier?).
I have looked in previous threads and found the suggestion that having video on one of the later cameras might be the culprit.
Can anyone add to this or provide another reason?
Apologies if this has already been covered and I did not find it.

08-12-2016, 03:17 AM   #2
Loyal Site Supporter
i_trax's Avatar

Join Date: Jan 2011
Location: Perth Western Australia
Photos: Gallery | Albums
Posts: 1,100
You are actually right!
I thought that with all black anodised lenses you would need to use aluminium foil, not true!
My K10D works fine without it, all later no go, why?
we should have menu setting to go
around it

Last edited by BigMackCam; 08-12-2016 at 04:47 AM. Reason: Removed vulgarity.
08-12-2016, 04:43 AM   #3
Pentaxian




Join Date: Jan 2012
Location: Slovenia
Photos: Gallery
Posts: 2,165
QuoteOriginally posted by i_trax Quote
we should have menu setting to go
around it
How exactly would this work?
08-12-2016, 08:20 AM   #4
Site Supporter




Join Date: Dec 2012
Location: Perth Western Australia
Photos: Gallery
Posts: 131
Had to dig deep into my pile of lenses to find the only black K mount lens. Green button stop down metering didn't work on either K20D or K5.

Stop Press: Gave the anodised aluminium a good clean and yes, green button stop down metering does work with K20D!


Last edited by beachboy2; 08-12-2016 at 08:38 AM. Reason: Correction
08-12-2016, 08:54 AM   #5
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 26,885
QuoteOriginally posted by Skodadriver Quote
Curious as to why the K20D does and the K-5 does not?
Things change and even back in the day, there was variation between Pentax models in regards to non-conductive mounts.


Steve
08-12-2016, 08:58 AM   #6
Loyal Site Supporter
paulh's Avatar

Join Date: Sep 2010
Location: DFW Texas
Photos: Gallery | Albums
Posts: 13,343
Just to muddy the waters a bit - I have a Vivitar (Cosina) 135/2.8 with the black anodized mount. Green button metering has always worked on my older bodies (*ist D and K10D). However focus confirmation has never worked with any of them. I haven't tried it on my K-5 yet.
08-12-2016, 12:44 PM   #7
Pentaxian
Not a Number's Avatar

Join Date: Mar 2012
Location: Venice, CA
Posts: 4,108
Behavior due to conductive or non-conductive mounts seems primarily linked to the body. Seems like nearly all bodies or at least with bodies with firmware released past a certain date need conductive mounts for the green button to work. My thought is the intention is to not actuate the stop down lever mechanism when no lens is mounted or when a screw-mount lens is installed.

When a non-conducting lens is mounted does the green button do nothing when pressed? Or does it meter through the lens and set the shutter speed without actuating the lever?
08-12-2016, 11:57 PM   #8
Loyal Site Supporter
i_trax's Avatar

Join Date: Jan 2011
Location: Perth Western Australia
Photos: Gallery | Albums
Posts: 1,100
QuoteOriginally posted by Giklab Quote
How exactly would this work?
A mechanical switch would be the way to go

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, k-5, k20d, mount, pentax help, photography, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
The K-1 does the 24H of Spa and kids at play kyukyu Pentax K-1 7 08-24-2016 08:17 PM
K-5 with old manual lens does not want to move the aperture kousalik Troubleshooting and Beginner Help 31 11-29-2014 02:58 AM
Does K3 use the same battery as the K-01? Ilovemypentax Pentax K-3 5 12-27-2013 08:16 PM
Is the Pixel war over -With the D4 at 16M, why does the K3 need to go to 24? philbaum Pentax DSLR Discussion 72 05-22-2012 03:23 PM
Why does the American President have to be born in the USA ? lesmore49 General Talk 75 07-12-2010 01:57 PM



All times are GMT -7. The time now is 03:45 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top