Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-28-2016, 11:36 AM   #1
Forum Member




Join Date: Aug 2016
Posts: 92
ME shutter failure

I just got an ME SE with brown leather and this thing is gorgeous! Everything seems to operate and function correctly except for the shutter. The meter works, frame counter, self timer, and even the shutter will fire on the mechanical speeds (125 and B). when I manipulate the aperture dial on the lens, the meter registers the change in shutter speed but the actual speed of the shutter does not change when fired. It seems stuck at the mechanical 1/125 second.

Since the exterior of the camera seems to be in near mint condition, I don't think the problem was caused by physical damage. I think that it might be something simple. Where should I start in trying to chase down the source of this malfunction?

08-28-2016, 11:50 AM   #2
Forum Member
Pentaxis's Avatar

Join Date: Jul 2012
Posts: 89
QuoteOriginally posted by ctrout Quote
I just got an ME SE with brown leather and this thing is gorgeous! Everything seems to operate and function correctly except for the shutter. The meter works, frame counter, self timer, and even the shutter will fire on the mechanical speeds (125 and B). when I manipulate the aperture dial on the lens, the meter registers the change in shutter speed but the actual speed of the shutter does not change when fired. It seems stuck at the mechanical 1/125 second.

Since the exterior of the camera seems to be in near mint condition, I don't think the problem was caused by physical damage. I think that it might be something simple. Where should I start in trying to chase down the source of this malfunction?
I wonder if the battery is low.
08-28-2016, 11:57 AM   #3
Forum Member




Join Date: Aug 2016
Posts: 92
Original Poster
Brand new batteries. Edit: I had shot two rolls of 24 on these batteries in my MX so I decided to grab another set out of the package and all is well now. I guess the MX pulled more from the batteries than I thought it did. So, THANK YOU! My $23 ME SE with Soligor 70-150 f3.5 zoom works great and just needs the mirror buffer and probably light seals replaced to be like a new camera. It'll be going off to Eric on payday.

Last edited by ctrout; 08-28-2016 at 12:07 PM.
08-28-2016, 12:10 PM   #4
Forum Member
Pentaxis's Avatar

Join Date: Jul 2012
Posts: 89
QuoteOriginally posted by ctrout Quote
Brand new batteries. Edit: I had shot two rolls of 24 on these batteries in my MX so I decided to grab another set out of the package and all is well now. I guess the MX pulled more from the batteries than I thought it did. So, THANK YOU! My $23 ME SE with Soligor 70-150 f3.5 zoom works great and just needs the mirror buffer and probably light seals replaced to be like a new camera. It'll be going off to Eric on payday.
Maybe this chap can advise: (you are probably aware that the ME and ME Super are of very similar construction).

A guide to the Pentax ME Super. Buying and Faults | eBay

---------- Post added 08-28-16 at 12:18 PM ----------

QuoteOriginally posted by ctrout Quote
I just got an ME SE with brown leather and this thing is gorgeous! Everything seems to operate and function correctly except for the shutter. The meter works, frame counter, self timer, and even the shutter will fire on the mechanical speeds (125 and B). when I manipulate the aperture dial on the lens, the meter registers the change in shutter speed but the actual speed of the shutter does not change when fired. It seems stuck at the mechanical 1/125 second.

Since the exterior of the camera seems to be in near mint condition, I don't think the problem was caused by physical damage. I think that it might be something simple. Where should I start in trying to chase down the source of this malfunction?
This may be of some value:
How To: Pentax Vertical Run Shutter Maintentance - Pick My Camera

08-28-2016, 12:41 PM   #5
Forum Member




Join Date: Aug 2016
Posts: 92
Original Poster
Thanks for the links. I've had three ME Supers over the years and never had a problem with any of them and it seems like batteries lasted for years in them. I got the ME because it was the brown SE version and I am more of a collector now and this piece will really set my collection off. I cleaned it up and aside from very light handling marks on the base plate, it truly does look brand new. I'll be picking up another package of batteries tonight and I'll put a roll of film through it in the coming week and see how it does. Once I send it off to Eric I'm sure it will come back to me as a nearly new machine with everything working as new.
08-28-2016, 01:21 PM   #6
Forum Member
Pentaxis's Avatar

Join Date: Jul 2012
Posts: 89
QuoteOriginally posted by ctrout Quote
Thanks for the links. I've had three ME Supers over the years and never had a problem with any of them and it seems like batteries lasted for years in them. I got the ME because it was the brown SE version and I am more of a collector now and this piece will really set my collection off. I cleaned it up and aside from very light handling marks on the base plate, it truly does look brand new. I'll be picking up another package of batteries tonight and I'll put a roll of film through it in the coming week and see how it does. Once I send it off to Eric I'm sure it will come back to me as a nearly new machine with everything working as new.
I am very pleased to hear that you will be using Eric's services. He fixed an ME Super for me: it's silky smooth, quiet and adorable. He is also very reasonable in his charges.
I am sure you will get a lot of pleasure from owning your ME!
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
batteries, camera, change, meter, mx, pentax, pentax help, photography, shutter, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Survey with shutter count and aperture block or shutter failure. macman24054 Pentax K-30 & K-50 256 12-30-2016 11:47 PM
Aperture Block / Shutter Failure lakeshore Pentax DSLR Discussion 37 09-17-2016 05:24 AM
Shutter not opening, shutter button stuck and unresponsive ( Pentax ME) pentytaxy Troubleshooting and Beginner Help 4 04-16-2016 12:54 AM
K-5 shutter release failure with manual zooms. pathdoc Pentax K-5 8 08-12-2015 12:35 PM
K110D shutter failure TreeHuggerDoug Pentax DSLR Discussion 9 07-08-2008 01:40 PM



All times are GMT -7. The time now is 05:33 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top