Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-26-2016, 11:01 AM   #1
New Member




Join Date: Sep 2016
Posts: 5
PDCU 5.6.2 Fails to Load on Win 10

Hey all -

I recently rented the K-3 II for a recent trip to Iceland, and I'm trying to develop some of the photos I brought back - in particular, the pixel shift DNGs.

At first I couldn't even figure out how to get PDCU in the first place since I didn't have the CD for it (seriously, what's up with that? no downloads on the ricoh site?) but someone on the reddit pentax community clued me into the tip of renaming an external drive to S-SW160 so that the "updater" would install it.

But now, when I launch the app the splash screen appears for a few seconds, and then disappears. Nothing else loads, no notification icon appears, nothing shows up in the taskbar. The process is visible in task manager, but that's it.

I've tried uninstalling, reinstalling as admin, running in compatibility mode - nothing works.

Anyone have suggestions?

09-26-2016, 11:16 AM   #2
amateur dirt farmer...
pepperberry farm's Avatar

Join Date: Dec 2014
Location: probably out in a field somewhere...
Photos: Gallery | Albums
Posts: 7,004
do you have any other photo-processing software? Lightroom, Photoshop, Aperture, etc?


did you shoot RAW or jpeg's?
09-26-2016, 11:46 AM   #3
New Member




Join Date: Sep 2016
Posts: 5
Original Poster
QuoteOriginally posted by pepperberry farm Quote
do you have any other photo-processing software? Lightroom, Photoshop, Aperture, etc?


did you shoot RAW or jpeg's?
I'm using the latest version of Lightroom and shot everything RAW, so I can make use of most of my photos just fine through LR. I just read in all the reviews that Pentax's software had better algorithms for reducing artifacts in Pixel Shift files, so I wanted to give that a shot for those photos I used it on.
09-26-2016, 12:35 PM   #4
Loyal Site Supporter
SeaRefractor's Avatar

Join Date: Aug 2016
Location: Normandy Park, WA US
Photos: Albums
Posts: 113
I use both LightRoom CC (updated to latest version) and PDCU 5.6.2 with WIndows 10 64bit Anniversary Edition with no trouble at all.

The difference being that did have the CD-ROM. I don't believe that the update has "all" the files for the installation, only the necessary bits to perform an update for the executable and the changed DLL's. Suspect that the re-name of the external drive as a work around allows for "patching" provided the original app was already previously installed.

This CD should have been packed with your K3 II. You might try contacting Ricoh US for support if it was missing (or if your camera was second hand).

09-26-2016, 12:57 PM   #5
New Member




Join Date: Sep 2016
Posts: 5
Original Poster
QuoteOriginally posted by SeaRefractor Quote
I use both LightRoom CC (updated to latest version) and PDCU 5.6.2 with WIndows 10 64bit Anniversary Edition with no trouble at all.

The difference being that did have the CD-ROM. I don't believe that the update has "all" the files for the installation, only the necessary bits to perform an update for the executable and the changed DLL's. Suspect that the re-name of the external drive as a work around allows for "patching" provided the original app was already previously installed.

This CD should have been packed with your K3 II. You might try contacting Ricoh US for support if it was missing (or if your camera was second hand).
As mentioned, I rented it (from lensrentals.com) so there was no CD with it. It seems silly to have to contact support for software that only benefits you if you have their hardware anyway - they don't really have anything to lose by making the full thing downloadable. It just seems like an unnecessary inconvenience to anybody who needs to reinstall and doesn't have all the CD's from god knows when they first bought something. At this point I'd rather just find a CD image somewhere.
09-26-2016, 01:17 PM   #6
New Member




Join Date: Sep 2016
Posts: 5
Original Poster
Apprently, you can BUY a replacement CD...Lost/Replacement CD | Ricoh Imaging Support

That's pretty absurd.
09-26-2016, 02:27 PM - 1 Like   #7
Pentaxian
Not a Number's Avatar

Join Date: Mar 2012
Location: Venice, CA
Posts: 4,106
I've tested installing DCU from version 5.4 through 5.6.2 on fresh installs of Windows 8.1 Pro and Windows 10 Pro both 64 and 32 bit and have had no problem installing using the update files available for download. No problems running it either.

On Windows 8, 8.1 and 10 it will complain that it can't find an earlier version or CD. If you click ok, next, next it will install anyway without having to use the dummy drive trick.

DCU 5.6.2 I don't think is even on CD yet as it was released after the K-1 and K-70 were released.

https://www.pentaxforums.com/forums/16-pentax-news-rumors/319705-digital-came...ml#post3692584

Some one posted a link to a CD image that they created from the 5.5.x CD. I haven't found the post yet but other than having an install app there was no difference in the software itself.

There have been reports of DCU not working on Windows 10. Appears to be no solution since the cause is unknown.
09-26-2016, 03:26 PM   #8
hcc
Pentaxian
hcc's Avatar

Join Date: Nov 2009
Location: Brisbane, Australia
Photos: Gallery | Albums
Posts: 3,517
If you do not have the CD, download the installation file from Pentax website and rename a SD card or usb-drive to S-SW90. Start the installer. Follow the normal steps. Next you will get a message about the installation disc. Push OK and go on.

I have installed PDCU 5.6.2 and 5.4.1 on Windows 10 without problem. But I still have issues with DCU 5.6.2. (I reported earlier problems in https://www.pentaxforums.com/forums/32-digital-processing-software-printing/3...y-5-4-2-a.html.) For these reasons I continue to use DCU 5.4.1 that I re-installed.

Hope that the comment may help.

09-26-2016, 04:02 PM   #9
Pentaxian
Oldbayrunner's Avatar

Join Date: Mar 2013
Location: Havre de Grace, MD
Posts: 1,225
To my knowledge PDCU software comes with cameras that are purchased. The various versions and upgrades are dependent on which camera one has and the version that came with it. Since you rented your equipment I don't think you can use the downloaded software from Ricoh. Perhaps some have found a way to bootleg the software. I presume it is not freeware due to Ricoh more than likely paying licensing fees to Silky Pix for the use of their software and development for use with the Pentax Brand.
09-26-2016, 04:19 PM   #10
Loyal Site Supporter
SeaRefractor's Avatar

Join Date: Aug 2016
Location: Normandy Park, WA US
Photos: Albums
Posts: 113
If you go to the SilkyPix website, an upgrade from the Pentax version is ~95 USD for the Developer Studio 7 and ~220 USD for the Developer Studio 7 Pro versions of SilkyPix, so it's definitely not freeware. Just reporting on the pricing, not if it's ridiculous or not.
While it's a pain, I can see why Ricoh charges for replacement CD's as the licensing cost is bundled into each camera, replacements are not so each CD request would be out of their pocket in terms of licensing.

I know the OP used the rented K3 II for Pixel Shift images, if the rental company cannot provide the software, than at a minimum they should offer a free service to transfer and develop the images for the rental customer.

I'll have to try the "Update" method on another workstation I have to see if that will do the install trick.
09-26-2016, 04:53 PM   #11
New Member




Join Date: Sep 2016
Posts: 5
Original Poster
QuoteOriginally posted by Not a Number Quote
I've tested installing DCU from version 5.4 through 5.6.2 on fresh installs of Windows 8.1 Pro and Windows 10 Pro both 64 and 32 bit and have had no problem installing using the update files available for download. No problems running it either.

On Windows 8, 8.1 and 10 it will complain that it can't find an earlier version or CD. If you click ok, next, next it will install anyway without having to use the dummy drive trick.

DCU 5.6.2 I don't think is even on CD yet as it was released after the K-1 and K-70 were released.

https://www.pentaxforums.com/forums/16-pentax-news-rumors/319705-digital-came...ml#post3692584

Some one posted a link to a CD image that they created from the 5.5.x CD. I haven't found the post yet but other than having an install app there was no difference in the software itself.

There have been reports of DCU not working on Windows 10. Appears to be no solution since the cause is unknown.
That was it! I used the 5.5.1 ISO in your link and it works fine. Apparently 5.6.2 is busted for my particular version of WIn10. Thanks!
09-27-2016, 04:34 AM   #12
New Member




Join Date: Sep 2010
Location: Brisbane
Posts: 21
QuoteOriginally posted by cogitoergosam Quote
I used the 5.5.1 ISO in your link and it works fine. Apparently 5.6.2 is busted for my particular version of WIn10
I had the same problem on Windows 7 and Windows 8.1.
The solution was to install 5.5.1 which has no problems and then install the 5.6.2 upgrade on top.
I didn`t run into the problem in Windows 10 because I already had the earlier version installed when I upgraded with 5.6.2.
09-27-2016, 10:31 AM   #13
Forum Member




Join Date: Dec 2006
Location: Taiwan
Posts: 98
QuoteOriginally posted by cogitoergosam Quote
That was it! I used the 5.5.1 ISO in your link and it works fine. Apparently 5.6.2 is busted for my particular version of WIn10. Thanks!
Glad you got it to work.

Last edited by Sideway; 09-27-2016 at 11:22 AM.
01-21-2017, 09:19 AM   #14
Veteran Member




Join Date: Jan 2012
Location: Somewhere, USA
Photos: Gallery
Posts: 452
I have the same exact problem. Argh. Compatibility mode does nothing to fix it. It just loads the splash screen and then freezes. I just finally dug out my CD and installed it today and then updated to the newest version. If anyone finds a solution, ping back here please.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, digital camera utility, digital camera utility 5, pdcu, pentax help, photography, silkypix, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax 10-17mm (fish-eye) compared to Sigma 10-20mm F4-5,6? mhoule418 Pentax SLR Lens Discussion 17 09-27-2016 10:39 AM
PDCU 5.6.2 released rechmbrs Pentax News and Rumors 7 09-08-2016 06:13 AM
to update to PDCU v. 5.3.1 if I get the D FA 150-450mmF4 ?? jpzk Digital Processing, Software, and Printing 7 04-04-2015 08:03 AM
For Sale - Sold: Sigma 10-20/4-5.6, Kiron 28/2, FA50/1.4, Helios 44-4k 58/2, DA* 50-135/2.8, To systemA Sold Items 13 12-15-2010 05:15 AM
K110D Firmware fails to load/install ? ? ? ? ? derek45 Pentax DSLR Discussion 2 09-20-2009 08:22 AM



All times are GMT -7. The time now is 05:36 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top