Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-07-2016, 08:56 PM   #1
New Member




Join Date: Oct 2016
Posts: 2
K110 stuck on initialize (pick language etc) screen

With batteries or the Pentax wall plug in power the display comes up with choose language but accepts no "OK" or "Menu" or any other option I've tried.

I've removed all batteries and power and reapplied, as I heard static electricity might be a gremlin. Can't reset as it seems to need access to the "Menu". Is there any other way to frighten it into waking up? Thanks

10-07-2016, 10:16 PM   #2
Senior Member
johnhilvert's Avatar

Join Date: May 2015
Location: Canberra, ACT
Posts: 173
I used to have a Pentax K110. If and when I got a freeze like that, I'd assume the camera's hardware is getting mixed signals from somewhere.

Does the LCD screen indicate whether the battery/wall power is OK?

Try switching the camera on and off under the following conditions:

* without a lens
* With a different lens (if you have one)
* switching to different modes on the mode dial
* different set of charged batteries
* taking out memory card and re-inserting
* holding down or clicking the Fn button (sometimes this may be stuck)
* connect the camera to a PC via the USB cable.

If nothing changes, it might be time to get another K110D or better body...
10-09-2016, 11:47 PM   #3
New Member




Join Date: Oct 2016
Posts: 2
Original Poster
thankyou / fixed

I fiddled with everything you mentioned a few times and no go and before ordering a new camera I thought I'd inspect the lens to see if it looked good. Put it back on and eureka the camera came to life. I had done this a couple of times before but it must have been mis mounted slightly or maybe dumb luck or my favorite tech support excuse...static electricity... .
10-10-2016, 12:47 AM   #4
Senior Member
johnhilvert's Avatar

Join Date: May 2015
Location: Canberra, ACT
Posts: 173
QuoteOriginally posted by babettejones Quote
I fiddled with everything you mentioned a few times and no go and before ordering a new camera I thought I'd inspect the lens to see if it looked good. Put it back on and eureka the camera came to life. I had done this a couple of times before but it must have been mis mounted slightly or maybe dumb luck or my favorite tech support excuse...static electricity... .
Sweet.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
batteries, camera, initialize pick language, language, pentax help, photography, power, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Protecting you K-50 investment: warranties, screen protectors, etc. Suleeto Pentax K-30 & K-50 21 01-30-2015 06:06 PM
Focus Screen Installation on K30 (Shims etc) godwinaustin Troubleshooting and Beginner Help 2 02-10-2013 03:57 PM
For Sale - Sold: FS: Katzeye screen for K10D etc ChrisN Sold Items 2 09-07-2008 03:01 AM



All times are GMT -7. The time now is 12:14 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top