Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-11-2016, 11:03 AM   #1
New Member




Join Date: Sep 2011
Posts: 5
Image not saved?

Hi;

I have a Pentax K-30 that has presented some issues recently.

Intermittently, it would display "Memory card error" or "image not saved" or words to that effect. I would take out the card, stare at it menacingly, pop it back in, turn the camera on and off several times, then it would be fine, until the next time.

I have just returned from a vacation and notice that a whole series of shots are missing; I guess I did not check after each shot. I haven't had a chance to try another memory card yet.

Any insights would be much appreciated.

Thanks;
Chris

10-11-2016, 11:21 AM   #2
Loyal Site Supporter
paulh's Avatar

Join Date: Sep 2010
Location: DFW Texas
Photos: Gallery | Albums
Posts: 12,480
I would try formatting the card in-camera and try again. (after backing up any photos still on the card) Errors will pop up if the memory card hasn't been formatted in awhile. If that doesn't work, time to try a new card.
10-11-2016, 11:25 AM   #3
Site Supporter




Join Date: Nov 2011
Location: East central Indiana
Photos: Gallery
Posts: 600
Well, the best case would be a problem with the memory card. Worse case would be a problem with your K30, either in the card slot or something else in the camera.


First thing I would do is get a different card and try that. If the new card works without a problem, then the fault is in the camera. At that point, you would need to decide if the camera is worth fixing.


Hopefully, it is just the card.
10-11-2016, 12:34 PM   #4
Loyal Site Supporter
Quartermaster James's Avatar

Join Date: Nov 2015
Location: Anchorage, Alaska
Posts: 598
QuoteOriginally posted by bigdavephoto Quote
First thing I would do is get a different card and try that. If the new card works without a problem, then the fault is in the camera. At that point, you would need to decide if the camera is worth fixing.


Hopefully, it is just the card.
If a new card works, wouldn't that indicate a problem with the old card, not the camera?

10-11-2016, 12:47 PM   #5
New Member




Join Date: Sep 2011
Posts: 5
Original Poster
QuoteOriginally posted by paulh Quote
I would try formatting the card in-camera and try again. (after backing up any photos still on the card) Errors will pop up if the memory card hasn't been formatted in awhile. If that doesn't work, time to try a new card.
Hi Paulh;
How do I format the card in-camera?
Chris
10-11-2016, 12:53 PM   #6
Loyal Site Supporter
paulh's Avatar

Join Date: Sep 2010
Location: DFW Texas
Photos: Gallery | Albums
Posts: 12,480
QuoteOriginally posted by ChrisDx Quote
Hi Paulh;
How do I format the card in-camera?
Chris
I don't own a K30, but it's a standard menu option on every Pentax DSLR I've used. On my K10D, it's under the "wrench" icon (setup) - not sure where it is on the K30. Perhaps a K30 owner can chime in, or you can consult your manual.
10-11-2016, 01:06 PM   #7
New Member




Join Date: Sep 2011
Posts: 5
Original Poster
QuoteOriginally posted by paulh Quote
I don't own a K30, but it's a standard menu option on every Pentax DSLR I've used. On my K10D, it's under the "wrench" icon (setup) - not sure where it is on the K30. Perhaps a K30 owner can chime in, or you can consult your manual.
Found it. Did it. Let's see what happens.
10-11-2016, 04:44 PM   #8
Site Supporter




Join Date: Nov 2011
Location: East central Indiana
Photos: Gallery
Posts: 600
QuoteOriginally posted by Quartermaster James Quote
If a new card works, wouldn't that indicate a problem with the old card, not the camera?


Yeah, your right. I knew what I wanted to say, I just didn't get it out right.

10-11-2016, 06:09 PM   #9
Site Supporter
ramseybuckeye's Avatar

Join Date: Apr 2009
Location: Elida, Ohio
Photos: Gallery | Albums
Posts: 8,124
QuoteOriginally posted by ChrisDx Quote
Found it. Did it. Let's see what happens.
If you have not been formatting your card then it's a good chance that you just fixed your problem. If that did not, it's most likely time for a new card. I format my cards after every download, but even if you don't, you ned to do it often.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, card, pentax help, photography, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Image not saved SoccerGeek Troubleshooting and Beginner Help 3 12-01-2014 01:19 AM
Photos Not Being saved To Card - Fault? sonny2962 Pentax K-5 14 05-11-2011 01:10 AM
K200D broken - Mirror stays up, picture not saved cfraz Pentax DSLR Discussion 3 03-22-2010 08:54 PM
Final Saved Image eco1 Digital Processing, Software, and Printing 11 01-17-2010 12:38 AM
Image not saved? kateowenjones Troubleshooting and Beginner Help 4 02-08-2009 03:34 PM



All times are GMT -7. The time now is 08:04 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top