Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-14-2016, 04:34 AM   #1
Junior Member




Join Date: Aug 2012
Posts: 28
AF540FGZ not being triggered

Setup:
Pentax K5:
  • exposure: o (o) ((o))
  • _______this ^
  • manual mode
  • flash mode: flash on
  • ISO 100, 1/160, F9.0 (doesn't really matter what are these settings)

AF540FGZ:
  • manual mode
Problem: Flash is not triggering when shooting
I can fix this problem using A mode, but I'd like to use 1/x coefficient in M mode.
Please, how to make flash to trigger every time no matter what?


Last edited by AndreyS; 10-14-2016 at 06:18 AM.
10-14-2016, 10:31 AM   #2
Site Supporter
enoeske's Avatar

Join Date: Jul 2009
Location: Surprise, Az
Photos: Gallery
Posts: 1,888
QuoteOriginally posted by AndreyS Quote
Setup:
Pentax K5:
  • exposure: o (o) ((o))
  • _______this ^
  • manual mode
  • flash mode: flash on
  • ISO 100, 1/160, F9.0 (doesn't really matter what are these settings)

AF540FGZ:
  • manual mode
Problem: Flash is not triggering when shooting
I can fix this problem using A mode, but I'd like to use 1/x coefficient in M mode.
Please, how to make flash to trigger every time no matter what?
Are you giving the flash enough time to recycle? It can take a long time depending on power level and batteries used
10-14-2016, 01:37 PM   #3
Junior Member




Join Date: Aug 2012
Posts: 28
Original Poster
QuoteOriginally posted by enoeske Quote
Are you giving the flash enough time to recycle? It can take a long time depending on power level and batteries used
yes, the test button is glowing. The charging sound is absent, I mean it just came to the end.
So I guess it's a bug?
I think I'll make a video later on, so that everybody could see. Maybe I'm doing something wrong, but I strongly doubt it.
10-14-2016, 01:56 PM   #4
Senior Moderator
Loyal Site Supporter
Nass's Avatar

Join Date: Aug 2009
Location: The British Isles
Photos: Gallery
Posts: 2,213
hm must be a problem your end, I have a k5 with 540 on it on manual, and the flash shoots just fine...

10-17-2016, 01:13 AM   #5
New Member
KoT_BacbKa's Avatar

Join Date: Apr 2012
Posts: 11
QuoteOriginally posted by AndreyS Quote
yes, the test button is glowing. The charging sound is absent, I mean it just came to the end.
So I guess it's a bug?
I think I'll make a video later on, so that everybody could see. Maybe I'm doing something wrong, but I strongly doubt it.
Test button is activated flash?
10-17-2016, 01:54 AM   #6
Junior Member




Join Date: Aug 2012
Posts: 28
Original Poster
QuoteOriginally posted by KoT_BacbKa Quote
Test button is activated flash?
Sorry, I cannot understand your question. Please rephrase it.

I played around with mentioned setup - preparing for taking the video. The light button didn't work this time. When I click it -> LCD display goes off and then immediately (after ~0.5 sec) goes on. For now flash fires every time.
Also I cannot change the format in PTTL and M modes, when I click it nothing happens. Of cause I use always digital, just saying it, maybe it can help for troubleshooting.
2 days ago I was able to turn LCD off, in that case flash fired not every time.
Am I doing something wrong? Or maybe it works as intended, isn't it? I have never worked with brand new fully working flash. I need your help in guiding me to figure out whether the flash is malfunctioning or not.

Any input regarding for resolving this ridiculous issue would be appreciated.

---------- Post added 10-17-16 at 11:10 AM ----------

This undefined behavior just pisses me off. I remember when my good friend asked me to take pictures of her weddings. First 30 min flash just didn't work. And it is not the only case. I recalled the most significant one.

Last edited by AndreyS; 10-17-2016 at 02:33 AM.
10-17-2016, 02:24 AM   #7
Senior Moderator
Loyal Site Supporter
Nass's Avatar

Join Date: Aug 2009
Location: The British Isles
Photos: Gallery
Posts: 2,213
Given the language issues, I think it'd help greatly if you made a video and posted a URL

-Nass
10-17-2016, 03:34 AM   #8
Junior Member




Join Date: Aug 2012
Posts: 28
Original Poster

Sorry for that bad quality, k-5 is the only good recording device I have.
If something wasn't clear enough or some details are missing, please let me know

10-17-2016, 05:14 AM   #9
Junior Member




Join Date: Aug 2012
Posts: 28
Original Poster
If I set C22 option to 3 (OFF) K-5's LCD and flashlight's LCD go off.
According to p.11 of af540fgz operational manual flashlight's LCD screen should not light up with K-5 when exposure metering timer is on.
As you can see on my video, LCD is lit no matter what in PTTL and M modes. It didn't light up in A mode though. It seems something is wrong either to the camera or the flashlight.
Anybody who has af540fgz, can you confirm this:
  • attach flashlight on the camera
  • turn flashlight and camera on
  • does light button switch LCD off/on in PTTL/A/M modes?

Last edited by AndreyS; 10-17-2016 at 07:48 AM.
12-31-2016, 06:01 AM   #10
Junior Member




Join Date: Aug 2012
Posts: 28
Original Poster
I cleaned up contact pads of flash unit as well as batteries. And it worked fine.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
af540fgz, button, camera, click, flash, lcd, matter, mode, pentax help, photography, time, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP -- TTL flash not triggered by radio triggers Class A Flashes, Lighting, and Studio 10 11-24-2009 04:53 PM
Radio Trigger and AF540FGZ - Not working Peacekeeper Flashes, Lighting, and Studio 5 07-02-2009 05:54 PM



All times are GMT -7. The time now is 01:56 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top