Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-14-2016, 05:29 AM   #1
Site Supporter
Site Supporter
JimD's Avatar

Join Date: Feb 2011
Location: Newport, South Wales
Posts: 164
Firmware Fail

I've just downloaded the Fwdc230b.bin file to the SD card, put it in my K3II and switched the power on whilst pressing in the menu button. The display comes on as usual. It doesn't refer to any updates or firmware.
The menu and all of the other buttons appear to react as they should in every other instance.

Any ideas ?

10-14-2016, 06:01 AM   #2
Loyal Site Supporter
Loyal Site Supporter
UncleVanya's Avatar

Join Date: Jul 2014
Photos: Gallery | Albums
Posts: 10,135
The card is in slot 1?
10-14-2016, 06:04 AM   #3
Pentaxian
calsan's Avatar

Join Date: Nov 2008
Location: Perth, Australia
Photos: Gallery
Posts: 1,389
Maybe watch this video and see if there's a step you're missing?
Pentax K-3 II Firmware v1.10 Released - Firmware Updates | PentaxForums.com

--
Edit - good call UncleVanya!
10-14-2016, 06:06 AM   #4
Veteran Member
fwbigd's Avatar

Join Date: Jun 2007
Location: Fort Worth TX
Posts: 320
Have you checked to see what version of firmware you are running. The latest (version 1.10) may already be loaded on the camera.

10-14-2016, 06:17 AM   #5
Pentaxian
Oldbayrunner's Avatar

Join Date: Mar 2013
Location: Havre de Grace, MD
Posts: 1,234
Did you download the .bin file to the root directory of your SD card? If not it the camera wont recognize it.
10-14-2016, 10:13 AM   #6
Site Supporter
Site Supporter
JimD's Avatar

Join Date: Feb 2011
Location: Newport, South Wales
Posts: 164
Original Poster
Thanks guys. A problem with the first file I think. I deleted it from my laptop and started again from scratch. Everything fine now.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, firmware, menu, pentax help, photography, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Memory card fail ? BenCPentax Troubleshooting and Beginner Help 9 07-28-2016 01:40 PM
People Alien Abduction... Fail Kerrowdown Post Your Photos! 6 11-01-2015 12:29 PM
Adorama fail Sigmund General Photography 33 08-03-2015 09:30 AM
Macro FAIL!! Not Epic, but FAIL... icywarm Photo Critique 3 04-28-2010 05:51 AM



All times are GMT -7. The time now is 02:43 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top