Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-15-2016, 02:54 PM   #1
Site Supporter
reivax's Avatar

Join Date: Jun 2011
Location: California
Posts: 719
K-1 Firmware Not Updating to 1.30

I am having no luck updating the Firmware on my K-1. I have downloaded the .bin file several times, have attempted different sd cards, have followed the steps over and over again, and nothing.

I put the card in SD card slot 1, push menu as I turn on the camera, and the camera still just straight into normal shooting mode. It won't give me the option to update. This is the first time I've ever had any issues updating firmware on any of my Pentax cameras. I'm hoping someone has a solution for me. Thanks in advance!

10-15-2016, 03:08 PM   #2
Senior Member
screwdriver222's Avatar

Join Date: Oct 2011
Location: Plymouth
Photos: Gallery | Albums
Posts: 126
Try formatting the card in the camera first then put the .bin file on it. Make sure you dont put it into a folder on the card.

Best of luck

Jeff
10-15-2016, 03:14 PM   #3
Site Supporter
reivax's Avatar

Join Date: Jun 2011
Location: California
Posts: 719
Original Poster
QuoteOriginally posted by screwdriver222 Quote
Try formatting the card in the camera first then put the .bin file on it. Make sure you dont put it into a folder on the card.

Best of luck

Jeff
Thank you for the response. Tried it and no luck. Still not working... I can't figure it out. Could it be the filed on Ricoh's site?
10-15-2016, 03:48 PM   #4
Pentaxian
Topsy's Avatar

Join Date: Feb 2014
Photos: Gallery
Posts: 327
Is your camera fully loaded?

10-15-2016, 03:49 PM   #5
Loyal Site Supporter
clackers's Avatar

Join Date: Jul 2013
Location: Melbourne
Photos: Albums
Posts: 7,694
Look at the card from Slot 1 mounted in Windows - what's the name of the file?

10-15-2016, 03:49 PM   #6
Site Supporter
reivax's Avatar

Join Date: Jun 2011
Location: California
Posts: 719
Original Poster
QuoteOriginally posted by Topsy Quote
Is your camera fully loaded?
What do you mean?

---------- Post added 10-15-16 at 03:50 PM ----------

QuoteOriginally posted by clackers Quote
Look at the card from Slot 1 mounted in Windows - what's the name of the file?
Using Windows 10. The filename is: fwdc228b
10-15-2016, 03:50 PM   #7
Pentaxian
Topsy's Avatar

Join Date: Feb 2014
Photos: Gallery
Posts: 327
QuoteOriginally posted by reivax Quote
What do you mean?
Sorry, my brain got lost in translation

What I mean is, is your camera fully charged?
10-15-2016, 03:51 PM   #8
Site Supporter
reivax's Avatar

Join Date: Jun 2011
Location: California
Posts: 719
Original Poster
QuoteOriginally posted by Topsy Quote
Sorry, my brain got lost in translation

What I mean is, is your camera fully charged?
No worries. I thought you might have meant that, but wasn't sure. Yes, I fully charged the battery after the first couple of failed attempts.

10-15-2016, 04:03 PM   #9
New Member




Join Date: Aug 2015
Location: Waikato
Posts: 2
Are you sure that the bin file is the 1.30 version? Each extract from the downloaded file uses the same name.

10-15-2016, 04:14 PM   #10
Loyal Site Supporter
clackers's Avatar

Join Date: Jul 2013
Location: Melbourne
Photos: Albums
Posts: 7,694
QuoteOriginally posted by reivax Quote

Using Windows 10. The filename is: fwdc228b
But we need to know the rest of the filename, Reivax - turn that option on so you can see the final three characters (file association type).

While you're there check both how many bytes in size the file is and the file system the card's been formatted with (it can't be NTFS).
10-15-2016, 04:15 PM   #11
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,957
QuoteOriginally posted by reivax Quote
What do you mean?

---------- Post added 10-15-16 at 03:50 PM ----------



Using Windows 10. The filename is: fwdc228b
Check that the extension is .BIN (go into the windows folder options dialog and check the checkbox for displaying file extensions).

It's quite likely that the file isn't named correctly.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

10-15-2016, 04:33 PM   #12
Site Supporter
reivax's Avatar

Join Date: Jun 2011
Location: California
Posts: 719
Original Poster
QuoteOriginally posted by Adam Quote
Check that the extension is .BIN (go into the windows folder options dialog and check the checkbox for displaying file extensions).

It's quite likely that the file isn't named correctly.


It is named .bin. Really weird that it's not working...
10-15-2016, 05:35 PM   #13
Lens Buying Addict
monochrome's Avatar

Join Date: Mar 2008
Location: Kirkwood (St. Louis) MO
Photos: Gallery | Albums
Posts: 19,449
And you are copying the .bin file to the Root directory, not inside the DCIM folder, correct?
10-15-2016, 05:36 PM   #14
Lens Buying Addict
monochrome's Avatar

Join Date: Mar 2008
Location: Kirkwood (St. Louis) MO
Photos: Gallery | Albums
Posts: 19,449
QuoteOriginally posted by cng312 Quote
Are you sure that the bin file is the 1.30 version? Each extract from the downloaded file uses the same name.
And this ^^. I did that once
10-15-2016, 05:39 PM   #15
Site Supporter
reivax's Avatar

Join Date: Jun 2011
Location: California
Posts: 719
Original Poster
QuoteOriginally posted by monochrome Quote
And you are copying the .bin file to the Root directory, not inside the DCIM folder, correct?
Yeah, I have tried doing so on three different SD cards. No luck.

---------- Post added 10-15-16 at 05:39 PM ----------

QuoteOriginally posted by monochrome Quote
And this ^^. I did that once
I made sure to delete any other files that I could confuse it with.

---------- Post added 10-15-16 at 05:41 PM ----------

QuoteOriginally posted by clackers Quote
But we need to know the rest of the filename, Reivax - turn that option on so you can see the final three characters (file association type).

While you're there check both how many bytes in size the file is and the file system the card's been formatted with (it can't be NTFS).
fwdc228b.bin

Size: 18,438 KB
Compressed: 8,570

(I tried both extracting and not extracting the file. None provide luck)

---------- Post added 10-15-16 at 05:47 PM ----------

I know this makes no sense, but I figured it out (kind of). Out of desperation, I borrowed a macbook, downloaded the file, transferred it to an SD card and it worked on the first try. Maybe it's a problem with Windows 10?
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, card, file, firmware, k-1, k-1 firmware, luck, pentax help, photography, pm, post, sd, size, troubleshooting, windows
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Firmware version 1.30 for PENTAX K-1 released OoKU Pentax News and Rumors 39 09-29-2016 05:59 PM
K-1 firmware update version 1.30 shaolen Pentax News and Rumors 15 09-20-2016 06:38 AM
Trouble Updating 1.21 Firmware Linemrkr Pentax Medium Format 2 03-30-2015 11:48 AM
Pentax K7 Firmware Updating to Version 1.11 Vadym Visitors' Center 2 02-07-2012 07:46 PM
Firmware Updating to 1.30 Jesus Pentax DSLR Discussion 7 05-24-2008 07:01 PM



All times are GMT -7. The time now is 03:45 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top