Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-01-2016, 02:17 PM   #1
New Member




Join Date: Nov 2016
Location: Dortmund
Posts: 4
K-1 swivel screen, one of the "legs" slipped out of the guide rail

Hi all,

I am having a bit of trouble. The ring on one of my lenses got loose and my K-1 dropped to the ground. The camera is fine, I just needed to remove a bit of dirt. During the fall however, one of the little "legs" that hold the LCD slipped oout of its guiding rail and I am unable to get it back into place.

Does anyone have access to a service manual or has an idea how I can get the little thing back into its place? I checked the 4 rails and it seems that nothing broke, the rail in question looks excactly the same as the other 3.

I'll be leaving for SEA the day after tomorrow so having the camera serviced is unfortunately out of the question. The camera works fine but I would have to tape the screen to the body as it is moving around without any force.

best
vaudebe

11-01-2016, 02:29 PM   #2
Senior Member
Nuno Almeida's Avatar

Join Date: Sep 2014
Location: Aveiro
Posts: 179
The same happened to me a week ago, with a 70/200 2.8 attached, to the camera happened the same has you, the lens was worse and the focus mechanism got stuck, lens is repairing. The camera was easy, i put it back the same way it come out, just forced it a little bit in to place, I tried freezing it to shrink size with a can of compressed air first, but didn't help much, also considered dismantling it to put it in place, small screws behind the rubber near the rails, but in the end was easier and probably less prone to further complications just forcing it in to place.
11-01-2016, 02:45 PM   #3
New Member




Join Date: Nov 2016
Location: Dortmund
Posts: 4
Original Poster
if you don't mind asking me again. How exactly did you apply force? From the frame that holds the LCD? Did you hold the leg at a certain angle?

I tried to use some force but I don't seem to find the right way to apply it
11-01-2016, 03:06 PM   #4
Senior Member
Nuno Almeida's Avatar

Join Date: Sep 2014
Location: Aveiro
Posts: 179
With a pointed plier directly on the loose leg against the rail

11-02-2016, 03:03 AM   #5
Pentaxian




Join Date: Oct 2010
Photos: Gallery | Albums
Posts: 3,924
My camera also rolled with tripod, one of the legs got out from rails. I did not dare to do it my self to put it back. Sent it in and they also checked for other possible things that might have got misanglied...there was all other things still good. And I have my camera securely fixed. Just couple hundred euros and I don't have to think about it anymore.
11-02-2016, 10:58 AM - 2 Likes   #6
New Member




Join Date: Nov 2016
Location: Dortmund
Posts: 4
Original Poster
I am either to weak or too untalented, can't get it into the rail. Will have to tape the LCD to the camera body until I return

---------- Post added 11-02-16 at 11:56 AM ----------

Couldn't find a way to edit my above post.

For anybody who has the same problem, I have managed to find out how to fix it:

1: gently remove the rubber casing that is over the respective rail
2: unscrew 4 screws (2 in front right at the entrance plate, 2 in the back, close to the edge of the body
3: remove the top plating and put it around the leg
4: put the rail into place again and put the top plate on top again
5: secure the 4 screws
6: push the rubber in place again ( i didn't need to add extra glue)

Seems that you can push it in again if the top casing has dented a bit, in my case it hadn't budged at all.

Best
vaudebe
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
bit, body, camera, k-1, pentax help, photography, plate, post, question, rail, rubber, screen, screws, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Link to a Review of the K-1 "in the field" Barry Pearson Pentax K-1 5 06-17-2016 09:06 AM
An analysis of the Pentax K-1's "Pixel Shift Resolution" mode - Image resource Oli86 Pentax K-1 7 05-06-2016 07:19 AM
K-S1 listed as one of the beste DSLRs in german Magazine "Der Spiegel" geedee Pentax K-S1 & K-S2 26 12-20-2014 04:23 AM
what happen if i shoot with the "back" of the film instead of the "front" ? aurele Film Processing, Scanning, and Darkroom 20 07-03-2013 08:21 AM
The "real" values for the FA 77mm f/1.8 Ltd. Just out of curiosity. bc_the_path Pentax SLR Lens Discussion 6 06-02-2008 05:34 PM



All times are GMT -7. The time now is 07:33 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top