Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-08-2017, 04:25 PM   #1
Pentaxian




Join Date: May 2010
Posts: 6,707
Trouble getting into PC Mode via USB Cable with K-5 II

I've done this a number of times in the past, but now I can't seem to get it to work. The camera never goes into PC Mode. The computer can see the K-5 II under Devices and even assigns it a drive letter (K: ) but doesn't show it in Explorer.

In Disk Management I see the K: drive but it says no data or something along those lines.. SD card in the slot.

I bought another USB cable.. it doesn't seem to affect the situation. I've tried MSC and PTP modes, different USB ports, different computers (Win 7 and Win 10). The closest I get is I can see the camera in Devices but cannot interact with it.

Am I missing a driver? Gremlins? Something easy to fix this?


To resolve a lot of frustrating and anger inducing posts I will say yes I'm in need of the USB port and PC mode, No an SD card reader will not help.

03-08-2017, 05:00 PM   #2
Site Supporter
Site Supporter




Join Date: Mar 2008
Location: Prince George, BC
Photos: Gallery | Albums
Posts: 2,778
I am a linux user so this may not be relevant. But any SD card equal to or larger than 64 gig needs drivers in linux to be mounted by the OS. Perhaps that is your problem?
03-08-2017, 05:21 PM   #3
mee
Pentaxian




Join Date: May 2010
Posts: 6,707
Original Poster
Good thought and thanks for troubleshooting with me. However, I'm using 8 and 16GB cards.

I got the win7 PC to see my K-r with the same cable. So I'm thinking it is a driver issue or a camera settings issue. Hoping not a hardware issue.
03-08-2017, 05:46 PM   #4
Moderator
Loyal Site Supporter
Loyal Site Supporter
photolady95's Avatar

Join Date: May 2009
Location: Cruising PentaxForums and watching your back.
Photos: Gallery | Albums
Posts: 11,729
mee, why not use a card reader? I know some of you prefer to hook the camera up to the PC with the USB cable, but did you know that drains your battery if you have a lot of photos to transfer?

As for the card size, I don't think what would be a problem on a Windows PC because I'm using a 128GB SDXC and have no problems on my Windows 7.

Something you could try. Go into Device Manager, click on the plus sign beside your entries for your USBs, uninstall, and reboot the computer. Computer will reinstall the USBs.

03-08-2017, 05:47 PM   #5
mee
Pentaxian




Join Date: May 2010
Posts: 6,707
Original Poster
QuoteOriginally posted by photolady95 Quote
mee, why not use a card reader? I know some of you prefer to hook the camera up to the PC with the USB cable, but did you know that drains your battery if you have a lot of photos to transfer?

As for the card size, I don't think what would be a problem on a Windows PC because I'm using a 128GB SDXC and have no problems on my Windows 7.
No thank you.

QuoteOriginally posted by mee Quote
To resolve a lot of frustrating and anger inducing posts I will say yes I'm in need of the USB port and PC mode, No an SD card reader will not help.
03-08-2017, 05:50 PM - 1 Like   #6
Moderator
Loyal Site Supporter
Loyal Site Supporter
photolady95's Avatar

Join Date: May 2009
Location: Cruising PentaxForums and watching your back.
Photos: Gallery | Albums
Posts: 11,729
Sorry, I didn't read that last in your original post. Apologize for that oops.
03-08-2017, 05:51 PM   #7
Moderator
Loyal Site Supporter
Loyal Site Supporter
photolady95's Avatar

Join Date: May 2009
Location: Cruising PentaxForums and watching your back.
Photos: Gallery | Albums
Posts: 11,729
Try the last thing I said in my post.
03-08-2017, 05:58 PM   #8
Moderator
Loyal Site Supporter
Loyal Site Supporter
photolady95's Avatar

Join Date: May 2009
Location: Cruising PentaxForums and watching your back.
Photos: Gallery | Albums
Posts: 11,729
QuoteOriginally posted by mee Quote
but doesn't show it in Explorer.
I found this to be a problem because there is a tick in the box under Folder Options/view tab. Look for an entry that says "hide empty drives in the computer folder" uncheck it, apply and okay out. Your drives will now show in Explorer.

03-08-2017, 06:00 PM   #9
Moderator
Site Supporter
Loyal Site Supporter
MarkJerling's Avatar

Join Date: May 2012
Location: Wairarapa, New Zealand
Photos: Gallery | Albums
Posts: 10,402
QuoteOriginally posted by mee Quote
I've done this a number of times in the past, but now I can't seem to get it to work. The camera never goes into PC Mode. The computer can see the K-5 II under Devices and even assigns it a drive letter (K: ) but doesn't show it in Explorer.

In Disk Management I see the K: drive but it says no data or something along those lines.. SD card in the slot.

I bought another USB cable.. it doesn't seem to affect the situation. I've tried MSC and PTP modes, different USB ports, different computers (Win 7 and Win 10). The closest I get is I can see the camera in Devices but cannot interact with it.

Am I missing a driver? Gremlins? Something easy to fix this?


To resolve a lot of frustrating and anger inducing posts I will say yes I'm in need of the USB port and PC mode, No an SD card reader will not help.
Stupid question: Have you tried it with a different SD card?
03-08-2017, 06:14 PM   #10
mee
Pentaxian




Join Date: May 2010
Posts: 6,707
Original Poster
Yes. I've even tried without a card (and trying to connect to PKtether) which should see the camera. Nope either way.

Both ways work with the K-r though.

Both are set to MSC mode at the moment.
03-08-2017, 06:25 PM   #11
Pentaxian




Join Date: Sep 2012
Location: NY
Photos: Gallery | Albums
Posts: 3,464
The SD card being used should be fully formatted in the camera you are using prior to taking the images or using it in the computer. Use with other devices before the computer you are using other than your camera may effect the card depending on activity.

---------- Post added 03-08-17 at 08:33 PM ----------

You could possibly restore your computer to an earlier point in time (without losing files). That point being a time when you were communicating the computer and camera you are trying to read from.
03-08-2017, 07:40 PM   #12
Pentaxian




Join Date: Dec 2010
Location: Ontario
Photos: Gallery
Posts: 3,209
My random shots:

Since it has a drive letter, have you tried manually navigating to it in explorer? Click the address bar in any open folder and type in "K"?

Try restarting the computer with the camera plugged in and powered on?

Have you tried restoring the camera to factory default?

Do you have the latest camera firmware?

Best of luck!
03-08-2017, 09:37 PM - 1 Like   #13
mee
Pentaxian




Join Date: May 2010
Posts: 6,707
Original Poster
Thanks all. I got it working.. in a roundabout way.

My goal was to get back into the debug menu to convert my SDM lens to screwdrive. Turns out I didn't need the USB cable (into PKtether) to get to the debug menu.

Inserting:

[DEBUG_MODE EN]
[SW_DEBUG_MENU EN]
[OPEN_DEBUG_MENU]
[VLENS_CONTROL]

Into the 00077680.536 file (instad of just the [OPEN_DEBUG_MENU] as I was previously doing) actually let me access both debug mode and the deeper menu together. (With the K-5 II you need to keep the SD card door open and hold the MENU button while turning the camera on to get there)

I converted my SDM lens without issue. Then I was still playing around with the K-5 II trying to get the USB cable / mode working. Nothing was working until I disabled the debug mode in the camera. As soon as I did that the USB cable worked and the camera went into PC mode fully.... even though I didn't have debug mode enabled initially. I guess something needed to be cycled or something. Again strange (esp since I could see the Pentax camera just couldn't accses the SD data).

But it works now.
03-09-2017, 02:55 AM   #14
Moderator
Site Supporter
Loyal Site Supporter
MarkJerling's Avatar

Join Date: May 2012
Location: Wairarapa, New Zealand
Photos: Gallery | Albums
Posts: 10,402
Good to hear you got it sorted.
03-09-2017, 09:24 AM   #15
Pentaxian




Join Date: Sep 2012
Location: NY
Photos: Gallery | Albums
Posts: 3,464
Nice you were able to remedy the situation back to normal.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
cable with k-5, camera, card, computer, devices, k-5, mode, mode via usb, pc, pc mode, pentax help, photography, sd card, time, troubleshooting, usb, usb cable
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
PC Desktop tethering K-1 via WLAN works well beholder3 Pentax K-1 13 06-02-2018 01:30 AM
Help needed by anyone successful in getting K-5 ii to tether to Mac or PC gsrokmix Pentax K-5 2 07-07-2016 11:15 AM
Trouble Mounting an M42 lens via an M42-K Adapter onto K-mount Bodies fwcetus Pentax SLR Lens Discussion 9 09-19-2015 02:51 PM
K200D not able to connect to PC through USB cable ducdao Pentax DSLR Discussion 15 05-22-2011 11:53 AM
Getting my photos into my computer - cable or card reader GregX999 Troubleshooting and Beginner Help 27 09-10-2010 11:08 AM



All times are GMT -7. The time now is 10:00 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top