Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-17-2017, 03:14 AM   #1
Forum Member




Join Date: Jul 2012
Location: Tasmania
Photos: Gallery | Albums
Posts: 72
K1 stuck in 'M' mode

Not sure if I am overlooking something simple in the settings or if I am going to have to send my K1 in for servicing (hope not) but for the past couple of days my camera won't shift out of M mode.

I can spin the dial fine but it remains in M no matter what I set the mode too (Tv, Av etc). It is the same in live view or not.

Has anyone else experienced something like this? Hoping I don't have to send it off for servicing. It is still under warranty though of course.

Thanks in advance.

Luke

03-17-2017, 03:19 AM   #2
pjv
Otis Memorial Pentaxian
Moderator
Loyal Site Supporter
pjv's Avatar

Join Date: Mar 2015
Location: Melbourne, Australia
Photos: Gallery
Posts: 7,277
Hi Luke. Here is an older thread dealing with this. It might help you. Good luck.

https://www.pentaxforums.com/forums/190-pentax-k-1/323037-k1-stuck-manual-mode.html
03-17-2017, 03:48 AM   #3
Forum Member




Join Date: Jul 2012
Location: Tasmania
Photos: Gallery | Albums
Posts: 72
Original Poster
Thanks for the link pjv. It looks like I will have to send it in for repairs doesn't it. Bummer... I hope the turnaround time in Aus is ok, I have a few trips planned with it in the next month or so!
03-17-2017, 03:55 AM   #4
pjv
Otis Memorial Pentaxian
Moderator
Loyal Site Supporter
pjv's Avatar

Join Date: Mar 2015
Location: Melbourne, Australia
Photos: Gallery
Posts: 7,277
QuoteOriginally posted by LukeOB Quote
I hope the turnaround time in Aus is ok,
C.R. Kennedy in Melbourne is the Australian importer and is an authorized service center mate. They are usually good with services. Post some pix of your trip when you get back.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, k1, mode, pentax help, photography, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
To K1 or not K1 - that is the question? interested_observer Pentax K-1 78 07-15-2017 03:58 PM
My K1 flashes aperture, speed and ISO settings - any K1 users confirm please? pjaynz Pentax K-1 7 01-03-2017 12:57 PM
K1 stuck directional pad buttons turff Troubleshooting and Beginner Help 5 10-17-2016 07:02 PM
K1 stuck in manual mode ukspeedtraps Pentax K-1 50 10-05-2016 12:41 AM
KX stuck in autofocus, but switch is stuck in MF icywarm Troubleshooting and Beginner Help 4 08-07-2012 07:21 AM



All times are GMT -7. The time now is 01:56 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top