Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-04-2017, 10:55 PM   #1
Site Supporter
Site Supporter
grhazelton's Avatar

Join Date: Jul 2007
Location: Jonesboro, GA
Photos: Albums
Posts: 1,886
K 5 "locks up"??

Twice now in the last few days my K 5 with battery grip has "frozen." I press the shutter button, the mirror rises and .... the top display stays on, the mirror is up, the shutter is closed, and the on/off switch has no effect. The first time removing the battery grip restored proper operation, the second time I had to remove the grip and then the body battery to "fix" things.

The grip is used. One of the pins on the one it replaces had got bent and I couldn't fix it. I hadn't had this behavior with the old grip. Since the new-to-me grip is from KEH I think it is still under warranty.

Any suggestions?

04-04-2017, 11:23 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 48,462
Was the body battery full at the time the issues happened?

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com server and development costs are user-supported. You can help cover these costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

04-05-2017, 05:51 AM   #3
Veteran Member
p38arover's Avatar

Join Date: Mar 2012
Location: Western Sydney, Australia
Photos: Gallery | Albums
Posts: 3,085
It happened to my K-5 twice last week when I was using the DA* 60-250 I had to remove the battery to reset it each time. I did wonder if it was battery or lens related.

I wasn't using the grip.
04-05-2017, 09:47 AM   #4
Pentaxian




Join Date: Sep 2012
Location: NY
Photos: Gallery | Albums
Posts: 3,503
When something like that happens I turn the camera off, remove the battery, reinsert the battery, and turn the camera back on. Testing with just a battery in the camera battery chamber to see if the condition persists might be a good idea. If it happens when only using a battery grip, it may be isolated to that. Another scenario may be the battery(s) being used are low in power.

04-05-2017, 11:00 AM   #5
Pentaxian
Just1MoreDave's Avatar

Join Date: Feb 2007
Location: Aurora, CO
Photos: Gallery | Albums
Posts: 5,373
Some grip problems can be fixed by changing the Auto setting for which battery the camera uses.
04-05-2017, 12:56 PM   #6
Site Supporter
Site Supporter
grhazelton's Avatar

Join Date: Jul 2007
Location: Jonesboro, GA
Photos: Albums
Posts: 1,886
Original Poster
Thanks for the responses. As I remember the battery charge indicated full, for what its worth. I have the camera set to use the grip battery first, then the body, since the grip is so much easier to change. Guess I'll practice watchful waiting.... And check to see if I have the latest software!
04-06-2017, 06:34 PM   #7
Pentaxian




Join Date: Jun 2009
Location: GMT +10
Photos: Albums
Posts: 11,619
Those lockups have always been hard to diagnose because they are intermittent and hard to reproduce. Most times when my K-5 or K-3 would lockup, however, it was battery grip related.

I suspect the problem with grip-related lockups may be the numerous electrical contact points the grip introduces into the system, which makes the camera more vulnerable to one or two bad (oxidized, bent or dirty) contacts mis-behaving, and thus fouling up power delivery or camera control. And the firmware can't cope with this instability, hence the camera locks up.
04-10-2017, 04:16 AM   #8
Moderator
Site Supporter
Loyal Site Supporter
MarkJerling's Avatar

Join Date: May 2012
Location: Wairarapa, New Zealand
Photos: Gallery | Albums
Posts: 10,732
The only time my K-5 locks up, and then only very intermittently, is if I have my Sigma 70-300 lens on and I'm using AF and zooming at the 300mm end at the same time, while shooting 7fps. It won't do it with any other lens and, here's the odd thing, only when I don't have the battery grip fitted.

04-10-2017, 06:24 AM   #9
Loyal Site Supporter
Loyal Site Supporter
TER-OR's Avatar

Join Date: Apr 2009
Location: Dundee, IL
Photos: Gallery | Albums
Posts: 6,408
There was a fairly widespread issue with the K5 battery causing lockup. IIRC, fully charged the body battery is actually a bit overcharged and the voltage regulator in the camera freezes. The problem seems to dissipate after a few recharge cycles. Perhaps this is the problem, or a related one with the battery grip. It's a pain, because you have to remove the grip to remove the battery. I don't know if it helps, but at least it's not a serious hardware problem with the camera.
04-24-2017, 02:28 PM   #10
Site Supporter
Site Supporter
grhazelton's Avatar

Join Date: Jul 2007
Location: Jonesboro, GA
Photos: Albums
Posts: 1,886
Original Poster
Just an update. I've charged both the body and the grip batteries, the body battery doesn't seem to indicate a full charge when in the body, but the grip battery does. Could be a battery problem...so I'm just watching and waiting.

QuoteOriginally posted by TER-OR Quote
There was a fairly widespread issue with the K5 battery causing lockup. IIRC, fully charged the body battery is actually a bit overcharged and the voltage regulator in the camera freezes. The problem seems to dissipate after a few recharge cycles. Perhaps this is the problem, or a related one with the battery grip. It's a pain, because you have to remove the grip to remove the battery. I don't know if it helps, but at least it's not a serious hardware problem with the camera.
Good that its not a hardware problem. I'd like a K-1, but not right now!! Money, dontcha know.....
05-13-2017, 01:51 PM   #11
Site Supporter
Site Supporter
grhazelton's Avatar

Join Date: Jul 2007
Location: Jonesboro, GA
Photos: Albums
Posts: 1,886
Original Poster
Well, the problem hasn't recurred so I'm crossing my fingers and keeping a spare pair of fully charged batteries with me. Many thanks for those who posted.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
battery, camera, grip, mirror, pentax help, photography, shutter, time, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Using Astrotracer with K3II locks up with exposures over about 40 sec ddbarchitect Pentax K-3 2 05-10-2016 02:50 PM
Brand new K-3 locks up during picture playback mode wabibito Troubleshooting and Beginner Help 11 11-04-2015 09:19 AM
K-50 continually locks up / freezes snej Troubleshooting and Beginner Help 3 10-17-2015 09:03 PM
K-30 - control wheel locks up jptreen Pentax K-30 & K-50 10 09-09-2012 09:35 PM
K200 locks up bpeek73 Pentax DSLR Discussion 2 11-30-2009 03:02 PM



All times are GMT -7. The time now is 04:19 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top