Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-18-2017, 03:33 PM   #1
Veteran Member
Pauld's Avatar

Join Date: Nov 2009
Location: Calgary, Alberta
Photos: Gallery | Albums
Posts: 507
K5 focusing electronics failure???

I just sent my K5 into Pentax Canada to see what they think the issue may be. What has been happening is that upon start up the camera is frozen in f8/125 and stays locked there. After about 5-10 minutes it used to unfreeze and I had full control of the camera. Lately it has stayed stuck and would not come out of f8. I tried every possible button configuration possible and they only thing that worked a couple times is if I changed it from 11 points to 5 which would free up the controls. That stopped working unfortunately. I also noticed that if I changed the dial on the back to selective focus I wasn't able to change the focal point I wanted to use. Also if I tried live view the screen was black and all the data on the bottom of the screen would be flashing like mad. I am curious if anyone else has heard of or had these same issues. I am really curious to see what Pentax has to say the issue is.

09-18-2017, 03:50 PM   #2
Moderator
Site Supporter
Loyal Site Supporter
MarkJerling's Avatar

Join Date: May 2012
Location: Wairarapa, New Zealand
Photos: Gallery | Albums
Posts: 15,279
Did you try a firmware update?
09-18-2017, 05:14 PM   #3
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 49,839
QuoteOriginally posted by Pauld Quote
I just sent my K5 into Pentax Canada to see what they think the issue may be. What has been happening is that upon start up the camera is frozen in f8/125 and stays locked there. After about 5-10 minutes it used to unfreeze and I had full control of the camera. Lately it has stayed stuck and would not come out of f8. I tried every possible button configuration possible and they only thing that worked a couple times is if I changed it from 11 points to 5 which would free up the controls. That stopped working unfortunately. I also noticed that if I changed the dial on the back to selective focus I wasn't able to change the focal point I wanted to use. Also if I tried live view the screen was black and all the data on the bottom of the screen would be flashing like mad. I am curious if anyone else has heard of or had these same issues. I am really curious to see what Pentax has to say the issue is.
My guess would be a broken or suck button, or a loose cable internally causing weird signals to be sent.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com server and development costs are user-supported. You can help cover these costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, KEH, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

09-18-2017, 09:43 PM   #4
Veteran Member
Pauld's Avatar

Join Date: Nov 2009
Location: Calgary, Alberta
Photos: Gallery | Albums
Posts: 507
Original Poster
QuoteOriginally posted by MarkJerling Quote
Did you try a firmware update?
Firmware is up to date.

---------- Post added 09-18-2017 at 10:45 PM ----------

QuoteOriginally posted by Adam Quote
My guess would be a broken or suck button, or a loose cable internally causing weird signals to be sent.
It's definitely something internal be it electronics or hardware. I'll just have to wait to see what the big guys say.

10-23-2017, 11:58 AM   #5
Veteran Member
Pauld's Avatar

Join Date: Nov 2009
Location: Calgary, Alberta
Photos: Gallery | Albums
Posts: 507
Original Poster
Finally heard back this morning from the repair company. It's a short circuit on the main circuit board. They said they would have to replace the whole circuit board and that it would cost 500 bucks. I told him no thanks since the body is not worth that much. Needless to say I'm on the look out for a new to me K5 body.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, firmware, issue, k5, k5 focusing electronics, pentax, pentax help, photography, screen, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Life pro tips. Don't use rice to dry electronics. swanlefitte General Talk 3 06-11-2017 06:04 AM
Electronics ban on flights to Middle East countries Dericali Pentax DSLR Discussion 24 03-23-2017 07:13 PM
How often lens electronics fails? snimcho Pentax SLR Lens Discussion 8 06-25-2016 08:50 AM
Request: I would love to see the reading of the electronics level in the meta data PeterL Pentax DSLR Discussion 14 03-30-2016 08:51 PM
Samsung Electronics to split activites between Consumer Electronics and Components ghelary Pentax News and Rumors 3 01-18-2009 04:36 AM



All times are GMT -7. The time now is 06:21 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top