Forgot Password
Pentax Camera Forums Home
 

Closed Thread
Show Printable Version Search this Thread
04-18-2018, 06:04 PM   #1
Pentaxian
BirdDude007's Avatar

Join Date: Jun 2009
Location: Las Vegas NV
Photos: Albums
Posts: 652
Help!!! K01 issues!

Ya I know I should be most likely posting this in the K01 threads but I thought if I put it out here then it would get more views and input. I just received a K01 from a member in this forum and it has a certain issue when I mount DC/
SDM lenses on it. the camera basically freaks out, it makes a sound like it is searching for either focus or something to do with positioning of the sensor, it makes a sound from inside the camera about once every second. The rear screen displays that the camera is in Manual mode and I cannot access anything else in the camera.
However when I mount either a manual lens or a screw drive lens, the camera works fine.
Now.....I actually kinda like this neat little camera and it looks like I will really enjoy using one, and I would hate to have to return the camera to the seller, but I really need a solution to make it so my DC/SDM lenses will work on it.
I HAVE done as much research as I could on here but have come up empty handed. folks in here say the camera is most likely not communicating with the lens via focusing contacts. I have cleaned the contacts with my camera cleaning kit, and I even updated the firmware, but no luck there. so.....if anyone in here knows what I can do, I would really appreciate it

04-18-2018, 07:47 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 47,777
My only thought is the battery might have gone bad. Other than that the most likely explanation is faulty hardware.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com server and development costs are user-supported. You can help cover these costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

04-18-2018, 10:26 PM   #3
pjv
Moderator
Loyal Site Supporter
Loyal Site Supporter
pjv's Avatar

Join Date: Mar 2015
Location: Melbourne, Australia
Photos: Gallery
Posts: 5,712
There is another thread in the K-01 forum for further replies to this post. Thanks.

DC/SDM issue - PentaxForums.com
Closed Thread

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, contacts, k01, lens, lenses, pentax help, photography, sound, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
is the pentax k01 still worth buying in 2017 ? Abrar420 Pentax K-01 42 12-23-2017 10:30 AM
My K01 gets hot paulpines Pentax K-01 4 11-17-2017 08:01 PM
AF 201FG on K01 Cata'S Pentax K-01 2 01-13-2017 01:39 AM
New to K01 : help me choose my first prime? skawa Pentax K-01 12 03-08-2014 09:53 PM
Help!!! I have had 3 k01's, ALL with focus issues JF Jayhawk Pentax K-01 11 04-28-2013 01:13 PM



All times are GMT -7. The time now is 06:17 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top