Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-05-2018, 11:59 AM   #1
New Member




Join Date: Jul 2013
Location: New Hampshire
Posts: 13
18-250mm lens F-stop issue

I have a Pentax 18-250mm lens that all of a sudden the F-stop has stopped working. I have tried it on my K3 and K5iis with the same result. No matter where I set the Fstop all the pics are the same. This happens in AF of MF mode. When in AF mode the AF is spotty and doesn't always focus, possibly a motor issue as that sounds a little funny also. Has anyone else had this issue? The lens is 10 years old and I have tried cleaning the contacts, tightening screws, etc.

Thanks

Phil

08-05-2018, 12:20 PM   #2
Loyal Site Supporter
Loyal Site Supporter




Join Date: Feb 2010
Location: Maryland
Posts: 449
Aperture control lever is probably sticking. If you have the right screwdriver you can remove the three retaining screws on the bottom of the lens and check the lever. May be slightly bent and binding. My copy had that problem.
08-05-2018, 12:40 PM   #3
New Member




Join Date: Jul 2013
Location: New Hampshire
Posts: 13
Original Poster
Any chance you have a picture of what screws I need to remove and the lever?

Last edited by PD63; 08-05-2018 at 12:46 PM.
08-05-2018, 01:15 PM - 1 Like   #4
Loyal Site Supporter
Loyal Site Supporter




Join Date: Feb 2010
Location: Maryland
Posts: 449
Bottom should look like this. Four screws and lever is at left. The lever should be spring loaded and return to small aperture upon release. Start by loosening screws and see if the lever frees up. If not you can remove them all and check the lever. Mine was binding to the the side of the lens mount. Pay attention to the screw at photo right. If over tight it can make the opposing lever bind. Very little tolerance in spacing for that lever.

Since it canít get to open aperture for focusing and viewfinder brightness, this can make focusing malfunction also. First thing to do is check to make sure the spring will close the aperture.

Attached Images
View Picture EXIF
IPhone 6s Plus  Photo 

Last edited by Pentax Syntax; 08-05-2018 at 01:39 PM.
08-05-2018, 01:38 PM - 1 Like   #5
New Member




Join Date: Jul 2013
Location: New Hampshire
Posts: 13
Original Poster
Ok, thanks. That is definitely the issue. I can move the lever but it does not spring back. I can see the spring next to the lever. I loosened the screws and then tightened them back up again it seems to be ok now. One screw may have been a little to tight. Thanks for your help it is much appreciated!
08-05-2018, 01:39 PM   #6
Loyal Site Supporter
Loyal Site Supporter




Join Date: Feb 2010
Location: Maryland
Posts: 449
QuoteOriginally posted by PD63 Quote
Ok, thanks. That is definitely the issue. I can move the lever but it does not spring back. Thanks for your help it is much appreciated!
No problem

Glad I could help 😊
08-05-2018, 01:45 PM   #7
New Member




Join Date: Jul 2013
Location: New Hampshire
Posts: 13
Original Poster
Huge help, I was getting ready to buy a new lens! This lens is 10 years old I just figured it was on it's last leg as it is pretty much my go to lens. Thanks again!
08-05-2018, 01:51 PM - 1 Like   #8
Loyal Site Supporter
Loyal Site Supporter




Join Date: Feb 2010
Location: Maryland
Posts: 449
One of my favorite travel lenses. Hope to keep mine going for many more years. It used to live on my K-7 and K-3 before I got the 16-85. Still the 18-250 gets lots of use when I want to go light.

08-05-2018, 02:06 PM   #9
New Member




Join Date: Jul 2013
Location: New Hampshire
Posts: 13
Original Poster
I use that lens the most and the 24-70...I bought that so I'd have something for the K1 when I get it...
08-05-2018, 02:37 PM   #10
Loyal Site Supporter
Loyal Site Supporter




Join Date: Feb 2010
Location: Maryland
Posts: 449
I think you will like full frame. I use the K-1ii and upgraded K-1 for everything other than hiking. Nice for car trips. To much mass for me to lug around
08-05-2018, 02:49 PM   #11
New Member




Join Date: Jul 2013
Location: New Hampshire
Posts: 13
Original Poster
I do lots of landscape photography so I am sure I'll like it for that. I also hike a lot, I bought a little fujifilm XP120 16mp camera for hiking to lighten the load a bit but, I think I took it on one hike without my K3 and now I take both. I use the K3 with the 18-250 the fuji for video. So you got the K1 and upgrade to the K-1ii? How do you like it, is the upgrade worth it?
08-05-2018, 05:08 PM   #12
Loyal Site Supporter
Loyal Site Supporter




Join Date: Feb 2010
Location: Maryland
Posts: 449
I thought the upgrade was definitely worth it. Bought the K-1ii preorder and evaluated it for a couple of months compared to my faithful K-1. It is equal to, or better than the K-1 for all of my applications . Autofocus seems much improved and the dynamic pixel shift can really pull the most out of landscapes. Worth the slight price increase if you are buying new. I thought of it as insurance against future developments.
08-05-2018, 08:09 PM   #13
New Member




Join Date: Jul 2013
Location: New Hampshire
Posts: 13
Original Poster
Thats good to know. I was thinking of the K1 at the discounted price, but I will probably just go with the K-1ii instead. Thanks for the input.
10-06-2018, 07:39 AM   #14
New Member




Join Date: Jul 2013
Location: New Hampshire
Posts: 13
Original Poster
I thought I would ask you this before posting the question in a forum, seeing you were able to help me with my last issue? I have a Mac and d/l my pics to I-Photo. When I am in info mode going through pics it shows which camera and lens was used. However, for some reason it does not show which lens when I use my Pentax 24-70mm or my Sigma 18-300mm, any idea why?
10-18-2018, 03:55 PM   #15
Loyal Site Supporter
Loyal Site Supporter




Join Date: Feb 2010
Location: Maryland
Posts: 449
QuoteOriginally posted by PD63 Quote
I thought I would ask you this before posting the question in a forum, seeing you were able to help me with my last issue? I have a Mac and d/l my pics to I-Photo. When I am in info mode going through pics it shows which camera and lens was used. However, for some reason it does not show which lens when I use my Pentax 24-70mm or my Sigma 18-300mm, any idea why?
The EXIF info is a little variable depending upon the lens. With the Sigma, it may not be able to confer the information from the body. Most Pentax lenses should convey the information. What happens when you use a third party EXIF reader? I like an iphone app called Investigator.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
18-250mm, 18-250mm lens f-stop, af, camera, f-stop, issue, lens, mode, pentax help, photography, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Which Zoom Lens? "Tamron AF 18-250mm", "Pentax-DA 18-250mm" or "Sigma 18-250mm" hoomanshb Pentax SLR Lens Discussion 4 07-30-2010 09:50 AM



All times are GMT -7. The time now is 10:16 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top