Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-11-2018, 11:01 PM   #1
New Member




Join Date: Sep 2018
Posts: 3
Problems using Pentax K-30

Dear all,
I am amateur photomaker and I do not know much about functioning of DSLR Pentax K-30 camera.
I would like to share with you all , my difficulties using Pentax K-30.
I own this camera since begining of year 2013.
When I am turning on camera, and start making photos , first 4-5 photos are perfect .
But after taking this 4-5 photos, when I want to continue with photos, camera is focusing and start first step making a short noice(“shkrap”), and is blocked. I think some photo taking process inside of camera is stocked, it is not finishing proccess till the end.
Usually I am taking out battery for 4-5 days, and just after several days without battery, and after replacing back battery , it can make again 3-5 pictures and again blocked.
Can somebody advice me what is the wrong with my camera and how can I fix this problem.
Thank you in advance

09-11-2018, 11:06 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 48,223
Have you tried a different lens, or removing and re-mounting your lens?

Another possible issue, assuming the camera hardware is OK, is a failing battery. This wouldn't be surprising after 5 years of use.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com server and development costs are user-supported. You can help cover these costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

09-12-2018, 08:51 AM   #3
Senior Member




Join Date: Apr 2017
Posts: 235
.."When I am turning on camera, and start making photos , first 4-5 photos are perfect .
But after taking this 4-5 photos, when I want to continue with photos, camera is focusing and start first step making a short noice(“shkrap”), and is blocked. I think some photo taking process inside of camera is stocked, it is not finishing proccess till the end."

I guess the problem is the camera card. Reset the camera and use another formatted SDHC card.
09-13-2018, 12:09 AM   #4
New Member




Join Date: Sep 2018
Posts: 3
Original Poster
QuoteOriginally posted by Adam Quote
Have you tried a different lens, or removing and re-mounting your lens?

Another possible issue, assuming the camera hardware is OK, is a failing battery. This wouldn't be surprising after 5 years of use.
Thank you for your help Adam.

I tried with different lences and also I have a battery adapter for ordiner AA batteries( I am using DURACELL brand), but after several shots, again camera is "stocked".
Thanks again

---------- Post added 09-13-18 at 01:01 AM ----------

QuoteOriginally posted by Penview52 Quote
.."When I am turning on camera, and start making photos , first 4-5 photos are perfect .
But after taking this 4-5 photos, when I want to continue with photos, camera is focusing and start first step making a short noice(“shkrap”), and is blocked. I think some photo taking process inside of camera is stocked, it is not finishing proccess till the end."

I guess the problem is the camera card. Reset the camera and use another formatted SDHC card.
Thank you very much for your reapond.
I did not imagine that problem could be with memory card. I will formatt one of SDHC card and try it.

Thanks again

---------- Post added 09-13-18 at 01:01 AM ----------

QuoteOriginally posted by Penview52 Quote
.."When I am turning on camera, and start making photos , first 4-5 photos are perfect .
But after taking this 4-5 photos, when I want to continue with photos, camera is focusing and start first step making a short noice(“shkrap”), and is blocked. I think some photo taking process inside of camera is stocked, it is not finishing proccess till the end."

I guess the problem is the camera card. Reset the camera and use another formatted SDHC card.
Thank you very much for your reapond.
I did not imagine that problem could be with memory card. I will formatt one of SDHC card and try it.

Thanks again

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
battery, blocked, camera, card, days, k-30, lens, memory, pentax, pentax help, photography, photos, proccess, reset, sdhc, thanks, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems using On1 Photo RAW with 645Z files tar4heel2 Pentax Medium Format 20 08-11-2018 09:36 AM
Solving AF Problems - 8 Common Autofocus Problems - And Their Solutions interested_observer General Photography 17 04-27-2016 03:06 AM
Anybody with mirror problems with K30? Focus problems. simbon4o Pentax K-30 & K-50 14 08-28-2013 10:39 PM
Any freezing problems with K30?(like those with K5) or any other problems? simbon4o Pentax K-30 & K-50 21 01-03-2013 01:54 PM
Need help with exposure problems and snow photography problems, urgent please respond montezuma Photographic Technique 7 02-24-2008 05:43 PM



All times are GMT -7. The time now is 01:40 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top