Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-26-2018, 08:22 AM   #1
New Member




Join Date: Sep 2018
Posts: 2
SMC Pentax-F 50mm F1.7 auto focus issue on K1 M2

Everytime when I put SMC Pentax-F 50mm F1.7 on k1 m2, this lens can not auto focus. I must turn the aperture ring from "A" to 1.7 and then turn it back to "A". After that auto focus started working.

I do not understand why. Is this lens just working like this? Or maybe I can change the setup on the camera to let auto focus work right away?

Thanks.

09-26-2018, 08:34 AM   #2
Moderator
Not a Number's Avatar

Join Date: Mar 2012
Location: Venice, CA
Posts: 5,868
The contacts probably could stand a cleaning. Try wiping them down with a microfiber cloth. Pay particularly close attention to the "data" and "A". The data pin corresponding to the 6 o'clock position of the camera face. The "A" should stick out a bit more than the other pins. It may retract a bit when you take the ring off the "A" setting and pop out a bit in the "A" setting. The pin might be a bit sticky so it doesn't pop out when you first mount the lens. Changing the ring setting might give it the nudge it needs to pop out. A tiny dab of alcohol or lighter fluid applied and immediately removed with a cotton swab might do the trick on cleaning away the stickiness.
09-26-2018, 09:20 AM   #3
Otis Memorial Pentaxian
Loyal Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 32,464
I agree that this is probably a contact issue. To expand on @Not_a_Number 's excellent advice, the camera attempts to detect the "A" contact followed by the "data" contact. If either is dirty or not functioning properly, AF will not work.


Steve
09-26-2018, 09:24 AM   #4
Senior Member




Join Date: Apr 2017
Posts: 235
I must turn the aperture ring from "A" to 1.7 and then turn it back to "A". After that auto focus started working.



Maybe the lens contact pins is not well aligned to the camera body. Try turning the lens a little bit left of A settings, if auto focus works , then turn a little bit of right if auto focus works... whichever.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
50mm, 50mm f1.7 auto, auto, auto focus issue, camera, f1.7 auto focus, focus, issue on k1, m2, pentax help, pentax-f 50mm f1.7, photography, smc pentax-f 50mm, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Looking for Ricoh WG-M2 firmware gedasst Pentax Compact Cameras 3 05-08-2018 03:20 AM
For Sale - Sold: Ricoh WG-M2 4K Action Camera Mikesul Sold Items 4 11-15-2017 11:54 AM
SMC Pentax A f1.4 50mm VS SMC Pentax M f1.4 50mm plunkstar Troubleshooting and Beginner Help 30 12-31-2015 09:04 AM
[Asking]SMC Pentax K 50mm f1/4 VS Pentax-M 50mm f1.4 VS Pentax-M 50mm f1.7 ? liemjerry Pentax SLR Lens Discussion 29 07-08-2015 04:23 PM



All times are GMT -7. The time now is 06:52 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top