Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-03-2019, 01:07 PM   #1
Site Supporter
Site Supporter




Join Date: Oct 2017
Location: Lancaster
Photos: Gallery
Posts: 809
Lens causing K3 menu to not stay on.

Hi
I took my K3 and 18-135mm out today in the rain. All was well. I dried it when I got home, still fine, now, when I press the menu or info button the menu flashes on then goes back to the main screen. This started happening just after I set my af to back button. Any ideas?

Edit: it’s the lens. My K3 works fine with other lenses but my 18-135 makes it have a fit. Any suggestions?


Last edited by Cerebum; 02-03-2019 at 01:22 PM.
02-03-2019, 01:49 PM - 1 Like   #2
Pentaxian




Join Date: Dec 2016
Posts: 1,681
Does it still do it if you set your AF to use the shutter button half-press for AF?
02-03-2019, 02:48 PM - 2 Likes   #3
hcc
Pentaxian
hcc's Avatar

Join Date: Nov 2009
Location: Brisbane, Australia
Photos: Gallery | Albums
Posts: 3,643
I would suspect that the camera is not 100% dry. I shoot often in the rain and I always dry carefully my cameras afterwards.

I recommend that you put back to drying both your camera and lens. Place both separately in a dry (to very dry) place for at least 24 hours. Remove the battery from the camera body and do leave the battery door open. Make sure that the camera is off (off course). Similarly, dry first your battery, then give it a full charge. Also, extend your DA-18-135mm to maximum zoom (barrel length) to dry it properly, after a gentle wipe with a dry cloth.

You might also need to reset your camera settings, if the above does not solve it.

Hope that these may help.

Last edited by hcc; 02-03-2019 at 03:12 PM.
02-03-2019, 03:12 PM - 1 Like   #4
Site Supporter
Site Supporter




Join Date: Oct 2017
Location: Lancaster
Photos: Gallery
Posts: 809
Original Poster
Thanks guys. Re the camera, that works fine with all my other lenses. Re the 18-135, it seems to be working again but I have left it somewhere lol warm and dry where it is staying for a few days. Thatís the last time I risk it in the rain, I nearly had a heart attack

02-03-2019, 05:27 PM   #5
Pentaxian




Join Date: Jun 2015
Location: South West UK
Photos: Albums
Posts: 1,453
QuoteOriginally posted by Cerebum Quote
Thanks guys. Re the camera, that works fine with all my other lenses. Re the 18-135, it seems to be working again but I have left it somewhere lol warm and dry where it is staying for a few days. Thatís the last time I risk it in the rain, I nearly had a heart attack
Yes, the Weather Resistance is only resistant to weather as long as it's not particularly wet weather.
02-03-2019, 05:46 PM   #6
Pentaxian




Join Date: Dec 2016
Posts: 1,681
Evidently, some moisture got to the lens/camera contacts. If the interface between lens and camera is not perfectly clean, there can be a tiny gap or break in the contact and WR seal. A good idea to keep the lens mount and contacts clean on both lens and on camera. I have often wondered also if these WR sealing rings eventually do wear and need to be replaced.

I have also noticed that even as high on the totem pole as are the Limited primes, they do not incorporate WR in their designs, which is sometimes a criticism. But they are so conservatively formulated, they still even use the old screw-driven AF, indicating the primary interest being in reliability and low maintenance.
02-04-2019, 09:22 AM - 1 Like   #7
Seeker of Knowledge
Loyal Site Supporter
aslyfox's Avatar

Join Date: Aug 2016
Location: Topeka, Kansas
Photos: Gallery | Albums
Posts: 13,467
this thread might be of interest to the OP and others

" About those WR body weather seals...User responsibility and best practice "

https://www.pentaxforums.com/forums/6-pentax-dslr-discussion/351252-about-th...ml#post4073115
02-06-2019, 03:15 AM   #8
Site Supporter
Site Supporter




Join Date: Oct 2017
Location: Lancaster
Photos: Gallery
Posts: 809
Original Poster
QuoteOriginally posted by aslyfox Quote
this thread might be of interest to the OP and others

" About those WR body weather seals...User responsibility and best practice "

About those WR body weather seals...User responsibility and best practice - Page 4 - PentaxForums.com
Thanks

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
button, camera, k3, k3 menu, menu, pentax help, photography, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Staying In kcjonez Monthly Photo Contests 5 12-11-2018 08:44 AM
Error Mobile Skin not staying logged in DeadJohn Site Suggestions and Help 2 02-03-2017 01:43 PM
K3 with USB not staying connected CopyRon Video and Pentax HDSLRs 3 06-28-2014 10:37 AM
User settings not staying after power off? SpartanD63 Pentax K-30 & K-50 3 02-06-2013 01:03 AM
Did you convert to your religion, if not why are you staying? troglodyte General Talk 11 08-20-2010 09:36 AM



All times are GMT -7. The time now is 02:29 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top