Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-03-2019, 07:50 PM   #1
New Member




Join Date: Apr 2019
Posts: 1
K-1:28-105mm kit lens not shooting consistently with the viewfinder

Hello everyone - hoping to get some insights into problem with the 28-105mm kit lens. I'm still a beginner.

When using the viewfinder, when I press to focus, it doesn't do so consistently (i.e. there is not movement of the lens to focus) and then won't shoot. This will happen in Av, Auto and other modes. Sometimes it will focus and shoot but I haven't been able to find any pattern as to when it will work vs not.

By contrast, if I go to Live view, it works fine. When I use other lenses, they work fine too.

I suspect there is a problem with my lens but want to rule out there isn't something else going on with the camera or the settings.

Appreciate any help!

04-03-2019, 08:05 PM   #2
Moderator
Site Supporter
Loyal Site Supporter
MarkJerling's Avatar

Join Date: May 2012
Location: Wairarapa, New Zealand
Photos: Gallery | Albums
Posts: 14,557
QuoteOriginally posted by rainmaker889 Quote
Hello everyone - hoping to get some insights into problem with the 28-105mm kit lens. I'm still a beginner.

When using the viewfinder, when I press to focus, it doesn't do so consistently (i.e. there is not movement of the lens to focus) and then won't shoot. This will happen in Av, Auto and other modes. Sometimes it will focus and shoot but I haven't been able to find any pattern as to when it will work vs not.

By contrast, if I go to Live view, it works fine. When I use other lenses, they work fine too.

I suspect there is a problem with my lens but want to rule out there isn't something else going on with the camera or the settings.

Appreciate any help!
Welcome to the forum.
Are you experiencing this problem in bright daylight?
Can you get good focus with it when focussing manually?
04-04-2019, 06:27 AM   #3
Senior Member
Hogdriver's Avatar

Join Date: Feb 2014
Location: Freedom Isn't Free
Posts: 102
Rainmaker welcome.
For what its worth....
Please consider cleaning/checking the contacts on your lens and camera. And ensure lens focus switch is set to auto verse manual.
Hope fix is simple.
04-04-2019, 06:52 AM   #4
Pentaxian
normhead's Avatar

Join Date: Jun 2007
Location: Near Algonquin Park
Photos: Gallery | Albums
Posts: 36,240
When this happens to me it is almost always because my finger has set the focus point to one of the edges, and I'm trying to focus on the middle of the frame.

04-04-2019, 08:10 AM   #5
Pentaxian




Join Date: Feb 2015
Photos: Gallery | Albums
Posts: 7,914
That's weird. I've never had anything similar. LV AF doesn't know when the lens is focused relative to target so it will proceed to an AF routine in any case. PDAF is different in a way that the sign of the phase indicate how to rotate in lens motor to move the lens elements forward or backwards. According to the description, it looks like the PDAF isn't able to know which way to go (forward or backward) and obviously unable to lock focus as a result. Lens/PDAF sensor issue IMO, it means the camera may also be responsible for the issue even if it works works with other lenses. Try AF.C instead of AF.S just to check that the AF does.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, focus, k-1:28-105mm kit lens, kit, lens, pentax help, photography, troubleshooting, viewfinder
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
D-FA 28-105mm lens vs. older FA 28-105mm lenses. Anyone? 6BQ5 Pentax SLR Lens Discussion 14 03-16-2018 06:57 PM
Fastest M-Mode ever... if the Green Button was implemented consistently -.- Bromberger Pentax DSLR Discussion 19 03-22-2017 10:39 AM
Flash on 645n not consistently working BDK Flashes, Lighting, and Studio 7 02-01-2017 12:21 PM
Help! Automatic Flash not working consistently cameramom Troubleshooting and Beginner Help 8 06-11-2011 11:09 AM
Why does Pentax consistently UNDER-EXPOSE and usually under-saturate images? PentaxForums-User Pentax DSLR Discussion 122 07-12-2010 06:14 AM



All times are GMT -7. The time now is 12:24 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top