Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-18-2019, 07:43 PM   #1
Site Supporter
Site Supporter




Join Date: Jan 2017
Posts: 19
Shutter/Mirror issues for K3ii

My K3ii is just over a year old and has performed well up until now. A week ago, I wanted to get some pics of my granddaughter in her marching band exhibition. The first picture worked as usual but after that, there was an extra noise coming from inside the camera, and the picture came out black on the review. It continued this way for the rest of the shoot, and it is still doing it. I removed the lens and watched inside as the shutter was activated., I have sent a video showing what happens. Hopefully it plays. Make sure you have volume turned up. It's very frustrating, and I no longer want to use it until I get this resolved. Any info you can send to me will be greatly appreciated.

Attached Files
File Type: avi Untitled.avi (237.6 KB, 53 views)
05-18-2019, 07:46 PM   #2
Moderator
Site Supporter
Loyal Site Supporter
MarkJerling's Avatar

Join Date: May 2012
Location: Wairarapa, New Zealand
Photos: Gallery | Albums
Posts: 10,704
I can't get that avi to play Dave. Would you like to try to post it to Youtube and post the link here?
05-18-2019, 07:52 PM   #3
Otis Memorial Pentaxian
Loyal Site Supporter
RobG's Avatar

Join Date: Dec 2009
Location: Canberra
Photos: Gallery | Albums
Posts: 4,378
I think people are calling it mirror slap. Have you upgraded the firmware? Tried taking out the battery? My K3 has done it a couple of times, but returns to normal after a second or two.
05-18-2019, 08:04 PM   #4
Senior Member




Join Date: Oct 2018
Location: Tokyo
Posts: 194
I can't play the video either. looks like the file has a problem. If you can upload to youtube and give us link here, we should be able to see what is it.
if it is a mirror lock up problem, you won't be able to take a photo and it could be fixed by remove battery. However from what you said it sound like you still can take photo? Not really sure what it is you are having.

by the way, On my K3, some Pentax's battery cause mirror lock up problem. I avoid using that battery.
Update firmware to the latest one help camera return mirror to normal position when turn camera on/off. otherwise, as mentioned, remove the battery.


Last edited by tokyoscape; 05-18-2019 at 08:13 PM.
05-18-2019, 08:36 PM   #5
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 48,446
I was able to open the file using VLC. No audio, though

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com server and development costs are user-supported. You can help cover these costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

05-18-2019, 11:06 PM   #6
Otis Memorial Pentaxian
Loyal Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 32,707
QuoteOriginally posted by davefraser54 Quote
The first picture worked as usual but after that, there was an extra noise coming from inside the camera, and the picture came out black on the review.
What you are describing sounds like the detect/recovery behavior included on the v1.11 firmware update for the K-3. The intent of the patch was to detect the so-called K-3 runaway mirror problem* when it occurs. While the firmware patch did not correct the problem, it helped avoid damage to the mirror mechanism until a repair could be done by aborting the exposure sequence with a resulting blank frame. Ricoh/Pentax also provided an actual fix for the problem itself, but which required installation of new low-level firmware for the mirror controller board. The fix was available as a warranty repair or for a fee for cameras already out of warranty.

That being said, the issue was resolved in production for all K-3 produced after fall of 2014. I don't recall whether anything similar has been reported and confirmed in the K-3II. If your K-3II was purchased from an authorized dealer in Canada, it should still be covered by the two-year Pentax Canada warranty. They would be your best resource in getting a proper diagnosis and repair done.


Steve

* The runaway mirror problem was distinct and different from the "mirror flap" (aka "mirror flop") issue reported on some K-5 and lower-model Pentax bodies (e.g. K-r). The mechanism on the K-3, K-3II, and KP is dissimilar to that on those cameras and has never shown that problem.

Last edited by stevebrot; 05-18-2019 at 11:27 PM.
05-19-2019, 06:41 AM   #7
Otis Memorial Pentaxian
Loyal Site Supporter
RobG's Avatar

Join Date: Dec 2009
Location: Canberra
Photos: Gallery | Albums
Posts: 4,378
QuoteOriginally posted by stevebrot Quote
* The runaway mirror problem was distinct and different from the "mirror flap" (aka "mirror flop") issue reported on some K-5 and lower-model Pentax bodies (e.g. K-r). The mechanism on the K-3, K-3II, and KP is dissimilar to that on those cameras and has never shown that problem.
Ah. I didn't know that. In all the time I've had the K5iis I don't think it's had an issue, and the "runaway" mirror behaviour has only happened a couple of times, I think, and was easily resolved by cycling the power. I didn't know that there was a "real" fix for the problem, so thanks for mentioning it! Maybe I should use the K5iis for a while and send the K3 back for repair...
05-19-2019, 10:05 AM   #8
Site Supporter
Site Supporter




Join Date: Jan 2017
Posts: 19
Original Poster
Thanks for the replies. To start the process of elimination, I have 5 batteries and the problem exists with all of them. I checked the firmware and I have the latest version (1.10). I will try to upload the video to YouTube and post the link.

The camera was purchased from Amazon. I will check to see if they keep the two year warranty.

I will try to post again sometime today.

---------- Post added 05-19-19 at 11:32 AM ----------

Here is the link to YouTube -


05-19-2019, 11:07 AM   #9
Otis Memorial Pentaxian
Loyal Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 32,707
QuoteOriginally posted by davefraser54 Quote
The camera was purchased from Amazon. I will check to see if they keep the two year warranty.
They are authorized in the U.S. and should be in Canada. Check with Ricoh/Pentax Canada. They will know.

I watched the video. This does not look to be something for which there is a user work-around.


Steve
05-19-2019, 12:49 PM   #10
Site Supporter
Site Supporter




Join Date: Jan 2017
Posts: 19
Original Poster
QuoteOriginally posted by stevebrot Quote
They are authorized in the U.S. and should be in Canada. Check with Ricoh/Pentax Canada. They will know.

I watched the video. This does not look to be something for which there is a user work-around.


Steve
QuoteOriginally posted by stevebrot Quote
I watched the video. This does not look to be something for which there is a user work-around.
Thanks, Steve. I'll post any pertinent details if and when I get this solved.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, k3ii, link, mirror malfunction, pentax help, photography, picture, post, shutter malfunction, shutter/mirror issues, troubleshooting, youtube
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K3ii - SD card issues jmerchant Troubleshooting and Beginner Help 10 01-01-2019 03:41 PM
K3II - Mirror Stuck sutherland Pentax K-3 15 07-17-2018 08:36 AM
New K3II mirror runaway still occurs? Chris Mak Pentax K-3 24 06-29-2018 06:07 PM
mirror flop? shutter issues, vibrations... wes k Pentax K-r 23 08-19-2015 05:38 AM
S3 and S1a shutter & mirror return issues? 35mmGun Pentax Film SLR Discussion 8 08-15-2011 05:43 AM



All times are GMT -7. The time now is 11:57 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top