Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-11-2019, 07:27 PM   #1
New Member




Join Date: Nov 2012
Posts: 8
Pentax MX Rapid-Wind Lever Sticking Partway Through Rolls

Hi All,

Today my Pentax MX rapid-wind lever began sticking (about a third of the way through a full cock) partway through 2 rolls of film - at about the 25th frame. When it sticks, I can get it going by depressing the film rewind button to cock it all the way. I can then fire off a shot, but when I attempt to cock it again (film rewind button now back to its default position) the rapid-wind lever locks up again. Without film loaded the camera cocks and fires at all speeds without a hitch. Has now happened partway through 2 rolls of film, which I decided to rewind into the canister in order to test the camera - works fine with no film in it. Thoughts?


Thanks!


Last edited by pepperberry farm; 07-11-2019 at 08:33 PM.
07-11-2019, 08:05 PM   #2
Pentaxian
arnold's Avatar

Join Date: Aug 2012
Location: Queensland
Photos: Gallery | Albums
Posts: 3,582
Welcome. It seems you are coming to the end of the film. Have you checked the counter? It may not be recording each shot.
07-12-2019, 03:12 AM   #3
Pentaxian
35mmfilmfan's Avatar

Join Date: Oct 2016
Location: Norfolk, UK
Posts: 725
Are you using 24 or 36 exposure rolls ?
07-14-2019, 01:39 AM   #4
New Member




Join Date: Nov 2012
Posts: 8
Original Poster
36 exposure rolls. Happened with 2 rolls back to back. I will try a third and see how it goes.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, cock, film, lever, lever sticking partway, mx rapid-wind lever, pentax help, photography, rapid-wind, rewind, rolls, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Spotmatic II rapid lever jam Ngarcia439 Pentax Film SLR Discussion 4 11-19-2016 11:34 AM
P30 Wind Lever Doesn't Wind Complete Cycle - Any ideas? pengam Pentax Film SLR Discussion 14 08-31-2015 06:08 AM
Pentax ME rapid-wind lever problem amhq Pentax Film SLR Discussion 0 02-16-2013 12:59 PM
Me-super rapid wind lever not returning properly Heldur Pentax Film SLR Discussion 13 10-10-2008 12:45 AM



All times are GMT -7. The time now is 04:34 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top