Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-02-2019, 02:15 PM   #1
Site Supporter
Site Supporter




Join Date: Oct 2013
Location: Sandy, UT
Photos: Albums
Posts: 532
Pentax KP Shutter issues when D-BG7 grip fitted?

Hello All, I'm wondering if anyone has had the same issue as me. I have a Silver KP I bought new. It was dropped back in March when the strap came off and in the 5000+ shots since then, I've had shutter issues on about 4 occasions - the shutter fires multiple times in succession then the mirror sticks half way up. It would not take an image during those multiple shots - my cure was generally to take both batteries out to reset it, then it would shoot fine again.

I thought the issue was possibly related to when I dropped it, BUT......

.... I bought another KP (black body this time) with a collection of lenses, too good a deal to pass up. It has around 4K actuations. It arrived last week, I've been out with it today shooting a car meet - and had exactly the same issue!

The penny dropped that the issues with the KP coincided with both it being dropped, but also with the arrival and fitment of the battery grip, which had been on it ever since.

I had fitted the grip to my newer KP today to give me longer battery life; once the shutter issue happened I removed the grip and had no more issues for the next 200 shots.

Has anyone else had this problem? I'm using the grip with the bigger batteries from the K-1 / K-3 etc. Thanks.


Last edited by rosettaquarrier; 09-02-2019 at 02:28 PM.
09-02-2019, 02:41 PM   #2
Otis Memorial Pentaxian
Loyal Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 34,003
QuoteOriginally posted by rosettaquarrier Quote
The penny dropped that the issues with the KP coincided with both it being dropped, but also with the arrival and fitment of the battery grip, which had been on it ever since.
Is this the Pentax-brand D-BG7 or a third-party battery grip? Are you using third-party batteries or the Pentax-brand? Was the grip on the first camera when it was dropped.


Steve

Last edited by stevebrot; 09-02-2019 at 02:46 PM.
09-02-2019, 02:48 PM   #3
Site Supporter
Site Supporter




Join Date: Oct 2013
Location: Sandy, UT
Photos: Albums
Posts: 532
Original Poster
QuoteOriginally posted by stevebrot Quote
Is this the Pentax-brand D-BG7 or a third-party battery grip? Are you using third-party batteries or the Pentax-brand? Was the grip on the first camera when it was dropped.


Steve
Genuine Pentax Grip and genuine battery in the grip. I did have a third party battery in the body. Thinking back the grip was on the body when it was dropped - I wonder if i actually have a grip issue?!?
09-02-2019, 03:26 PM   #4
New Member




Join Date: Apr 2017
Posts: 16
QuoteOriginally posted by rosettaquarrier Quote
Genuine Pentax Grip and genuine battery in the grip. I did have a third party battery in the body. Thinking back the grip was on the body when it was dropped - I wonder if i actually have a grip issue?!?
Hi! I too own the grip, but I've never experienced anything strange with it. If also your silver body works flawlessly without the battery grip, then the answer is simple...
At least the price for a repair should be a lot less.

Gianfranco

09-02-2019, 03:28 PM   #5
Site Supporter
Site Supporter




Join Date: Oct 2013
Location: Sandy, UT
Photos: Albums
Posts: 532
Original Poster
Thanks - I'll have to try the silver body on it's own again now, I had only been using it with the grip.

All signs at this point seem to indicate an intermittent grip issue.....
09-02-2019, 03:31 PM   #6
Site Supporter
Site Supporter




Join Date: Feb 2013
Location: Norwich, Ct
Posts: 106
This is the scenario when I have a problem like that...with the Pentax grip and either the large or small battery with drive mode Medium...AFC...cant recall it happening without the grip...SD card San Disk Extreme Pro...and I bet if you try to review images when it happens you will watch the little circle go round and round...BTW I have not updated to the last firmware yet

Last edited by cpobuttons; 09-02-2019 at 03:34 PM. Reason: add one more bit of info
09-02-2019, 03:50 PM   #7
Site Supporter
Site Supporter




Join Date: Oct 2013
Location: Sandy, UT
Photos: Albums
Posts: 532
Original Poster
QuoteOriginally posted by cpobuttons Quote
This is the scenario when I have a problem like that...with the Pentax grip and either the large or small battery with drive mode Medium...AFC...cant recall it happening without the grip...SD card San Disk Extreme Pro...and I bet if you try to review images when it happens you will watch the little circle go round and round...BTW I have not updated to the last firmware yet
Interesting - sounds like issues with the grip could be a thing. I was in Medium and AFC as well. Thanks for sharing.
10-05-2019, 05:18 AM - 1 Like   #8
dlh
F.O.G. (fat old geezer)
Loyal Site Supporter
dlh's Avatar

Join Date: Nov 2015
Location: Northern Piedmont of Virginia
Posts: 963
When you set up the grip with the camera(s), did you set the battery selection option to work off the battery in the grip first? I'm thinking that the battery in the grip may be failing and not putting out enough juice to work the camera properly - low voltage or amperage (which would explain why both otherwise normal cameras get the same problem when the grip's attached). Try switching the batteries?

10-05-2019, 07:26 AM   #9
Site Supporter
Site Supporter




Join Date: Oct 2013
Location: Sandy, UT
Photos: Albums
Posts: 532
Original Poster
Good question - I did not change the battery settings so it would be whatever is the default. Since I identified the grip as an issue I took the grip off to to check the camera without it - I must have shot 2000 frames since with no issues at all, so maybe time to go back and try to troubleshoot the grip again.
10-05-2019, 02:23 PM - 1 Like   #10
Loyal Site Supporter
Loyal Site Supporter




Join Date: Mar 2013
Location: Kansas
Posts: 30
I have the grip on my KP and haven’t had any issues after 2500-3000 shots. I’ve used it with body battery selected first and with grip battery first, whichever was selected first it switched to the other when needed without a problem. Hope you find the problem soon and can get it fixed easily!
10-05-2019, 05:24 PM - 1 Like   #11
Site Supporter
Site Supporter
Ex Finn.'s Avatar

Join Date: Nov 2007
Location: Southern Maryland.
Photos: Gallery | Albums
Posts: 7,646
5000 shots in almost 2 years with my KP and the vertical grip fitted with DLi-90 as a primary source, no issues so far.
10-05-2019, 08:32 PM - 1 Like   #12
retired sw engineer
Loyal Site Supporter
reh321's Avatar

Join Date: Nov 2014
Location: South Bend, IN, USA
Photos: Gallery | Albums
Posts: 13,803
QuoteOriginally posted by rosettaquarrier Quote
Hello All, I'm wondering if anyone has had the same issue as me. I have a Silver KP I bought new. It was dropped back in March when the strap came off and in the 5000+ shots since then, I've had shutter issues on about 4 occasions - the shutter fires multiple times in succession then the mirror sticks half way up. It would not take an image during those multiple shots - my cure was generally to take both batteries out to reset it, then it would shoot fine again.

I thought the issue was possibly related to when I dropped it, BUT......

.... I bought another KP (black body this time) with a collection of lenses, too good a deal to pass up. It has around 4K actuations. It arrived last week, I've been out with it today shooting a car meet - and had exactly the same issue!

The penny dropped that the issues with the KP coincided with both it being dropped, but also with the arrival and fitment of the battery grip, which had been on it ever since.

I had fitted the grip to my newer KP today to give me longer battery life; once the shutter issue happened I removed the grip and had no more issues for the next 200 shots.

Has anyone else had this problem? I'm using the grip with the bigger batteries from the K-1 / K-3 etc. Thanks.
To partially answer your question, I have had no problems in the year that I've a KP - but I've kept the size small and never tried the BG made to with the body.
10-05-2019, 09:01 PM - 1 Like   #13
Pentaxian




Join Date: Mar 2010
Location: Manila, Philippines
Posts: 1,335
You may send it for service for peace of mind.
10-06-2019, 07:46 AM   #14
Site Supporter
Site Supporter




Join Date: Oct 2013
Location: Sandy, UT
Photos: Albums
Posts: 532
Original Poster
QuoteOriginally posted by wed7 Quote
You may send it for service for peace of mind.
I think that would make sense. It's less than a year old, so presumably under warranty.
10-06-2019, 07:51 AM - 1 Like   #15
Loyal Site Supporter
Loyal Site Supporter




Join Date: Mar 2013
Location: Kansas
Posts: 30
QuoteOriginally posted by rosettaquarrier Quote
I think that would make sense. It's less than a year old, so presumably under warranty.
I assume you will but please let us know the outcome, good luck!
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, d-bg7 grip, grip, issue, issues, issues when d-bg7, kp, kp shutter issues, pentax help, pentax kp shutter, photography, shots, shutter, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale - Sold: D-BG7 battery grip for KP (lowered price) carlb Sold Items 4 08-16-2019 04:57 PM
Canada: Battery Grip D-BG7 for Pentax KP DSLR Sale Price: $189.97 You Save: $90.02 fill23ca Pentax Price Watch 2 01-11-2019 02:59 PM
Which lens can be fitted to our K mont cameras? CapitanXeon Pentax Camera and Field Accessories 6 07-11-2018 06:13 PM
KP vs K-70 - to KP or not to KP, that is the question OldChE Pentax DSLR Discussion 19 02-04-2018 09:43 AM
Pentax KP with Battery Grip D-BG7 derrenhodson Pentax KP 9 01-30-2018 07:37 AM



All times are GMT -7. The time now is 02:50 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top