Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-09-2019, 05:04 AM   #1
Junior Member
WondringLisa's Avatar

Join Date: Oct 2017
Posts: 34
'SMC Pentax-D FA 100mm F2.8 Macro' intermittent viewfinder black photo

I have recently bought a SMC Pentax-D FA 100mm F2.8 Macro and it has been working well for the most part. However I have noticed an intermittent problem when shooting through the viewfinder where the photos shot will be totally black. The camera picks up all the correct settings and it shoots fine with screen view. It doesn't do this all the time, last time it occurred I took off the uv filter that i put on to protect the lens, shot through the screen and flicked back to viewfinder and it was working again. I am kind of stumped.

10-09-2019, 05:06 AM   #2
amateur dirt farmer / mod
Loyal Site Supporter
pepperberry farm's Avatar

Join Date: Dec 2014
Location: probably out in a field somewhere...
Photos: Gallery | Albums
Posts: 16,041
which camera body?
10-09-2019, 05:09 AM   #3
Junior Member
WondringLisa's Avatar

Join Date: Oct 2017
Posts: 34
Original Poster
Pentax K-S2
10-09-2019, 05:11 AM   #4
Pentaxian




Join Date: May 2019
Posts: 588
That does sound like the aperture control failure rearing its head... Are you sure it never happens in Live View or could it be a coincidence?


EDIT: does this problem happen with other lenses?

10-09-2019, 05:17 AM   #5
Junior Member
WondringLisa's Avatar

Join Date: Oct 2017
Posts: 34
Original Poster
Definitely not had it in live view. I tried with my Sigma 28-300 and i didn't have any issues. I've had the aperture control failure before and know how to fix that if need be.

[edit] can a filter interfere with a lens light metering properly?

Last edited by WondringLisa; 10-09-2019 at 05:23 AM.
10-09-2019, 05:24 AM   #6
Pentaxian




Join Date: May 2019
Posts: 588
Mmm. Can you post a picture with EXIF data?

Edit: it is possible that a filter might influence it. Are you using a graduated ND filter?
10-09-2019, 05:35 AM   #7
Junior Member
WondringLisa's Avatar

Join Date: Oct 2017
Posts: 34
Original Poster
Was just a regular UV filter. Attached two shots, not exactly the same settings but close enough.
Attached Images
View Picture EXIF
PENTAX K-S2  Photo 
View Picture EXIF
PENTAX K-S2  Photo 
10-09-2019, 05:36 AM   #8
Pentaxian
Medex's Avatar

Join Date: May 2013
Posts: 396
QuoteOriginally posted by WondringLisa Quote
Definitely not had it in live view. I tried with my Sigma 28-300 and i didn't have any issues. I've had the aperture control failure before and know how to fix that if need be.

[edit] can a filter interfere with a lens light metering properly?
try to use your lens 100/2,8 in non-A setting, e.g. at f4. In case you have aperture block failure, pictures will still be good, not dark, because aperture will not go beyond f4

---------- Post added 10-09-19 at 03:39 PM ----------

QuoteOriginally posted by WondringLisa Quote
Was just a regular UV filter. Attached two shots, not exactly the same settings but close enough.
BTW if you have aperture block repaired earlier, the failure can repeat because solenoid that was replaced can be the same bad quality as first one.

10-09-2019, 05:42 AM   #9
Junior Member
WondringLisa's Avatar

Join Date: Oct 2017
Posts: 34
Original Poster
QuoteOriginally posted by Medex Quote
try to use your lens 100/2,8 in non-A setting, e.g. at f4. In case you have aperture block failure, pictures will still be good, not dark, because aperture will not go beyond f4

---------- Post added 10-09-19 at 03:39 PM ----------


BTW if you have aperture block repaired earlier, the failure can repeat because solenoid that was replaced can be the same bad quality as first one.
I didn't actually replace it, I just took out the little bit of metal that is part of the mechanism and lightly ran an emery board over the edges of it and put it back, worked fine again after that.

[edit] does seem to be working correctly now. I'll follow up if the issue happens again. I think i'll clean contacts just in case that was a factor.
10-09-2019, 05:46 AM   #10
Pentaxian




Join Date: May 2019
Posts: 588
Filing off part of the solenoid's plunger is only a temporary solution, it will appear again, unfortunately. It's weird that it doesn't happen in LV however, I can think of nothing that explains it.

Does the D FA default to aperture fully closed when out of the camera? I don't have that one in particular.
10-09-2019, 07:08 AM   #11
Site Supporter
Site Supporter
sergysergy's Avatar

Join Date: Jan 2011
Posts: 3,240
sounds more like a problem with the camera than the lens
1 Day Ago   #12
Loyal Site Supporter
Loyal Site Supporter




Join Date: Mar 2008
Location: N. Calif
Photos: Gallery | Albums
Posts: 2,866
How about other lenses. Do they all work fine?
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
'smc pentax-d fa, 100mm, aperture, block, camera, f2.8, f4, fa 100mm f2.8, failure, filter, lens, macro, pentax help, pentax-d fa 100mm, photography, screen, shot, time, troubleshooting, viewfinder
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax F-100mm f2.8 macro vs Pentax D FA-100mm f2.8 macro WR pentaz Pentax SLR Lens Discussion 8 07-03-2013 06:22 AM
Pentax-D FA 100mm F2.8 Macro WR or Pentax-FA 100mm F2.8 Macro jkobleur Pentax SLR Lens Discussion 3 09-05-2011 06:47 PM
100mm f2.8 macro FA vs new 100mm mavro f2.8 DA stemked Pentax SLR Lens Discussion 19 08-23-2010 01:34 PM
FA 100mm f2.8 Macro vs D FA 100mm f2.8 macro David Pentax SLR Lens Discussion 4 10-22-2007 07:11 AM



All times are GMT -7. The time now is 09:52 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top