Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-12-2019, 06:02 AM   #1
New Member




Join Date: Oct 2019
Posts: 2
Aperture not changing Manual Lens

Hi,

I just bought a Pentax K mount 37 - 70mm 3.5 - 4.8f Macro lens and I can't change the aperture. When I turn the ring on the lens I cannot see the blades inside moving at all and when I mount it on my GX80 camera, it does not change. I've attached some photos and videos of the lens in which you can see that when the aperture ring turns, a section at the back of the lens does, but there is no actual change.

If anyone has any ideas how to fix this, I'd really appreciate it.
Videos:
https://drive.google.com/open?id=1fXnlkZnnt6idQIBbg40pixrAIBbpU7v_
https://drive.google.com/open?id=1KMw3ELVFsWjMaAsCrcbn01Xh3OovDbzK
In the video, I start on manual video mode as it previews how the shutter, ISO, and aperture look and then moved to manual photo mode.

Attached Images
View Picture EXIF
DMC-GX80  Photo 
View Picture EXIF
DMC-GX80  Photo 
View Picture EXIF
DMC-GX80  Photo 
10-12-2019, 06:45 AM   #2
Site Supporter
Site Supporter




Join Date: Nov 2012
Location: North Wales
Photos: Gallery | Albums
Posts: 2,149
Yes the iris should close down as you move the aperture ring to higher F, and it should move when you flick the aperture lever. If the lens doesn't do these things then there is something mechanically wrong with the connections or the iris (?stuck blades).
PS plenty of better 37-70mm/similar zooms than this offbrand one.

Last edited by marcusBMG; 10-12-2019 at 06:54 AM.
10-12-2019, 06:47 AM   #3
Pentaxian




Join Date: May 2014
Location: Linz
Photos: Albums
Posts: 1,026
I am unfortunately unable to open the videos.
As for your problem:

-Are the aperture blades moving when you actuate the aperture lever?
-Is the aperture open or closed? If the aperture is always open when you change your aperture with the aperture ring, but the blades are moving when you move the aperture lever, then it is very likely that the spring actuating the aperture lever is defective/broken.

If the blades arn't moving at all no matter what you do you will have to disassamble the whole lens looking for the problem. If your aperture ring is moving freely, but your blades are stuck it is likely that something is broken, too, that way you will probably need another donor lens to fix things

Last edited by othar; 10-12-2019 at 06:55 AM.
10-12-2019, 06:59 AM   #4
New Member




Join Date: Oct 2019
Posts: 2
Original Poster
QuoteOriginally posted by othar Quote
I am unfortunately unable to open the videos.
As for your problem:

-Are the aperture blades moving when you actuate the aperture lever?
-Is the aperture open or closed? If the aperture is always open when you change your aperture with the aperture ring, but the blades are moving when you move the aperture lever, then it is very likely that the spring actuating the aperture lever is defective/broken.

If the blades arn't moving at all no matter what you do you will have to disassamble the whole lens looking for the problem. If your aperture ring is moving freely, but your blades are stuck it is likely that something is broken, too, that way you will probably need another donor lens to fix things
The blades do not move at all. As far as I can tell it is fully open as I cannot see any blades through the glass. For disassembly do you have any resource recommendations? I've never disassembled a lens before.

10-12-2019, 07:03 AM   #5
Pentaxian




Join Date: Oct 2011
Location: Savannah, GA
Posts: 5,357
With the lens off the body, the blades should definitely open and close and you turn the ring. If if you are stopped down on the ring, the aperture lever should be springy and the blades should open if you move the lever and then close again if you let it go. So it seems like your aperture is just broken, but I didn't see you check the lever in the video so make sure that isn't just stuck or something ( probably bent if it is).
10-12-2019, 07:17 AM   #6
Moderator
Not a Number's Avatar

Join Date: Mar 2012
Location: Venice, CA
Posts: 6,687
Most likely the auto aperture lever (long lever) is bent or disengaged. Stop the lens down and operate the long lever. The iris should close down.

If you don't have experience working on lenses and don't have the tools (JIS drivers minimum) and don't think you are up to it see if you can return the lens for refund.
10-12-2019, 09:05 AM   #7
Otis Memorial Pentaxian
Loyal Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 35,105
QuoteOriginally posted by nissin Quote
The blades do not move at all. As far as I can tell it is fully open as I cannot see any blades through the glass. For disassembly do you have any resource recommendations? I've never disassembled a lens before.
Unless the lens was sold as inoperable or you got it for free, ask to return. Repairing a lens is not easy and not worth doing unless one already has the skills and/or has no issue with making things worse.


Steve
10-12-2019, 10:23 AM   #8
Loyal Site Supporter
Loyal Site Supporter
pschlute's Avatar

Join Date: Mar 2007
Location: Surrey, UK
Photos: Gallery
Posts: 3,813
QuoteOriginally posted by nissin Quote
The blades do not move at all
Return the lens

10-14-2019, 05:26 AM   #9
Forum Member




Join Date: Mar 2018
Posts: 69
Push in the Aperture lever and see if they change then. If they do they your camera is not moving the lever. As mentioned it could be bent or it just might not work with the camera.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
aperture, aperture stuck, camera, change, lens, manual aperture, manual lens pentax, mode, pentax help, photography, troubleshooting, video, videos
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
KP ridiculously loud while changing aperture in M mode? ZombieArmy Pentax KP 23 09-28-2019 08:54 AM
Lens compatibility and Aperture on a manual MX with a manual Sicor XL MC jkcerezo Pentax SLR Lens Discussion 7 12-03-2018 07:53 PM
Manual settings and shutter speed was changing in between shot jstrowe Pentax K-r 11 08-25-2018 05:41 PM
Aperture control problems with variable aperture lenses (with aperture rings) gtxSeries Troubleshooting and Beginner Help 3 09-13-2017 01:11 PM
Aperture not changing with K-30 and SMC Pentax-M 1:1.7 50 mm SLR lens kenbobblehead Troubleshooting and Beginner Help 7 10-28-2013 07:48 PM



All times are GMT -7. The time now is 01:08 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top