Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-17-2019, 03:08 AM   #1
Site Supporter
Site Supporter
e_nogueras's Avatar

Join Date: Dec 2016
Location: Barceloneta
Photos: Gallery
Posts: 195
K-1 LCD display won't turn on for a few minutes (after pixel shift mode)

Hi:

This past Sunday I went to take some long exposure photos of the sunrise at a beach nearby (using a remote cable).
Took 8 to 9 photos without problem, then a wave splatter some water an a few drops hit the camera but nothing too serious (I did noticed a drop of water near the remote cable port). Took 5 more photos still everything normal.

However, I switched the K-1 menu to take 2 or 3 bracketed / pixel shift resolution photos since I do not play much with those functions.
First photo was take and "stitched" perfectly then suddenly after taking the second photo the LCD went completely black.

I waited a minute to see if the camera was processing the image to the SD Card but nothing happened so I decided to turn the camera off/on.
Thru the viewfinder I could see the all the photographic parameters, however nothing was showing on the LCD. It would not let me to change functions.
I decided to swap to a fresh battery, but same thing, I could see the all the photographic parameters and even take a photo but no LCD.

I put the camera on the bag and took a break. After 10 minutes I turned the camera on and everything was completely normal.

However, after 10-15 photos normal photos it did the same thing while taking photos using the pixel shift resolution mode.
So, I once again waited like 5 minutes and everything was back to normal.

The camera have the latest firmware installed and it is the first time something like this happens. Any ideas?

12-17-2019, 03:18 AM - 1 Like   #2
Site Supporter
Site Supporter
Kevin B123's Avatar

Join Date: Jul 2016
Location: Hampshire
Photos: Gallery | Albums
Posts: 1,304
Hi, for repeatable issues like this I would search the menu for things like enabled nr or other time consuming functions and turn them all off and try again. If there is no improvement then try and isolate the exact behaviour for analysis.
12-17-2019, 04:54 AM - 1 Like   #3
Loyal Site Supporter
Loyal Site Supporter
pschlute's Avatar

Join Date: Mar 2007
Location: Surrey, UK
Photos: Gallery
Posts: 3,890
Put the camera in a bag of rice or some other dessicant. Leave it for 24 hours.
12-17-2019, 06:27 AM   #4
Pentaxian




Join Date: Feb 2015
Photos: Gallery | Albums
Posts: 7,806
QuoteOriginally posted by e_nogueras Quote
The camera have the latest firmware installed and it is the first time something like this happens. Any ideas?
That's normal. The display is only active in PS mode if the image preview is enabled. If the image preview is disabled, the rear LCD display stays black when a pixel shift sequence is triggered.

12-17-2019, 10:23 AM   #5
Site Supporter
Site Supporter
e_nogueras's Avatar

Join Date: Dec 2016
Location: Barceloneta
Photos: Gallery
Posts: 195
Original Poster
QuoteOriginally posted by biz-engineer Quote
That's normal. The display is only active in PS mode if the image preview is enabled. If the image preview is disabled, the rear LCD display stays black when a pixel shift sequence is triggered.

The problem was, it won't do anything for more than 5 minutes. No information at all, even the mirror won't go up for the live view mode.
12-17-2019, 02:46 PM - 1 Like   #6
Loyal Site Supporter
Loyal Site Supporter
BigDave's Avatar

Join Date: Sep 2010
Location: Hudson Valley, NY
Photos: Gallery | Albums
Posts: 2,361
The K-1 has a slow shutter noise reduction routine that tries to reduce noise from dark images. Hit Menu, 2, Noise reduction, Slow Shutter speed NR- turn it off, the display should come back quickly.
12-18-2019, 08:24 AM   #7
Site Supporter
Site Supporter
e_nogueras's Avatar

Join Date: Dec 2016
Location: Barceloneta
Photos: Gallery
Posts: 195
Original Poster
QuoteOriginally posted by BigDave Quote
The K-1 has a slow shutter noise reduction routine that tries to reduce noise from dark images. Hit Menu, 2, Noise reduction, Slow Shutter speed NR- turn it off, the display should come back quickly.
I will try that. Thank you BigDave!
12-19-2019, 06:54 AM   #8
Veteran Member




Join Date: Apr 2017
Posts: 301
" I put the camera on the bag and took a break. After 10 minutes I turned the camera on and everything was completely normal."

After the camera is turned off it will go back to normal. Pixel shift behavior is like HDR in some camera.

Read more at: K-1 LCD display won't turn on for a few minutes (after pixel shift mode) - PentaxForums.com

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, k-1 lcd display, lcd, lcd display issues, minutes, minutes after pixel, parameters, pentax help, photo, photography, photos, pixel, pixel shift, random, shift, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pixel shift with pixel artefacts Dericali Pentax K-1 4 07-18-2018 12:57 PM
Lloyd Chambers Prefers Pentax Pixel Shift To Sony's Pixel Shift Fenwoodian Pentax K-1 2 07-16-2018 02:15 PM
Pentax LX meter won't turn off / battery drain after CLA jayy Pentax Film SLR Discussion 5 05-02-2018 12:24 PM
Does the K1 Allow Us to Turn Pixel-Shift ON and Remain On when Camera Restarts? MichaelErlewine Pentax K-1 4 06-01-2016 03:14 AM
Nature ...there is a season, turn turn turn... littledrawe Post Your Photos! 4 09-19-2012 11:57 PM



All times are GMT -7. The time now is 10:04 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top