Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-28-2019, 03:44 PM   #1
New Member




Join Date: Dec 2019
Posts: 3
Wind lever problem.

i was loading a film on my PENTAX PROGRAM A , as i closed my camera and proceeded to pull the lever in order to advance the counter to 0 it felt a bit stuck, i slightly forced (stupidly , i know cameras must not be forced but i did it out of reflex) the advance lever and it made a weird noise. now its really loose, it doesnt cock the shutter and its not turning the takeup film stool also the shutter release button isnt working but i imagine thats just because the shutter isnt cocked. does anyone have an idea what can i do? what the problem might be and if i can attempt to fix it myself? and if i can should i look on the bottom or the top of the camera?

12-28-2019, 04:11 PM   #2
Pentaxian
Aaron28's Avatar

Join Date: Jan 2015
Location: Huntsville, Al
Posts: 5,624
removing the bottom plate may allow to see what moves if anything when you advance the lever......maybe something slipped outta place or a spring has broken since it seems 'really loose' now...….I had a spring break on a mamiya 1000dtl and the lever got 'really loose' as it was for tension in the return of the lever....the shutter would still cock and fire though
12-28-2019, 04:14 PM   #3
Loyal Site Supporter
Loyal Site Supporter




Join Date: Dec 2019
Location: Mohave county Arizona
Photos: Albums
Posts: 1,058
You might try watching this video, different model, but seems like same problem.
good luck and let us know if you fix it.
12-28-2019, 05:01 PM   #4
Site Supporter
Site Supporter




Join Date: May 2016
Photos: Albums
Posts: 1,580
This seems to be a common Super A problem, though I don't know the fix. (Maybe it's the same as the K1000 above.)

12-28-2019, 06:12 PM   #5
Pentaxian
Aaron28's Avatar

Join Date: Jan 2015
Location: Huntsville, Al
Posts: 5,624
also the lever itself could be loose and may need to be put back into place and tightened down
01-06-2020, 12:11 PM   #6
New Member




Join Date: Dec 2019
Posts: 3
Original Poster
hi as i proceeded to try out the fix of the video, i was starting to loosen up my bolts and then i heard a similar crack noise and everything went back to normal. the wind lever was working and i started to shoot the first roll of 2020.... thanx for the help even if the fix was completly accidental cuz i was just trying to oopen up the cameras bottom. heres a pic of the thing i twitched and unlocked the problem, ust in case anyone encounters the same problem
Attached Images
View Picture EXIF
 Photo 
01-06-2020, 04:57 PM   #7
Pentaxian
Aaron28's Avatar

Join Date: Jan 2015
Location: Huntsville, Al
Posts: 5,624
sweet! debris, curd whatever may have dislodged and wa la !!

happy shooting!
01-06-2020, 05:14 PM   #8
Pentaxian
Just1MoreDave's Avatar

Join Date: Feb 2007
Location: Aurora, CO
Photos: Gallery | Albums
Posts: 5,797
That's the connection for the optional motor drive so it makes sense. I'm not sure if there is a cover for that; if there was, most of them were lost.

01-10-2020, 06:29 PM   #9
New Member




Join Date: Dec 2019
Posts: 3
Original Poster
So i shot a roll of portra 400 and at the last shot it died out on me again, finally took it to get it checked but the guy told me that the Program A worked with a electromagnetic shutter release button /system and that he had strip it down and that it would cost mi like 140 euros so ....****, been looking online and a guy is selling a Pentax P30 for 80 euros but since my program a is my first pentax and the only camera ive used for the past 2 years, so : Does the p30 would be considered an upgrade or more of a downgrade?
01-17-2020, 11:08 PM   #10
Senior Member




Join Date: Oct 2019
Location: Los Angeles, CA
Photos: Gallery
Posts: 111
I don't know a whole lot about Pentax A- and P-series cameras (I'm a K/M series guy myself), but since no one else is answering... I believe the P30 would be a decent replacement, though it uses DX coding for the film so if you roll your own that makes things a bit tougher. If you buy rolled film, no worries.

I'm a big believer in the old K series cameras -- my first and favorite is a KX, now 45 years old, never serviced and still working. No electronics to break. But it's manual only, no auto-exposure mode like the Program A.

You might also want to contact the famous Eric (Home-Pentaxs) - I haven't used him myself but everyone raves about him. He might be familiar with the issues you're having, and if you can have your camera repaired and cleaned/lubed/adjusted for the same cost as replacing it, well, I'd put the $$ into a camera you know. Once renewed it'll probably last a long, long time.

If you're looking at replacement, a cheap alternative that I rather like is the Ricoh KR-10. I have one and it's not as solid as the Pentaxes (plastic top/bottom cover, I think), but it has an AE mode and takes Pentax K-mount lenses and I've gotten some good pictures out of it. I see (supposedly) working bodies on eBay for $25-$50.

Good luck. A broken camera is a sad thing indeed.
01-18-2020, 07:55 AM   #11
Pentaxian
Aaron28's Avatar

Join Date: Jan 2015
Location: Huntsville, Al
Posts: 5,624
QuoteOriginally posted by santiago pacheco Quote
at the last shot it died out on me again,
as in jammed or did the batteries die out? as the shutter requires batteries to operate based on yer tech guy
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
advance, advance lever problem, camera, film, lever, pentax help, photography, shutter, troubleshooting, wind lever
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax P30 - Wind Lever Problem. nat.mitch Troubleshooting and Beginner Help 4 08-09-2020 04:20 AM
Problem with wind lever and loading film Pentax K1000 Katalin Troubleshooting and Beginner Help 5 01-11-2019 09:43 AM
P30 Wind Lever Doesn't Wind Complete Cycle - Any ideas? pengam Pentax Film SLR Discussion 14 08-31-2015 06:08 AM
ME super wind lever problem Cat among the pigeon Pentax Film SLR Discussion 11 07-14-2015 06:28 PM
Pentax me super wind lever problem Manchesterroses Troubleshooting and Beginner Help 5 03-13-2014 11:29 PM



All times are GMT -7. The time now is 02:40 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top