Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-06-2020, 08:25 AM   #1
New Member




Join Date: Jan 2020
Posts: 1
Problem with sigma lens and k-70

Hello, I'm currently in possession of both a k-50 and a k-70. I recently bought a second hand lens from eBay which is a Sigma DG150-500mm (APO HSM). The lens works perfectly on the k-50 but for some reason, it doesn't work on the k-70. Whenever I attach it to the k-70, the camera completely freezes up and you have to remove the battery for it to turn off. I don't believe the issue is with the k-70 as all the other lens still work perfectly when attached to the camera.

Any idea why this problem is occurring and what's the best way to solve it?

Kind regards,

Conor

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, k-50, k-70, lens, pentax help, photography, sigma, sigma 150-500 hsm, sigma lens, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale - Sold: Pentax FA 100-300, FA 70-200, M 28mm; Sigma EX 28-70, Apo 70-300; Tamron Di LD 70-300 stillnk Sold Items 17 04-08-2012 11:39 AM
K-5 battery problem? camera problem? user problem? imtheguy Pentax K-5 39 11-03-2010 06:02 PM
Tamron AF 70-300mm or Sigma Lens 70-300mm or Sigma 70-200mm Ben Hunt Pentax SLR Lens Discussion 21 11-05-2008 05:47 AM



All times are GMT -7. The time now is 11:24 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top