Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-24-2020, 02:29 AM   #1
New Member




Join Date: Mar 2020
Posts: 5
645z D-FA 55mm Iris Stopping Down When Lens is Mounted

Hi, I'm a new 645z user and have a difficulty with the iris of the lens stopping down when attaching to the camera body. The lens (D-FA 55mm) stops down to what looks like approx f8 or f11 when attaching it to the camera; this happens during the final part of the attachment when the iris tab of the lens meets with the iris driver of the body. The same thing happened when I tried an older 645 lens. Unsurprisingly, the metering is way out, the camera barely functions and I'm only able to use manual mode with aperture settings above f11 (albeit with great results). Both the 645z body (like new condition) and the lens were purchased used from a reputable dealer. Is the camera body faulty or am I missing something really obvious..? I'm baffled as to why this should be happening and any suggestions would be greatly appreciated. Many thanks, John

03-24-2020, 04:30 AM   #2
Pentaxian
35mmfilmfan's Avatar

Join Date: Oct 2016
Location: Norfolk, UK
Posts: 1,091
Have you had a word with the dealer ?
03-24-2020, 05:27 AM   #3
New Member




Join Date: Mar 2020
Posts: 5
Original Poster
Yes, but unfortunately they don't have anyone familiar with the 645z and are unable to suggest a cause or remedy. I could send the camera back for a refund but would like to know if there is something obvious or straightforward that I'm missing.
03-24-2020, 08:04 AM   #4
Otis Memorial Pentaxian
Loyal Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 35,541
QuoteOriginally posted by JohnVol Quote
Yes, but unfortunately they don't have anyone familiar with the 645z and are unable to suggest a cause or remedy. I could send the camera back for a refund but would like to know if there is something obvious or straightforward that I'm missing.
Welcome to the Pentax Forums!

In case you don't, do you have a copy of the manual and menu supplement?

Operation Manuals Download : Support & Service | RICOH IMAGING

I don't have a 645Z in front of me, but memory from previous use of the 645 system is that mounting the lens should be quite straightforward...align the red dots and rotate clockwise onto the mount (nothing more to press or fiddle with) until it locks into place. The camera should be as easy to use as a smaller format dSLR with few surprises. If the seller is not helpful due to ignorance, it is likely they did not test the body for basic operation before offering it for sale. I would call them again and suggest a return for full credit.


Steve

03-24-2020, 12:23 PM   #5
New Member




Join Date: Mar 2020
Posts: 5
Original Poster
Thanks Steve. Lens mounting is fine; I've had Pentax 67s for many years and many other SLR cameras. If there is no obvious solution, I can return the camera for a refund, which would be a shame.
John
03-24-2020, 12:25 PM   #6
New Member




Join Date: Mar 2020
Posts: 5
Original Poster
ps.. I have a copy of the manual and after reading thoroughly, still can't figure out a solution.
03-24-2020, 01:29 PM - 1 Like   #7
Site Supporter
Site Supporter




Join Date: Feb 2018
Location: 48282 Emsdetten
Posts: 52
I am not a technician but this sounds like the aperture control part inside the z is defect. Pentax service can replace it for a few hundred bucks.
I had this with mine when I bought it used too.
6 Days Ago   #8
New Member




Join Date: Mar 2020
Posts: 5
Original Poster
Thanks everyone. Looks like the camera will need to be returned for repair.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
55mm, 645z, 645z d-fa 55mm, body, camera, d-fa, d-fa 55mm, d-fa 55mm iris, f11, iris, lens, pentax help, photography, stopping down, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Manual lens seems to work ok without use of green button stopping down? c_j_m Troubleshooting and Beginner Help 19 09-04-2016 11:41 AM
pentax smc k mount lens not stopping down on the K1 body if I turn the aperture ring michael sandquist Visitors' Center 3 08-07-2016 02:32 PM
Pentax-M lens -- trouble stopping down bklonoski Pentax SLR Lens Discussion 2 09-02-2011 07:59 PM
Down down down down... innershell Post Your Photos! 5 08-06-2009 05:45 PM
Auto Revuenon 135mm lens not stopping down pszilard Pentax SLR Lens Discussion 8 02-12-2009 05:26 PM



All times are GMT -7. The time now is 03:30 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top