Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-20-2020, 06:58 AM   #1
New Member




Join Date: Apr 2020
Posts: 2
First image often shows black

I'll see something outside my window that I quickly want to capture. I quickly grab my K50. Unfortunately and quite often the first image is often blank or black. Second, third, and forth etc. are fine. This has been going on for a couple of months. Any ideas.

04-20-2020, 07:05 AM   #2
pjv
Otis Memorial Pentaxian
Moderator
Loyal Site Supporter
pjv's Avatar

Join Date: Mar 2015
Location: Melbourne, Australia
Photos: Gallery
Posts: 7,396
Hi Bill, it sounds like the aperture block issue. Check the link below. Good luck.

Dark exposure problems on K-30 or K-50? Read me first! - PentaxForums.com
04-20-2020, 08:44 AM   #3
Site Supporter
Site Supporter




Join Date: Nov 2012
Location: North Wales
Photos: Gallery | Albums
Posts: 2,364
+1 typical aperture block symptoms. My KS2 has just started showing same symptoms, a quick rat-tat-tat in burst mode has so far always cleared it. I think it is possible to keep going like this for a long time. But equally, could become a consistent failing at any moment.
The good news is the cure is a relatively easy repair. I just fixed a K30 that I bought with aperture block failure. Photogem is our guru on this...:

Manual: Solenoid Replacment Pentax K-30/50/500 + Discharge of flash-condenser - PentaxForums.com

Or if you're not diy inclined, any competent camera repair technician can do this relatively cheaply and quickly (only took me an hour). Just need to locate the relevant part: an original white solenoid (ideally).
04-20-2020, 03:15 PM   #4
Senior Member




Join Date: Jul 2017
Posts: 273
Yes. Aperature block. My K50's failed. Sent to Precision Camera for repair. Under $200, as I remember. Two years ago, still working great. I'm too shaky and don't see good enough for a self repair.

05-11-2020, 06:19 AM   #5
Pentaxian




Join Date: Nov 2015
Location: Sydney
Posts: 488
QuoteOriginally posted by Bill Bellows Quote
I'll see something outside my window that I quickly want to capture. I quickly grab my K50. Unfortunately and quite often the first image is often blank or black. Second, third, and forth etc. are fine. This has been going on for a couple of months. Any ideas.
That is EXACTLY what my K-50 when it started to develop the aperture block problem. Where are you located? In Australia, Pentax charges AU$150 (about US$100) to fix this problem. They have repair centers in Sydney and Melbourne. You have to be seriously skilled to DYI it in my opinion.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
black, camera, image, pentax help, photography, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
My printed calendar photos are often dark Lambic Digital Processing, Software, and Printing 26 02-14-2020 08:34 PM
Charger shows 100%. Camera shows less. MJSfoto1956 Pentax K-3 4 02-17-2014 12:53 PM
Sale of image, requires "20x30 image size digital image" ? NeverSatisfied Digital Processing, Software, and Printing 25 03-29-2013 05:38 AM
negative scanner shows images as black rcbs Digital Processing, Software, and Printing 11 09-02-2012 05:41 AM



All times are GMT -7. The time now is 02:28 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top