Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-16-2020, 01:38 AM   #1
New Member




Join Date: Mar 2020
Posts: 8
Canon AE-1P SL lever

Hello

I have an Canon AE-1 Program that I was doing some maintenance on. The issue is that the SL lever (A-L-S) doesn't fully rotate now. I have spinned it around for a good while now, but I still can't manage to seat it properly so that I can turn the lever in those 3 different positions, also when I screw the top cover back on, SL lever becomes so hard to turn that it's almost frightening, like it will snap in any moment. Any tips?

07-16-2020, 06:31 AM   #2
Loyal Site Supporter
Loyal Site Supporter




Join Date: Feb 2018
Posts: 348
Try a Canon forum... that's my tip... and I'm kidding. Probably someone here will know.
07-16-2020, 10:40 AM   #3
Loyal Site Supporter
Loyal Site Supporter




Join Date: Jul 2015
Posts: 316
Check out this Youtube video:
He's shows disassembly and assembly. Maybe you just put a piece back in wrong or dropped something.
Good luck
07-16-2020, 01:40 PM   #4
New Member




Join Date: Mar 2020
Posts: 8
Original Poster
QuoteOriginally posted by blumoon722 Quote
Check out this Youtube video:
He's shows disassembly and assembly. Maybe you just put a piece back in wrong or dropped something.
Good luck
Fix Old Cameras: AE 1P Top Cover Removal / PC Socket Repair - YouTube
Thanks, but I did the maintenance with this video, I did everything in reverse until the SL lever didn't move anymore and now the camera doesn't turn on.

07-16-2020, 03:14 PM - 1 Like   #5
Site Supporter
Site Supporter




Join Date: Jun 2010
Location: Central Coast, CA
Posts: 886
Remove the wind lever etc. until you get to the e-ring. Remove the e-ring. Does the black indicator move now? If not you probably need to remove the top cover again. There is a metal "finger" that pushes against the clear plastic piece that is the switch. My guess is that spring loaded finger is jammed under the switch. You will need to pull back on the finger and push the switch down all the way. The finger pushes against the edge of the clear switch. I hope that helps. I don't have a Canon handy to take pictures of the process.
07-16-2020, 10:57 PM   #6
New Member




Join Date: Mar 2020
Posts: 8
Original Poster
QuoteOriginally posted by pentaxus Quote
Remove the wind lever etc. until you get to the e-ring. Remove the e-ring. Does the black indicator move now? If not you probably need to remove the top cover again. There is a metal "finger" that pushes against the clear plastic piece that is the switch. My guess is that spring loaded finger is jammed under the switch. You will need to pull back on the finger and push the switch down all the way. The finger pushes against the edge of the clear switch. I hope that helps. I don't have a Canon handy to take pictures of the process.
Thanks for the tip. I re-read the PDF to see if you meant what I was thinking and I didn't see it first, but the SL plastic piece is put first on the shaft and aligned with the metal finger, then the plastic top cover will be installed on top. Now the camera functions normally, now I just need some oil for the squeaky shutter

E: Battery test button still haunts me as it randomly beeps and pressing it stops it. The "lever" metal piece that is being pressed down doesn't seem to have enough force to come back up. Tips for this, or should I just come up with some kind of small plate that makes it harder to press the button, and therefor harder for it to randomly short circuit.

Last edited by Laamapalmu; 07-17-2020 at 12:56 AM.
07-17-2020, 07:31 AM - 2 Likes   #7
Site Supporter
Site Supporter




Join Date: Jun 2010
Location: Central Coast, CA
Posts: 886
The squeaky noise is not the shutter, it is the mirror damper mechanism. It almost never affects pictures but sounds gnarly. It is on the lower wind lever side of the mirror box. Hard to get to.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, canon, canon ae-1p, lever, pentax help, photography, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wanted - Acquired: Looking to buy pz-1p/pz-1 camera or z-1p/z-1 varient brewmaster15 Sold Items 4 03-05-2020 02:36 PM
Serious backfocus problem on Z-1P (PZ-1P) vlad59134 Pentax Film SLR Discussion 13 12-15-2016 01:49 AM
Z-1/PZ-1 vs. Z-1p/PZ-1p - differences? scottax1 Pentax Film SLR Discussion 5 08-27-2007 03:01 AM



All times are GMT -7. The time now is 07:28 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top