Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-08-2020, 05:48 PM   #1
New Member




Join Date: Aug 2020
Posts: 1
Removing "Watermarks"

I recently received a Pentax K-70 for my birthday. I began using it only to notice that in each photo I had taken, there was a small "2" type splotch in the top left corner that seems to appear as a type of watermark. When I looked through the viewfinder I did not notice any disfigurations on the photo. I also checked both sides of the lens as well as the mirror inside the body of the camera and did not notice anything that may have caused this. How could I get rid of this "watermark"?

08-08-2020, 06:00 PM   #2
Site Supporter
Site Supporter
ramseybuckeye's Avatar

Join Date: Apr 2009
Location: Hampstead, NC
Photos: Gallery | Albums
Posts: 11,844
QuoteOriginally posted by rj.abby Quote
I recently received a Pentax K-70 for my birthday. I began using it only to notice that in each photo I had taken, there was a small "2" type splotch in the top left corner that seems to appear as a type of watermark. When I looked through the viewfinder I did not notice any disfigurations on the photo. I also checked both sides of the lens as well as the mirror inside the body of the camera and did not notice anything that may have caused this. How could I get rid of this "watermark"?
Could you show a sample? Also, when does it appear? in camera?, after import?, in processing?
08-08-2020, 06:26 PM   #3
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 49,542
QuoteOriginally posted by rj.abby Quote
I recently received a Pentax K-70 for my birthday. I began using it only to notice that in each photo I had taken, there was a small "2" type splotch in the top left corner that seems to appear as a type of watermark. When I looked through the viewfinder I did not notice any disfigurations on the photo. I also checked both sides of the lens as well as the mirror inside the body of the camera and did not notice anything that may have caused this. How could I get rid of this "watermark"?
Sounds like maybe dust on the sensor? Those would look like spots. If so, do a quick search for cleaning your sensor, as it could be as simple as using a blower or activating the in-camera dust removal if it isn't already activated.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com server and development costs are user-supported. You can help cover these costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, KEH, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

08-08-2020, 10:37 PM   #4
Pentaxian
Wheatfield's Avatar

Join Date: Apr 2008
Location: The wheatfields of Canada
Posts: 12,274
QuoteOriginally posted by rj.abby Quote
I recently received a Pentax K-70 for my birthday. I began using it only to notice that in each photo I had taken, there was a small "2" type splotch in the top left corner that seems to appear as a type of watermark. When I looked through the viewfinder I did not notice any disfigurations on the photo. I also checked both sides of the lens as well as the mirror inside the body of the camera and did not notice anything that may have caused this. How could I get rid of this "watermark"?
Clean your sensor.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, k-70, notice, pentax help, photo, photography, remove watermarks, troubleshooting, type, watermark, watermarks
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
LR4 - Preset Watermarks. Bramela Digital Processing, Software, and Printing 5 05-08-2013 12:50 AM
Watermarks fusionimaging Digital Processing, Software, and Printing 12 11-18-2009 09:58 PM
Adding watermarks blu3ness Digital Processing, Software, and Printing 2 11-11-2009 04:18 PM



All times are GMT -7. The time now is 11:17 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top