Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-28-2020, 04:31 PM   #1
Loyal Site Supporter
Loyal Site Supporter
kcjonez's Avatar

Join Date: Jul 2015
Location: Mount Desert, Maine, USA
Photos: Gallery | Albums
Posts: 644
K-3 card access light blinking when camera is off

The orange card access light (to the right of 4-way controller) is blinking non stop on my K-3 when it is turned off. It stops when I turn the camera on which must mean nothing is being written to the card. It stops when I remove the battery or cards. I tried two new cards and it continued blinking.
Anyone got any ideas why this is happening and how to make it stop?

09-28-2020, 05:07 PM   #2
Site Supporter
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Washington Cascades
Photos: Gallery | Albums
Posts: 12,983
Aside from the blinking does the camera take images and more importantly write to both cards? I'm just guessing but that is the card access light so maybe one of the card slots is bad and the camera keeps trying to read that card but can't?
09-28-2020, 05:08 PM - 1 Like   #3
maw
Pentaxian
maw's Avatar

Join Date: Feb 2014
Location: Sassari (Italy)
Posts: 1,088
QuoteOriginally posted by kcjonez Quote
The orange card access light (to the right of 4-way controller) is blinking non stop on my K-3 when it is turned off.
This is abnormal, it should be the opposite.

Anyway similar problem happened this summer, I was doing some tests on K1, the read/write light remained on even after turning off the switch went off after a long time.
It could be either 'overheating' or a corrupted 'file system'.
- You can try to reverse the cards to see if the problem returns or disappears.
- I fixed it by copying all the photos from the card and then I reformatted it, even if this doesn't work, it could be a defective card.
- You can format it eventually in a card reader in your computer and then insert it in the slot of the K3.

Let us know if the problem remains.

Ciao Mario
09-28-2020, 05:09 PM   #4
Pentaxian
Aaron28's Avatar

Join Date: Jan 2015
Location: Huntsville, Al
Posts: 6,687
really don't........i know it will blink very temporarily when placing a card in the slot(s) when turned off but not continuously there after.......

wonder if debris is in the slot........

09-28-2020, 05:30 PM   #5
Moderator
Not a Number's Avatar

Join Date: Mar 2012
Location: Venice, CA
Posts: 8,541
Since you tried new cards we can for now concentrate on other areas namely the card slots.

As suggested above check to see if there is dust or other debris in the slots. Perhaps blowing out with a squeeze bulb blower. Also see if any of the contacts are bent. It may be difficult to see some of the lower contacts as they are double rowed.

Does it behave the same with only one card (check either slot)?
09-28-2020, 06:04 PM   #6
Loyal Site Supporter
Loyal Site Supporter
kcjonez's Avatar

Join Date: Jul 2015
Location: Mount Desert, Maine, USA
Photos: Gallery | Albums
Posts: 644
Original Poster
Affirmative. No issues with taking or transferring files.

QuoteOriginally posted by jatrax Quote
Aside from the blinking does the camera take images and more importantly write to both cards? I'm just guessing but that is the card access light so maybe one of the card slots is bad and the camera keeps trying to read that card but can't?


---------- Post added 09-28-20 at 09:06 PM ----------

Interestingly, the light only blinks one blink at a time when only card #1 is installed. Blinks double blinks when card #2 or both cards are installed.

Strange.

Have blown out card slots with no change. Maybe a little alcohol on a toothpick or somesuch?

QuoteOriginally posted by Not a Number Quote
Since you tried new cards we can for now concentrate on other areas namely the card slots.

As suggested above check to see if there is dust or other debris in the slots. Perhaps blowing out with a squeeze bulb blower. Also see if any of the contacts are bent. It may be difficult to see some of the lower contacts as they are double rowed.

Does it behave the same with only one card (check either slot)?

Last edited by kcjonez; 09-28-2020 at 06:10 PM.
09-28-2020, 06:31 PM - 1 Like   #7
Site Supporter
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Washington Cascades
Photos: Gallery | Albums
Posts: 12,983
QuoteOriginally posted by kcjonez Quote
Maybe a little alcohol on a toothpick or somesuch?
Last resort only I think. Those little contacts are very delicate. I wouldn't touch them.

- format cards in the camera?

09-28-2020, 07:38 PM   #8
Otis Memorial Pentaxian
Loyal Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 41,120
QuoteOriginally posted by kcjonez Quote
Interestingly, the light only blinks one blink at a time when only card #1 is installed. Blinks double blinks when card #2 or both cards are installed.
This is how my K-3 behaves.

Camera off, both cards out, single card on insert:
Slot #1: blinks x2
Slot#2: blinks x1
Same as above two cards:
First card, slot #1: blinks x2
Second card, slot #2: blinks x3

First card, slot #2: blinks x1
Second card, slot #1: blinks x3
Turning camera ON:
Single card either slot: blinks x1
Two cards, slot #1 loaded first: blinks x2
Two cards, slot #2 loaded first: blinks x2

Steve

(...suspects blink count is a red herring...)
09-29-2020, 03:43 AM - 3 Likes   #9
Loyal Site Supporter
Loyal Site Supporter
kcjonez's Avatar

Join Date: Jul 2015
Location: Mount Desert, Maine, USA
Photos: Gallery | Albums
Posts: 644
Original Poster
Update;
I left both cards out last night and card slot door open. Reinserted cards this morning.......no blinking lights!?!
Suspect moisture may have been the problem. Yesterday was a wet day for the old K-3.
Thanks to all for feedback!
Attached Images
View Picture EXIF
PENTAX K-3  Photo 
09-29-2020, 08:31 AM   #10
Site Supporter
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Washington Cascades
Photos: Gallery | Albums
Posts: 12,983
Thanks for reporting back. Always good to collect another tidbit of information.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
access, camera, card, cards, check, contacts, installed, k-3, light, pentax help, photography, slots, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
KS2 Blinking Bracket Indicator retpgmr Pentax K-S1 & K-S2 2 03-09-2020 05:18 PM
K20D - Slow review, Card Access Light on Mike Gallagher Pentax DSLR Discussion 4 03-06-2015 08:14 PM
K-5 timer light blinking Harry42 Pentax K-5 & K-5 II 4 01-06-2014 01:59 AM
blinking red light on my AF-540FGZ juicebox Pentax Camera and Field Accessories 4 07-21-2010 03:24 PM
For Sale - Sold: Tamron 75-250mm, Access 35-70mm f/2.5-3.5, Access 70-210mm f3.5, Kenlock 80-20 hinman Sold Items 14 03-20-2010 12:25 PM



All times are GMT -7. The time now is 05:52 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top