Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-01-2020, 05:05 PM   #1
Veteran Member
SunnyG.'s Avatar

Join Date: Apr 2017
Posts: 428
Pentax K-50: Need help

I updated my K-50, to the recent firmware. Now in manual mode, I can't set the camera between ISO 800 - ISO 1600. After I reach iso 800, the camera jumps to iso 1600.

I don't understand what's happening?

Not only that I can't under expose my images. Am I doing something wrong?

11-01-2020, 05:12 PM   #2
Pentaxian
Aaron28's Avatar

Join Date: Jan 2015
Location: Huntsville, Al
Posts: 6,860
QuoteOriginally posted by SunnyG. Quote
After I reach iso 800, the camera jumps to iso 1600.
is it set to 1/2 or 1/3 ev steps? believe thats in the custom menu........also some things are not available at 1/2 step whereas 1/3 step allows i ferget what they are but remember having to change to 1/3 steps

don't know why you can't EV - for under expose......
11-01-2020, 06:12 PM   #3
Otis Memorial Pentaxian
Loyal Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 42,004
QuoteOriginally posted by SunnyG. Quote
I updated my K-50, to the recent firmware. Now in manual mode, I can't set the camera between ISO 800 - ISO 1600. After I reach iso 800, the camera jumps to iso 1600.

I don't understand what's happening?

Not only that I can't under expose my images. Am I doing something wrong?
Do you have exposure compensation set? Are you in bracketing mode? FWIW, the default interval for ISO is 1 EV, unless you have overridden that setting (C2, Sensitivity Steps), the step to 1600 sounds right.

Intentional underexpose fails? Please explain how you are attempting to do that.


Steve
11-01-2020, 06:15 PM - 2 Likes   #4
Pentaxian
grog85361's Avatar

Join Date: Dec 2010
Location: Phoenix Arizona
Photos: Gallery | Albums
Posts: 854
Check the Custom Menu item 2,"Sensitivity Steps"> If it is set to "1", ISO will adjust in 1EV steps, which is the condition you are seeing. Set it to "2", "As EV Steps", and ISO will adjust in the same steps as Custom Menu "1", EV Steps", which selects 1/2 EV or 1/3 EV steps. I hope this helps!

11-02-2020, 07:27 AM   #5
Pentaxian




Join Date: Aug 2016
Location: Appingedam
Photos: Gallery
Posts: 2,412
Indeed, by adjusting the EV-steps you should be able to change this. Also, I'm unsure what is happening with the exposure. I can underexpose without any problem in manual mode. Can you provide more details?
11-02-2020, 08:29 AM   #6
Moderator
Not a Number's Avatar

Join Date: Mar 2012
Location: Venice, CA
Posts: 9,367
Yes, more information is needed. How are you trying underexpose?
11-02-2020, 08:47 AM   #7
Site Supporter
Site Supporter




Join Date: Aug 2018
Location: Arkansas, USA
Posts: 1,160
QuoteOriginally posted by grog85361 Quote
Check the Custom Menu item 2,"Sensitivity Steps"> If it is set to "1", ISO will adjust in 1EV steps, which is the condition you are seeing. Set it to "2", "As EV Steps", and ISO will adjust in the same steps as Custom Menu "1", EV Steps", which selects 1/2 EV or 1/3 EV steps. I hope this helps!
This!

11-02-2020, 12:38 PM   #8
New Member




Join Date: Feb 2017
Posts: 12
I don't know if this has anything to do with your problem, but remember also that the change from 800 to 1600 is as large as from 100 to 200. It's a logarithmic scale.
11-03-2020, 04:34 AM   #9
Veteran Member
SunnyG.'s Avatar

Join Date: Apr 2017
Posts: 428
Original Poster
QuoteOriginally posted by Aaron28 Quote
is it set to 1/2 or 1/3 ev steps? believe thats in the custom menu........also some things are not available at 1/2 step whereas 1/3 step allows i ferget what they are but remember having to change to 1/3 steps

don't know why you can't EV - for under expose......
I haven't touched the custom menu settings! I think there in the problem lies. Thanks for the suggestion

---------- Post added 11-03-20 at 04:35 AM ----------

QuoteOriginally posted by grog85361 Quote
Check the Custom Menu item 2,"Sensitivity Steps"> If it is set to "1", ISO will adjust in 1EV steps, which is the condition you are seeing. Set it to "2", "As EV Steps", and ISO will adjust in the same steps as Custom Menu "1", EV Steps", which selects 1/2 EV or 1/3 EV steps. I hope this helps!
Thank you! That's very helpful! Thank you for helping me!
11-03-2020, 08:18 AM - 1 Like   #10
Pentaxian
grog85361's Avatar

Join Date: Dec 2010
Location: Phoenix Arizona
Photos: Gallery | Albums
Posts: 854
QuoteOriginally posted by SunnyG. Quote
I haven't touched the custom menu settings! I think there in the problem lies. Thanks for the suggestion

---------- Post added 11-03-20 at 04:35 AM ----------


Thank you! That's very helpful! Thank you for helping me!
You are welcome! It's what we are here for
11-03-2020, 04:16 PM   #11
Pentaxian
Aaron28's Avatar

Join Date: Jan 2015
Location: Huntsville, Al
Posts: 6,860
QuoteOriginally posted by SunnyG. Quote
I haven't touched the custom menu settings! I think there in the problem lies. Thanks for the suggestion
cool good luck and report back success or fail......
11-04-2020, 12:07 PM   #12
Veteran Member
SunnyG.'s Avatar

Join Date: Apr 2017
Posts: 428
Original Poster
QuoteOriginally posted by Aaron28 Quote
cool good luck and report back success or fail......
Definitely will report back!
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, custom, ev, iso, k-50, menu, pentax help, photography, step, steps, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP! PENTAXIANS! HELP! Portland Oregon K-50 HELP! patrickhenryhague Visitors' Center 11 09-09-2018 05:23 PM
Help, help, help! I need a case, box, trunk... dansamy Pentax Camera and Field Accessories 13 02-18-2014 06:17 PM
For Sale - Sold: K-5, 16-50,50-135,65-250, Sigma 17-50, 50 1.4, 50 1.8, Tamron 90 2.8, Flashes virarfast Sold Items 8 04-04-2013 02:30 PM
Need Help on Pentax 90-WR Wireless Remote 35mm Camera...Need Help need.good.advice Pentax Compact Cameras 0 04-06-2011 06:57 PM
For Sale - Sold: SMC Pentax-A 50's: 50/2.8 Macro, 50/1.4, 50/1.7, 50/2 arpaagent Sold Items 14 01-16-2009 08:06 PM



All times are GMT -7. The time now is 03:04 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top