Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-23-2021, 04:23 PM   #1
Site Supporter
Site Supporter




Join Date: Nov 2017
Photos: Gallery | Albums
Posts: 550
OK, WB, Brightness, etc Buttons Not Working

I was out doing some moon pictures last night, and noticed that after I switched from timed to single shot, using the button above the OK button on my K-1, suddenly I couldnít shift out of that mode any longer using the shortcut. In fact, in viewfinder mode, none of the buttons around the OK button, and the OK button itself, are working. When I do live view, I can change my shot and my white balance etc., but when I do the viewfinder, all those buttons are acting as if they are disabled. When I go into the menus to adjust anything, it works just fine. This feels like a software issue, but I cannot tell why it would suddenly start happening. Iíve taken the batteries out for a moment and also used the reset option in the menu. Any ideas?

04-23-2021, 04:35 PM   #2
Loyal Site Supporter
Loyal Site Supporter




Join Date: Feb 2013
Location: Canada
Photos: Albums
Posts: 171
QuoteOriginally posted by jawats Quote
I was out doing some moon pictures last night, and noticed that after I switched from timed to single shot, using the button above the OK button on my K-1, suddenly I couldnít shift out of that mode any longer using the shortcut. In fact, in viewfinder mode, none of the buttons around the OK button, and the OK button itself, are working. When I do live view, I can change my shot and my white balance etc., but when I do the viewfinder, all those buttons are acting as if they are disabled. When I go into the menus to adjust anything, it works just fine. This feels like a software issue, but I cannot tell why it would suddenly start happening. Iíve taken the batteries out for a moment and also used the reset option in the menu. Any ideas?
Also happened to me once but could never figure out why hasnt happened since
04-23-2021, 04:38 PM   #3
Site Supporter
Site Supporter




Join Date: Nov 2017
Photos: Gallery | Albums
Posts: 550
Original Poster
QuoteOriginally posted by Kwong Quote
Also happened to me once but could never figure out why hasnt happened since
Did yours start working normally again after awhile?
04-23-2021, 05:01 PM   #4
Site Supporter
Site Supporter
Lowell Goudge's Avatar

Join Date: Jan 2007
Location: Toronto
Photos: Gallery | Albums
Posts: 16,769
Hit the function button above the 4 way controller, it toggles between different info screens. My K1 MKII is set to have the 4 way controller options in one info screen and af point selection in the other

04-23-2021, 06:02 PM   #5
Site Supporter
Site Supporter




Join Date: Aug 2018
Location: Arkansas, USA
Posts: 1,124
QuoteOriginally posted by Lowell Goudge Quote
Hit the function button above the 4 way controller, it toggles between different info screens. My K1 MKII is set to have the 4 way controller options in one info screen and af point selection in the other
Learned something new. Didn't know one could do that.
04-23-2021, 06:08 PM   #6
Loyal Site Supporter
Loyal Site Supporter




Join Date: Feb 2013
Location: Canada
Photos: Albums
Posts: 171
QuoteOriginally posted by jawats Quote
Did yours start working normally again after awhile?
yes and never happened again
04-23-2021, 06:35 PM   #7
Site Supporter
Site Supporter




Join Date: Nov 2017
Photos: Gallery | Albums
Posts: 550
Original Poster
QuoteOriginally posted by Lowell Goudge Quote
Hit the function button above the 4 way controller, it toggles between different info screens. My K1 MKII is set to have the 4 way controller options in one info screen and af point selection in the other
The toggle worked, but as soon as I made a selection, the AF point selection came back and the function options vanished. Iíd love if they stayed so I didnít have to hit the function to bring them up each time. Is there a way to make the functions the default?

---------- Post added 04-23-21 at 06:37 PM ----------

QuoteOriginally posted by Lowell Goudge Quote
Hit the function button above the 4 way controller, it toggles between different info screens. My K1 MKII is set to have the 4 way controller options in one info screen and af point selection in the other
Oh, and thank you for the help! I omitted that in my prior reply.

04-23-2021, 06:48 PM   #8
Site Supporter
Site Supporter
Lowell Goudge's Avatar

Join Date: Jan 2007
Location: Toronto
Photos: Gallery | Albums
Posts: 16,769
QuoteOriginally posted by DWS1 Quote
Learned something new. Didn't know one could do that.
It took me a year to figure that one out, donít feel too embarrassed
04-24-2021, 05:30 AM   #9
Site Supporter
Site Supporter
Kevin B123's Avatar

Join Date: Jul 2016
Location: Hampshire
Photos: Gallery | Albums
Posts: 2,301
It's the C20 type 2 setting to have AF default and the you press the function button above to use the other functions. Really handy, since you want af most of the time and the other functions are locked out.
04-24-2021, 11:16 AM   #10
Loyal Site Supporter
Loyal Site Supporter
Crooski's Avatar

Join Date: Feb 2013
Location: Rozenburg , Zuid-Holland
Photos: Gallery
Posts: 3,299
QuoteOriginally posted by jawats Quote
The toggle worked, but as soon as I made a selection, the AF point selection came back and the function options vanished. Iíd love if they stayed so I didnít have to hit the function to bring them up each time. Is there a way to make the functions the default?

---------- Post added 04-23-21 at 06:37 PM ----------



Oh, and thank you for the help! I omitted that in my prior reply.

Remove AF Active area from select and the four-way controller will work as it was before
04-25-2021, 05:01 AM   #11
Site Supporter
Site Supporter
Lowell Goudge's Avatar

Join Date: Jan 2007
Location: Toronto
Photos: Gallery | Albums
Posts: 16,769
QuoteOriginally posted by jawats Quote
The toggle worked, but as soon as I made a selection, the AF point selection came back and the function options vanished. Iíd love if they stayed so I didnít have to hit the function to bring them up each time. Is there a way to make the functions the default?
Youíre right

It would be preferable to have it go back to the selection screen, but .... it doesnít

However there are risks in both options, I have found myself failing to get focus only to discover that I have advertantly moved the focus point by accidental use contact of the 4 way controller, probably during review of past images, but I have also had the converse of accidentally changing the color options in JPEG, or WB on my K5 and K1 when it is set on the normal 4way controller settings.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
af, button, buttons, camera, controller, function, function button, info, k1, mode, options, pentax help, photography, screen, selection, shot, troubleshooting, viewfinder
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Illumination of buttons - not working for me GeeEmm Pentax K-1 & K-1 II 6 03-15-2021 03:22 AM
GRIII Macro and WB buttons not customizable Carlos_gr Ricoh GR 4 02-25-2020 11:29 AM
When camera is in "AF Active Area Select" how to use ISO, Flash, WB, timer buttons? Newtophotos Pentax DSLR Discussion 5 10-12-2015 06:23 AM
K-x tungsten WB is not a fixed WB kxr4trids Pentax DSLR Discussion 3 05-18-2010 12:43 AM
K-7's auto-WB vs. Lightroom's auto-WB inferno10 Post Your Photos! 13 07-16-2009 08:54 AM



All times are GMT -7. The time now is 02:51 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top