Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-16-2021, 11:47 AM   #1
Junior Member
DeerFat's Avatar

Join Date: Oct 2021
Posts: 26
Pentax K10D Keeps Crashing

So I bought a Used Pentax K10D as my first camera for a good deal.

Camera works like a charm! however... when putting the camera in a faster shutter speed it crashes? It also crashes when putting it into mode like: progrm automatic exposure, sensitivity priority automatic exposure, aperture priority auto exposure, and green mode.

Camera buttons don't work, top LCD is frozen and only way to make the camera work again is to take out the battery and put it back in.

I would love some input on what to do so that my camera will work properly, thanks!

10-16-2021, 11:56 AM - 2 Likes   #2
Moderator
Man With A Camera
Loyal Site Supporter
Racer X 69's Avatar

Join Date: Jun 2010
Location: The Great Pacific Northwet
Photos: Gallery | Albums
Posts: 24,740
QuoteOriginally posted by DeerFat Quote
So I bought a Used Pentax K10D as my first camera for a good deal.

Camera works like a charm! however... when putting the camera in a faster shutter speed it crashes? It also crashes when putting it into mode like: progrm automatic exposure, sensitivity priority automatic exposure, aperture priority auto exposure, and green mode.

Camera buttons don't work, top LCD is frozen and only way to make the camera work again is to take out the battery and put it back in.

I would love some input on what to do so that my camera will work properly, thanks!
Welcome to Pentax Forums.

Try doing a reset first. Then check the firmware, and if it isn't the latest update it.

Be sure the batter is fully charged when doing the firmware update.
10-16-2021, 01:39 PM - 1 Like   #3
Pentaxian




Join Date: Jan 2018
Location: Jersey C.I.
Photos: Albums
Posts: 1,392
QuoteOriginally posted by Racer X 69 Quote
Welcome to Pentax Forums.

Try doing a reset first. Then check the firmware, and if it isn't the latest update it.

Be sure the batter is fully charged when doing the firmware update.


All this ^^^ and can you try it with a different lens or even no lens at all, just in case it's the lens causing the problem. I'd also try formatting the card in the camera, if you haven't already done so.
10-16-2021, 02:12 PM - 1 Like   #4
Moderator
Not a Number's Avatar

Join Date: Mar 2012
Location: Venice, CA
Posts: 8,733
Try a new battery.

The mode dial(s) may have gone bad which is a weakness on this camera. Search the forum for K10D mode dial.

10-16-2021, 02:20 PM - 1 Like   #5
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 50,346
There is a date code on the battery. If it's about as old as the camera, you'll likely want to get a new one.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com server and development costs are user-supported. You can help cover these costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, KEH, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

10-16-2021, 03:32 PM   #6
Site Supporter
Site Supporter
ramseybuckeye's Avatar

Join Date: Apr 2009
Location: Hampstead, NC
Photos: Gallery
Posts: 14,577
You did not say how many batteries you have, if only one try a new battery and hope that is the problem. If that's not it try to get a refund because it could have a bad board.
10-16-2021, 04:22 PM - 2 Likes   #7
Junior Member
DeerFat's Avatar

Join Date: Oct 2021
Posts: 26
Original Poster
QuoteOriginally posted by Racer X 69 Quote
Welcome to Pentax Forums.

Try doing a reset first. Then check the firmware, and if it isn't the latest update it.

Be sure the batter is fully charged when doing the firmware update.
Camera is all fixed now, thank you so much!


and thank you to all the other reply's!

10-16-2021, 04:57 PM   #8
Moderator
Man With A Camera
Loyal Site Supporter
Racer X 69's Avatar

Join Date: Jun 2010
Location: The Great Pacific Northwet
Photos: Gallery | Albums
Posts: 24,740
QuoteOriginally posted by DeerFat Quote
Camera is all fixed now, thank you so much!


and thank you to all the other reply's!
You're welcome.

What did it take to get it functional again?
10-16-2021, 06:25 PM - 1 Like   #9
Junior Member
DeerFat's Avatar

Join Date: Oct 2021
Posts: 26
Original Poster
QuoteOriginally posted by Racer X 69 Quote
You're welcome.

What did it take to get it functional again?
It was just the firmware update, was on V1.30 updated to V1.31
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, crashes, exposure, k10d, mode, pentax, pentax help, pentax k10d, photography, priority, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Finally stopped my computer from crashing... hjoseph7 General Talk 4 03-09-2021 02:33 PM
Pentax KP crashing issues? StarTroop Pentax KP 9 03-27-2019 02:19 PM
People Series :: K10D goes for a walk.. and keeps delivering ! manntax Post Your Photos! 10 11-09-2013 11:32 AM
K10D Crashing when changing options in menu? jmdeegan Pentax DSLR Discussion 20 07-14-2008 08:34 AM
K100D menu and Fn failing/crashing off/LCD going black, Why? juliank100d Pentax DSLR Discussion 6 03-22-2008 12:01 AM



All times are GMT -7. The time now is 06:58 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top