Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-25-2023, 08:09 AM   #1
New Member




Join Date: Mar 2023
Posts: 2
Pentax K-5 Live View

Pentax cameras are still new to me and i just wanted to know the answer to the problem since i've never had one like this before.
Basically when using my K-5 in LiveView it has this delay like sluggish look i dont know is it really a problem or thats just the way this camera is?

03-25-2023, 09:58 AM   #2
Site Supporter
Site Supporter




Join Date: Mar 2007
Location: Christchurch, New Zealand
Photos: Gallery
Posts: 1,400
It's just the way the camera is. Newer cameras have a much faster auto focus in live view. The K-5 was an early live view canera.

Regards

Chris
03-25-2023, 11:01 AM   #3
Loyal Site Supporter
Loyal Site Supporter
robgski's Avatar

Join Date: Nov 2012
Location: Shenandoah Valley, Virginia
Photos: Gallery | Albums
Posts: 8,646
QuoteOriginally posted by Mazver Quote
Pentax cameras are still new to me and i just wanted to know the answer to the problem since i've never had one like this before.
Basically when using my K-5 in LiveView it has this delay like sluggish look I dont know is it really a problem or thats just the way this camera is?
I owned a K-5 until I damaged it, it has a very good autofocus system, even though it's a decade old.

A "sluggish look" is probably more a function of how many focus points you are using, whether you are using AF.S or AF.C, distance to the subject and how much the subject fills the frame as well as teh subjects or your movement, objects in the foreground, objects in the background, lighting, etc.

Start with a simple subject relatively close against a uniform background and use live view. You might also turn on the focus assist in Live View and try both autofocus and manual focus.
03-25-2023, 11:07 AM   #4
Site Supporter
Site Supporter




Join Date: Apr 2015
Posts: 3,478
QuoteOriginally posted by Mazver Quote
Pentax cameras are still new to me and i just wanted to know the answer to the problem since i've never had one like this before.
Basically when using my K-5 in LiveView it has this delay like sluggish look i dont know is it really a problem or thats just the way this camera is?
LV uses CDAF which by its nature is slower but possibly more precise than PDAF which is used with OVF
With PDAF speed is seen to be more important than other factors.

So it got to be that way!

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, k-5, pentax, pentax help, pentax k-5, photography, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K50 Exposure is much different from live view to view finder neptune Troubleshooting and Beginner Help 23 02-10-2018 09:07 PM
live view noise and smc dfa 100mm f2.8 macro lens not focusing in live view tommygunn84 Troubleshooting and Beginner Help 7 11-24-2016 08:59 PM
Typical live view humming, when not in live view. Unregistered User Pentax K-1 & K-1 II 8 05-05-2016 02:20 AM
K5 Live View: Live Exposure Adjustments Visible in "M" Mode? godwinaustin Pentax K-5 & K-5 II 6 08-13-2013 08:11 PM
View finder vs Live View on K5 II Wingincamera Pentax K-5 & K-5 II 5 12-08-2012 03:47 PM



All times are GMT -7. The time now is 10:24 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top