Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-15-2009, 02:27 PM   #1
Inactive Account




Join Date: Dec 2008
Location: North Carolina
Posts: 2
Broken Autofocus?

Hi, I hope it doesn't look too bad that my first post is asking for help. Haha.
My friend accidentally knocked my k200 off of a table. I picked it up and everything seemed to be okay, except that the 'input focal length' screen came up when I turned it on. My lens is a 50/1.4 FA and it had never done this before. The f-stop won't show up on the camera and I can't autofocus anymore.
It isn't a huge deal since I've had to learn how to manually do everything, but I'd like to know if this is a problem that is fixable without me having to bring it to a shop since there aren't any nearby. I don't have any other lenses, so I don't know if it is the lens or the body.
Thanks in advance. (:

03-15-2009, 02:43 PM   #2
Veteran Member
code4code5's Avatar

Join Date: Oct 2007
Location: Denver, CO
Photos: Gallery
Posts: 438
Have you tried taking the lens off of the body and putting it back on? It sounds like the lens isn't mounted well and the contacts aren't matching up. I'm sorry about the fall... that certainly makes the heart stop, doesn't it?
03-15-2009, 03:26 PM   #3
Kiz
Inactive Account




Join Date: Dec 2008
Location: North Carolina
Posts: 2
Original Poster
Yeah, it really did. It was second time it fell...The first time was worse, but nothing broke.
I've tried taking the lens off and putting it back on a few times. No dice.
03-16-2009, 12:48 PM   #4
Veteran Member
krypticide's Avatar

Join Date: Dec 2007
Photos: Gallery
Posts: 1,079
Check the contacts on the lens and the camera, and also make sure that the aperture ring on your FA50 didn't accidentally switch from A to a set aperture.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, lens, pentax help, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
My autofocus is broken? Please Help! marius Pentax DSLR Discussion 5 08-13-2010 05:30 AM
K7 Autofocus selection broken ? holdgaj Pentax DSLR Discussion 0 08-24-2009 07:19 AM
Broken dreams, broken camera brkl Post Your Photos! 3 03-10-2009 05:08 PM
For Sale - Sold: FS: Autofocus film cameras and autofocus lenses Not Registered Sold Items 15 03-17-2008 07:08 AM



All times are GMT -7. The time now is 04:51 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top