Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-19-2009, 01:39 PM   #1
Inactive Account




Join Date: Mar 2009
Posts: 2
Battery acting weird

So my Optio m20 is acting real weird. I put in some new batteries couple of days ago, and the battery cap is broken so usually it lies around with it open, anyway yesterday I got an error saying Battery depleted. turned itself off, I turned it on the battery indicator showed 3 green stripes. Took some pictures, the screen going off and on randomly, then suddenly the battery indicator had 0 stripes and had turned red. it shut down.

Is this normal when batteries are out? were my batteries old?
is my camera broke?

fyi I just got this camera from my uncle some days ago so this is all new to me.
oh and it wasnt new he had been usin it for awhile....

03-19-2009, 03:54 PM   #2
Veteran Member
AndrewG NY's Avatar

Join Date: Dec 2006
Location: Chappaqua, NY
Photos: Gallery
Posts: 677
It's possible that the batteries are old and aren't holding their charge long anymore--if you can recharge the batteries and the same thing continues to happen (works for a short time then dies quickly) it is somewhat likely that the battery is worn out. If you have a second battery that would be more easily verified. Personally I've always bought at least one extra battery for every camera I've owned because I don't want the camera dead in the middle of shooting, so usually want a spare.

If the camera won't power up at all after charging, then you might have a more serious problem.
03-20-2009, 09:51 AM   #3
Veteran Member
Ben_Edict's Avatar

Join Date: Jul 2007
Location: SouthWest "Regio"
Photos: Albums
Posts: 3,303
QuoteOriginally posted by loffen90 Quote
So my Optio m20 is acting real weird. I put in some new batteries couple of days ago, and the battery cap is broken so usually it lies around with it open, anyway yesterday I got an error saying Battery depleted. turned itself off, I turned it on the battery indicator showed 3 green stripes. Took some pictures, the screen going off and on randomly, then suddenly the battery indicator had 0 stripes and had turned red. it shut down.
What "battery cap" is broken? Dio you mean the door of the battery compartment of your camera? If that is the case, your experience simply sounds like bad contact, caused by the broken door. Perhaps you can fix that with some tape or a replacement door.

Ben
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
batteries, battery, camera, days, indicator, pentax help, photography, stripes, weird
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax battery charger d-bc50 acting strange CWyatt Photographic Technique 1 02-01-2010 03:56 PM
DA 17-70mm Acting Up? builttospill Pentax SLR Lens Discussion 11 12-01-2009 11:14 AM
lx is acting strangly. bensan9 Pentax Film SLR Discussion 3 09-19-2008 09:56 AM
Help, my K100D hot shoe flash acting weird! HermanLee Flashes, Lighting, and Studio 3 09-01-2008 05:41 PM
Battery grip causing weird readings? Inspection Guy Pentax Camera and Field Accessories 3 02-02-2008 09:25 AM



All times are GMT -7. The time now is 08:14 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top