Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-19-2009, 01:39 PM   #1
New Member




Join Date: Mar 2009
Location: upnorth, sweden ;)
Posts: 2
k100d super, lens problems (m42 to pentax K)

hello there fellow pentax owners!

not so long ago, I purchased my Pentax K100D Super with original 18-55 lens.

my interest grew and I acquired some different M42 lenses the other day,
so a "conversion ring" was purchased (m42 mount to pentax k mount)
everything fits just fine on the camera, but...

when I mount a M42 lens(with the "conversion ring" of course) the "av --" starts flashing on the screen at the trigger

how can I circumvent this problem?

// M0ppeN

03-19-2009, 02:00 PM   #2
Igilligan
Guest




In the custom menu

on the K100 I think it is using aperture ring or allow aperture ring.. select 2 Permitted...

That should stop the flashing and then when you turn on the camera it should ask for the lens length to set SR
03-19-2009, 02:10 PM   #3
Veteran Member




Join Date: Oct 2008
Location: Zagreb, Croatia
Posts: 370
read your camera's manual, for the beginning.

then, you'll find you have to switch "Using aperture ring" setting from "prohibited" to "permitted". you may also switch "FI with S lens used" from "Unavailable" to "Available".

i don't want to sound rude, this is fairly common question, and i really don't understand, is it so hard just to scan through the settings menu and fiddle a bit with various settings?
03-19-2009, 02:29 PM   #4
New Member




Join Date: Mar 2009
Location: upnorth, sweden ;)
Posts: 2
Original Poster
Many thanks to you Igilligan and elkarrde! problem solved!

now i can keep making textures

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, k100d, lens, m42, pentax, pentax help, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Autofocus problems with DA*16/50 and K100D Super jotarou1 Troubleshooting and Beginner Help 12 09-02-2009 09:48 PM
I found a Super-Takumar M42 screwmount lens...worth getting an adapter for K100d? maconmatt Troubleshooting and Beginner Help 17 08-17-2009 08:10 AM
My first m42 lens and having problems pcarfan Pentax DSLR Discussion 4 02-19-2009 05:21 AM
Best Pentax lens from a K100D Super? weirdnjfan1 Pentax DSLR Discussion 8 04-14-2008 12:30 AM
Problems with Pentax-A lens on K100D xs400 Pentax SLR Lens Discussion 5 10-31-2007 09:53 PM



All times are GMT -7. The time now is 12:17 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top