Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-13-2009, 11:09 PM   #1
New Member




Join Date: Jul 2008
Location: Poland
Posts: 5
K-7 strange not nice sound during starting up...

Hi,
can anybody hear a short unpleasant sound, when you turn on your camera?
Similar to checking DOF in K10D/K20D.

The reason, that I discovered, is this small aperture lever inside the camera, which very quickly shakes up and down....

Is that normal?

07-13-2009, 11:10 PM   #2
Damn Brit
Guest




It's the dust removal.

Last edited by Damn Brit; 07-13-2009 at 11:23 PM.
07-13-2009, 11:20 PM   #3
Veteran Member
heliphoto's Avatar

Join Date: May 2008
Location: Region 5
Photos: Gallery
Posts: 2,540
QuoteOriginally posted by Damn Brit Quote
It's the shake reduction.
Eh? Gary this sound like crazy talk mate...

Is it possible you've activated a dust removal on startup option? I've reading this sounds like a buzzing on startup vs. the old rapid clunking sound of the older models with the dust removal feature.

Edit: if you're seeing the aperture actuation lever shaking on startup, that would be weird, but I don't have my k7 yet so I can't say for sure.
07-13-2009, 11:24 PM   #4
Damn Brit
Guest




QuoteOriginally posted by heliphoto Quote
Eh? Gary this sound like crazy talk mate...

Is it possible you've activated a dust removal on startup option? I've reading this sounds like a buzzing on startup vs. the old rapid clunking sound of the older models with the dust removal feature.

Edit: if you're seeing the aperture actuation lever shaking on startup, that would be weird, but I don't have my k7 yet so I can't say for sure.
Oops! You know what it's like with a new baby Josh.
I've corrected my post, I knew what I meant.

07-13-2009, 11:30 PM   #5
New Member




Join Date: Jul 2008
Location: Poland
Posts: 5
Original Poster
QuoteOriginally posted by Damn Brit Quote
It's the dust removal.
No, this is definetely NOT the dust removal. The dust removal in K-7 is nearly soundless, however you can hear a very high tone from the inside of the camera.

QuoteOriginally posted by heliphoto Quote
Edit: if you're seeing the aperture actuation lever shaking on startup, that would be weird, but I don't have my k7 yet so I can't say for sure.
Yes, I can see it. That's why I'm asking K-7 owners.
07-13-2009, 11:31 PM   #6
Damn Brit
Guest




QuoteOriginally posted by Samp Quote
No, this is definetely NOT the dust removal. The dust removal in K-7 is nearly soundless, however you can hear a very high tone from the inside of the camera.
I made a booboo, see above.
07-13-2009, 11:47 PM   #7
New Member




Join Date: Jul 2008
Location: Poland
Posts: 5
Original Poster
BTW, I'm not the Pentax Beginner....

I use Pentax since 1998, I own ME Super, MZ-3, i also owned MZ-6, K10D and K20D... I really know what I'm writing about.

Here I found a post describing similar problem:
http://forums.dpreview.com/forums/read.asp?forum=1036&message=32353530
07-14-2009, 03:10 AM   #8
Veteran Member
Christopher M.W.T's Avatar

Join Date: Jun 2009
Location: Geelong, Victoria, Australia
Posts: 1,689
I heard it to, then realised its the ultrasonic dust cleaner....trust me, ultrasonic ie HIGH frequency!

07-14-2009, 03:42 AM   #9
New Member




Join Date: Jul 2008
Location: Poland
Posts: 5
Original Poster
It's NOT the dust cleaning, dust cleaning sound is AFTER that strange one – it's a specific high frequency whistle. I recognize it.

I'm afraid somethings wrong with the ON/OFF switch. It simply tries to check DOF, each time when its being turned on. Also when camera goes to "sleep mode" and wakes up, the same event appears.
07-14-2009, 08:10 AM   #10
Veteran Member
Dr_who's Avatar

Join Date: Jun 2009
Location: Edmonton, Alberta, Canada
Photos: Gallery | Albums
Posts: 690
I did the dust removal option when the lens was off and it does get pretty high when you do that.
07-14-2009, 08:45 AM   #11
Veteran Member
GLXLR's Avatar

Join Date: Feb 2009
Location: Sugar Land, TX
Photos: Gallery
Posts: 686
QuoteOriginally posted by Samp Quote
Hi,
can anybody hear a short unpleasant sound, when you turn on your camera?
Similar to checking DOF in K10D/K20D.

The reason, that I discovered, is this small aperture lever inside the camera, which very quickly shakes up and down....

Is that normal?
Make a video so we can hear/see it. Might help you get a better answer.
07-14-2009, 08:59 AM   #12
Forum Member




Join Date: Sep 2007
Location: Germany / BaWŁ
Posts: 50
theres a thread about the same "problem" in a german forum.

it really is the aperure lever. if you have a lens on while turning the k7 on, the aperture of the lens opens and closes, too.

the OP asked pentax about this behaviour and they replied, that it would be normal and part of the new way how the aperture is controlled (somehow electronically instead of mechanical). this is needed because of the aperture control in video mode.
07-14-2009, 11:28 AM   #13
New Member




Join Date: Jul 2008
Location: Poland
Posts: 5
Original Poster
OK, I checked another K-7 in the nearby store and it behaves in similar way.
Moreover, I discovered that changing the aperture in LV or Movie mode causes the same sound. It's not related to SRII, it's simply just the aperture lever inside the body.

So, there's nothing to worry about, however this sound is quite unpleasant.
07-14-2009, 11:36 AM   #14
Veteran Member
GLXLR's Avatar

Join Date: Feb 2009
Location: Sugar Land, TX
Photos: Gallery
Posts: 686
QuoteOriginally posted by Samp Quote
OK, I checked another K-7 in the nearby store and it behaves in similar way.
Moreover, I discovered that changing the aperture in LV or Movie mode causes the same sound. It's not related to SRII, it's simply just the aperture lever inside the body.

So, there's nothing to worry about, however this sound is quite unpleasant.
The aperture level is a high pitched sound? For my GX-10 (K10D) it sounds more like a tiny *clunk*.

Either way, I don't think it is a big problem, but if it bothers you, go check ANOTHER store and/or exchange for another K-7. Not worth it if it's going to bother you (like my loose 50-135mm focus ring)
07-14-2009, 11:51 AM   #15
Pentaxian
Ratmagiclady's Avatar

Join Date: Nov 2008
Location: GA
Photos: Gallery | Albums
Posts: 13,476
Thought: People have different abilities to hear high-frequency sounds, ...I wonder if those who are hearing it happen to be the youngest.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, pentax help, photography, sound
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Best starting lens? Cheap body and nice lens? or nice body and okay lens? lovemehate Troubleshooting and Beginner Help 52 10-12-2010 07:27 PM
Landscape nice house... nice boat.... dcmsox2004 Post Your Photos! 7 08-18-2010 02:49 PM
Nice... real nice SCOTUS jeffkrol General Talk 45 04-22-2010 08:41 AM
K-m (K2000) strange shutter sound wicked Shimmy Pentax DSLR Discussion 4 12-11-2009 03:44 PM
This might sound strange photolady95 Photographic Technique 26 09-30-2009 07:47 PM



All times are GMT -7. The time now is 12:33 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top