Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-29-2009, 05:36 PM   #1
Inactive Account




Join Date: Aug 2009
Location: Down south
Posts: 7
Help please Pentax ZX-M

Hi everyone, I'm new here. My Pentax's are a MV and ZX-M.The trouble is that the shutter sticks on the MV when set on Auto.To release the shutter I have to change setting to 1/100 or B. My ZX-M shot well until recently.Was shooting a roll of 400 24 exposure and after the 12th shot the ZX-M Auto rewind kicked in. Ever since then when I load film and turn to ON the camera eats the film. Will not advance to first exposure. I hope that this makes sense I am a newbie. Really love these cameras and hope some kind person will address these issues. Going crazy because the price of film and once loaded and turned to ON the film is GONE. Any suggestions? Thanks for your time!!

08-30-2009, 09:58 AM   #2
Pentaxian




Join Date: Sep 2007
Location: Bay Village, Ohio USA
Posts: 1,035
MV Shutter

It sounds like the battery in the MV might be dead. I don't have an MV, but I do have its cousin, the ME Super. The battery is used only for the meter and electronically controlled shutter. It is designed so that it can be used in B and at 1/100 second without battery power. Try a new battery.


The ZX-M sounds more serious. I can't help you there. There's a guy named Eric Hendrickson who has an excellent reputation for repairing Pentax cameras. His website is Home. However, it might be more cost-effective to replace the camera. ZX-M's are readily available on eBay for around $50, which is probably less than the repair cost.


Paul Noble
08-31-2009, 06:09 AM   #3
Veteran Member
MJB DIGITAL's Avatar

Join Date: Jul 2007
Location: st. louis
Posts: 1,173
better in the 'film slr' forum
09-01-2009, 06:05 AM   #4
Inactive Account




Join Date: Aug 2009
Location: Down south
Posts: 7
Original Poster
QuoteOriginally posted by noblepa Quote
It sounds like the battery in the MV might be dead. I don't have an MV, but I do have its cousin, the ME Super. The battery is used only for the meter and electronically controlled shutter. It is designed so that it can be used in B and at 1/100 second without battery power. Try a new battery.


The ZX-M sounds more serious. I can't help you there. There's a guy named Eric Hendrickson who has an excellent reputation for repairing Pentax cameras. His website is Home. However, it might be more cost-effective to replace the camera. ZX-M's are readily available on eBay for around $50, which is probably less than the repair cost.


Paul Noble
Hi and thank you for the reply. The MV has two batterys. The thing that gets me is that while In Auto mode the light meter shows on the left side of the view finder. I figure that the battery would still be OK. I'LL try the batterys, also if it still has the same results as before should I have the shutter cleaned and oiled. I hope that this the right tech phrase and if so could you give a ballpark figure on cost? The ZX-M isn't really priority, I like metal not plastic.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, exposure, film, hope, mv, pentax help, photography, shot, shutter, zx-m
Thread Tools Search this Thread
Search this Thread:

Advanced Search



All times are GMT -7. The time now is 09:58 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top